Announcement

Collapse
No announcement yet.

Team Foundation Server - Source Control Integration

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Steps

    I start beyond compare, and go to the SCI options area. Then I add my Source control project mapping, see "ss1.jpg" and "ss2.jpg"

    then i do a comparison w/ files under my source control tree. I am prompted to connect to a TFS server the first time, see "ss3.jpg"
    and then am immediately greeted w/ the problem addressed by this thread, see "ss4.jpg," on each and every comparison involving a file under the source tree from here on out

    If i disable SCI, i am able to compare the same files w/ no error prompts.

    If indeed this is an error thrown to us by TFS, then I am curious as to what's causing it. Our entire development team has no source control issues w/ either VS.net 2005, 2008, 2010, or the TFS powertools shell extension. BC is the only one that exhibits this behavior.
    Last edited by bc3tech; 24-Jun-2009, 07:32 AM. Reason: spelling

    Comment


    • #17
      Is it a conflict between BC3 integration and the TFS Windows Shell Extensions? Have you tested it on a system that does not have the TFS Windows Shell Extensions in place?
      BC v4.0.7 build 19761
      ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ

      Comment


      • #18
        Originally posted by Michael Bulgrien View Post
        Is it a conflict between BC3 integration and the TFS Windows Shell Extensions? Have you tested it on a system that does not have the TFS Windows Shell Extensions in place?
        uninstalled shell extensions, re-set up BC3, same thing happens.

        Comment


        • #19
          Hello,

          Can you create and email your BCSupport package (Help menu -> Support; Export) to support@scootersoftware.com

          Please include a link to this forum post, and make sure the Support package includes your BCPrefs.xml. If it does not include the BCPrefs.xml you should be able to manually get it by going to the Help menu -> Support; click the blue link to Explore your settings folder, then grab it from there.
          Aaron P Scooter Software

          Comment


          • #20
            has this issue been resolved as I also get the error message

            "The string must have at least one character.
            Parameter name: name"

            every time, after a (hidden under VS) popup asking for my TFS server.

            Comment


            • #21
              I tried searching for an email from this registered user but did not find one.

              Are you using the latest BC3 install (3.1.7)? Were you able to try some of the above troubleshooting steps? Such as trying it on another machine, or one without TFS Windows Shell extensions?
              Aaron P Scooter Software

              Comment


              • #22
                I have this issue too. Have read all the previous posts and seem to have done everything I can think of.
                I am using VS2008 TS - but also have VS2005 installed for older projects. Our TFS server appears to still be at version 2005 (not upgraded to 2008).

                I have tried installing (mutually exclusively) both "Visual Studio Team Foundation Server MSSCCI Provider" (VS 2005) and "Visual Studio Team System 2008 Team Foundation Server MSSCCI Provider". I set up the workspace from the tools menu.
                In both cases when from Windows Explorer I try to compare two files in the workspace folder tree I get a little message box saying:

                "The string must have at least one character.
                Parameter name: name" [OK]

                After clicking OK there are no context-menu options or anything to allow source control manipulation.
                Comparing files outside the workspace folder causes no problems....

                Is there a resolution for this issue yet ?

                Comment


                • #23
                  I have never been able to reproduce this problem. Is it possible that you are running TFS in workgroup authentication mode? Do you have to enter your user credentials every time you open Source Control Explorer?

                  If you've installed TFS on a server that not part of an Active Directory domain, then perhaps your user credentials are not being authenticated properly.

                  Windows (XP/Vista/2003) has a feature that allows you to store a "network credential" in the OS for servers you access. If you have TFS running in workgroup authentication mode, try this:

                  1. Go to: Windows Start menu | Control Panel | User Accounts
                  2. You should see the User Accounts dialog. Select your user ID
                  3. Click on Advanced Tab -> Manage Passwords
                  4. Click on Add, provide the TFS server name, your user ID and Password, click OK.
                  BC v4.0.7 build 19761
                  ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ

                  Comment


                  • #24
                    Originally posted by Michael Bulgrien View Post
                    I have never been able to reproduce this problem. Is it possible that you are running TFS in workgroup authentication mode? Do you have to enter your user credentials every time you open Source Control Explorer?
                    no. this is our corporate domain.

                    Comment


                    • #25
                      I also have this issue.
                      I have TFS 2008, VS 2008, I'ce def'ly got the 2008 MSSCCI, and get exactly the same error message and no src control integration, which is very annoying.
                      I'm running on Vista 64bit, and in a corporate domain, and dont get asked for a log in to the TFS src control.

                      Comment


                      • #26
                        Same issue here. Windows 7 64bit, VS 2008, 2008 MSSCCI, corporate domain. Using 3.1.10 (build 11626).

                        Comment


                        • #27
                          Is this the root cause? This work-around worked for me.

                          I recently moved to Windows 7 and VS2010 from Vista and VS2005 and started getting the "string must have..." error since the new box had different mappings. I found that if I mapped to the root of TFS I would get the error (e.g. Project = $/) If I switched to mapping to subprojects (e.g. $/Projects and $/Prod, etc.) the error went away and I could use source control in BC.

                          I switched back and forth and could easily re-create the problem if $/ was mapped.

                          Comment


                          • #28
                            Originally posted by JimW View Post
                            Is this the root cause?
                            Thanks Jim... perhaps that will turn out to be the common thread. I've never seen the error on my system... but then again... I've never mapped directly to the TFS root.
                            BC v4.0.7 build 19761
                            ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ

                            Comment


                            • #29
                              Originally posted by JimW View Post
                              Is this the root cause? This work-around worked for me.

                              I recently moved to Windows 7 and VS2010 from Vista and VS2005 and started getting the "string must have..." error since the new box had different mappings. I found that if I mapped to the root of TFS I would get the error (e.g. Project = $/) If I switched to mapping to subprojects (e.g. $/Projects and $/Prod, etc.) the error went away and I could use source control in BC.

                              I switched back and forth and could easily re-create the problem if $/ was mapped.
                              nice troubleshooting... however what are we expected to do if we work w/in multiple projects of TFS? kind of a pain to keep switching it if you're BC'ing between the projects. But maybe it'll give the scooter guys something to check out and get this thing solved once & for all

                              Comment


                              • #30
                                Originally posted by bc3tech View Post
                                what are we expected to do if we work w/in multiple projects of TFS? kind of a pain to keep switching it if you're BC'ing between the projects.
                                I agree. That is precisely why I made the following recommendation earlier in this thread:

                                Originally posted by Michael Bulgrien View Post

                                Observations for the Scooter Team:
                                1. ...
                                2. ...
                                3. I have more than one workspace defined in Visual Studio Source Control Explorer. If I define multiple entries in the BC3 Source Control Integration (one for each defined workspace) then BC3 only manages one of the workspaces per session. In other words if I compare two folders, each under a different source control workspace, the source control context menu only comes up for one side of the compare even though both sides are under source control. I've reported this issue before. It would be nice if BC3 had the ability to switch workspaces on-the-fly. In other words, if the user activates a folder compare pane that points to a different folder under Source Control Integration (i.e. a path under a different Source Control association but using the same TFS server) BC3 should disconnect from the TFS server then reconnect to activate the integration for the new workspace. Note that workspaces cannot overlap...so no local folder will ever fall under two different TFS workspaces.
                                Additional comments were appended in this post.
                                Last edited by Michael Bulgrien; 10-May-2010, 09:46 PM.
                                BC v4.0.7 build 19761
                                ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ

                                Comment

                                Working...
                                X