Announcement

Collapse
No announcement yet.

Automatic Text Merge not wanted

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Automatic Text Merge not wanted

    I am running Beyond Compare 3 and the BeyondCVS Eclipse plugin on the MAC OS X. I am using Wine Bottler on the MAC to run Beyond Compare. When I open "Compare with" in Eclipse and Beyond Compare opens up, for some reason it always goes into text merge mode. I would like it to go into text compare. I have looked online and I have not found out how to have it open up text compare by default. I really only need text compare. I had read somewhere that this setting is in the default sessions of Beyond Compare but I have not found it. Is there a way to make Beyond Compare default to Text Compare? If it opens up in Text Merge do I then go into Text Compare with the same files?

  • #2
    Hello,

    BeyondCVS is not written by Scooter Software, but we may be able to help with some pointers. Is there any kind of configuration you would have access to, where you can override the default BeyondCVS settings?

    Which option are you using in the Compare With submenu? When it automatically opens from Compare With, is the Text Merge launching and showing 2 inputs and an empty output? Or is the output defined, or are there 3 inputs?

    Which version of Beyond Compare 3 and BeyondCVS are you using?
    Aaron P Scooter Software

    Comment


    • #3
      Hello Aaron,

      Thanks for the reply. I am using Beyond Compare 3 and Beyond CVS org.eclipse.externaltools-Update-0.8.9.v201003051612.zip (this is the latest version on the website).

      For the BeyondCVS settings, If I go to Eclipse -> Preferences -> External Tools -> Beyond Compare there is a settings screen there. The settings are as follows:
      -Path to Beyond Compare
      -Stored Session Name
      -Show debug info (checkbox)
      -Close the 'Compare With Revisions' dialog after compare (checbox)
      -Three way compare selected (checkbox)
      -Temporary directory for CVS/SVN files

      All the checkboxes are unchecked.

      For Compare With, I am doing Compare With -> Latest Revision (Beyond Compare). Text Merge launches and I see two panes at the top with the 2 files and an empty pane at the bottom (I assume that would be the empty output).

      Comment

      Working...
      X