Announcement

Collapse
No announcement yet.

3-way merge - Grammar not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aaron
    replied
    Hello,

    If you can post or email a screenshot of the Text Merge session in the graphical interface showing the current inputs and outputs (along with sample files, if you can) and with your BCSupport.zip from the Help menu -> Support; Export, we can help investigate further.

    If you email us at support@scootersoftware.com, please also include a link back to this forum thread.

    Leave a comment:


  • rv1990
    replied
    Hi Aaron,

    I did as you suggested , but it is not working.
    The header sections are getting merged each time.

    In command line i used this command :
    "BComp.exe /automerge /reviewconflcts $left $right $center /mergeoutput=$center"

    The headers i created during lit preparations are there and even unchecked , but i am not getting proper solution.

    I even tried favorleft option but nothing is happening in my favor.

    Waiting for your reply..

    Leave a comment:


  • Aaron
    replied
    Hello,

    If you go to the Home screen, and in the saved sessions list, expand the Edit session defaults folder, select Text Merge, and in the Importance tab, are your items unchecked? If not, uncheck and save to update the defaults to mark the grammars as unimportant for new Text Merge sessions. Repeat for the Text Compare session type.

    Does this clear up the behavior you are running into?

    Leave a comment:


  • rv1990
    started a topic 3-way merge - Grammar not working

    3-way merge - Grammar not working

    I made some grammars for 2 way folder comparisons. Those grammars are used to ignore some unimportant differences like header sections , etc.
    Using this i prepare a list of changed files.

    Now when i am using 3-way merge using command line , the grammars are not working in this case . it is not ignoring them . I didn't use the /ic in cmd as it will also discard some valuable changes of mine.

    How can i make my grammars available for 3-way merge so that after the merge the contexts which i ignored during list preparation i.e header sections in file ,are not getting merged in my final file.
Working...
X