Announcement

Collapse
No announcement yet.

Change to default encoding not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Change to default encoding not working

    Iím doing a two-way text compare by selecting two files from the right click menu in Windows Explorer. Initially, it was taking > 7 seconds to open the file differences window. After looking in the forum I found the suggestion to switch the encoding option from "Detect" to "ANSI".Ē This worked very well and my compare went from > 7 seconds to .45 seconds for that session.

    So I decided to change the default for all COBOL files. I selected Tools, File Formats, clicked on COBOL source and set the encoding option to ANSI instead of detect. I also set the default for Text Format encoding to ANSI instead of detect and saved my changes. However, when I select two COBOL files for compare, it ignores my ANSI default and still uses detect. The files are recognized correctly as COBOL but I canít seem to get it to default to ANSI. If I click on the dropdown beside ANSI for either the left or right side it says ďDonít OverrideĒ. If I go into Tools, File Formats for COBOL my default says ANSI so I know it saved my changes. It just doesnít seem to be using them. Am I missing something?

    I'm using the trial version of Beyond Compare 3 - v3.3.5 on Windows 7.

  • #2
    Hello,

    Given this description, changing the option in the File Formats dialog should work. The files are detected as using the COBOL format in both panes (via the View menu -> File Info status bar), correct? Each pane can be independently detected for a file format, so it would be important that both were detecting/using COBOL.

    Which forum post would you be referencing? Do you have a link?
    Aaron P Scooter Software

    Comment


    • #3
      The link was in a thread under a performance issue. See below:

      http://www.scootersoftware.com/vbull...ead.php?t=5828

      Suggestions were from Craig.

      Comment


      • #4
        Are both panes detecting as COBOL (upper status bar of each pane)? A full screen screenshot would help.
        Aaron P Scooter Software

        Comment


        • #5
          Yes. Both panes are detected as COBOL and both have encoding as Don't override. I couldn't get a screenshot of the dropdown opened, however I verified both sides.

          Also I've included a screenshot of my settings for file format COBOL.
          Last edited by cwill; 12-Feb-2013, 08:01 AM. Reason: Remove attachment

          Comment


          • #6
            Would it be possible to get a copy of these files emailed to support@scootersoftware.com ? Please also include a link to this forum thread for our reference, and your BCSupport.zip from the Help menu -> Support; Export.

            Are you on a US/English Windows install, or do you have a different default encoding?
            Aaron P Scooter Software

            Comment


            • #7
              After exchanging a couple of emails it was determined that Beyond Compare is actually behaving as it should. I received the following explanation from Scooterís Chris K.

              "Don't Override" doesn't mean that Beyond Compare is auto-detecting the character encoding. It means the current session isn't overriding the character encoding that you've set in the file format. If you change the character encoding to ANSI in the session rather than the file format, then you'll see "ANSI" listed rather than "Don't Override". The summary is, as long as you have ANSI set in the file format, it will open the files as ANSI rather than detect the character encoding.

              Thanks to Chris for clearing this up. The compare seems to be slower on initial load than when re-running the compare from within Beyond Compare, which led me to believe auto detect encoding (which I had turned off for the re-run) was causing my performance issue. After additional testing it was determined that one of the grammar items was causing the performance slowdown. Iíve deleted the grammar item and performance is now similar to what was seen with version 2.

              Comment

              Working...
              X