Announcement

Collapse
No announcement yet.

Why does Beyond Compare wrap my line before encountering the newline?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Why does Beyond Compare wrap my line before encountering the newline?

    Hello,

    I have Beyond Compare version 4.2.9 (build 23626).

    I'm seeing some strange line wrapping behavior from BC4. Every time I open the attached (BeyondCompare.txt) file. I see lines 2 and 3 wrap. But line 1 seems fine. I've also opened the same file using another text editor with no line wrapping and included a screen capture for reference.

    Click image for larger version

Name:	LineWrappingIssue.png
Views:	61
Size:	109.9 KB
ID:	81006

    My expectation is for beyond compare to not wrap the lines until encountering the carriage return newline.

    Am I reaching the limits of a line buffer?
    Attached Files
    Last edited by IChickenNugget; 03-Jul-2019, 04:05 PM.

  • #2
    Replacing the tab near the beginning with a space produces the same results, and the order of the lines doesn't matter.

    With a space instead of tab, it is clear what is happening:

    The first line has 4096 characters before the CR/LF and is not wrapped.
    The second line has 4097 characters before the CR/LF and the last character is forced onto a new line.
    The third line has 4112 characters before the CR/F and the last 16 characters are forced onto a new line.

    The pattern is consistent with Beyond Compare's Text Compare limiting the line length to 4096 characters, with any text beyond that pushed onto a new line.

    This is not a fixed limit: there is a setting for the maximum line length in Tools > File Formats, which defaults to 4096 characters per line. You can set it differently for each text-based file format, on the Conversion tab. (There is no corresponding setting for table-based file formats such as CSV.)

    Comment


    • #3
      Originally posted by dempson View Post
      This is not a fixed limit: there is a setting for the maximum line length in Tools > File Formats, which defaults to 4096 characters per line. You can set it differently for each text-based file format, on the Conversion tab. (There is no corresponding setting for table-based file formats such as CSV.)
      This is what I was looking for.

      Thanks.

      Comment

      Working...
      X