Announcement

Collapse
No announcement yet.

Disable line alignment

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disable line alignment

    How to disable line alignment, i.e I want to see to files side by side with
    red marked different lines between them without BC tries to align them.
    For example:


    0 1
    1 1
    1 0
    0 0
    0 0

  • #2
    Hello,

    In the Text Compare:
    Go to the Session menu -> Session Settings, Alignment tab. Manually type in '1' for the skew tolerance.

    How does that work for you?
    Aaron P Scooter Software

    Comment


    • #3
      Worked perfectly for me , thanks.

      Comment


      • #4
        When comparing excel files (.xlsx) I dont get the Alignment tab in the session setting (using BC Version 4.0.7). Is there a way to disable the alignment (or do a manual alignment, that option also seems to be gone) when comparing excel files?

        Comment


        • #5
          Hello,

          BC 4.2+ have added Alignment Settings. All 4.x updates are free for 4.x users, so you could update to the latest BC 4.2.10 to get this feature.

          This thread is specific for the Text Compare, which does have the Alignment options (but does not sort by Key). You can open Excel files in the Text Compare with an additional downloaded format:
          http://www.scootersoftware.com/downl..._moreformatsv4

          In the Tools menu -> File Formats, whichever *.xlsx format is higher on the list is used by default (where the icon represents the Viewer used: Purple table sheet for Table Compare, and White paper for Text Compare).
          Aaron P Scooter Software

          Comment


          • #6
            I should add that, out of the box, the Table Compare sorts and aligns by the Key column, which is column 1 by default. You can right click any column(s) to set as Key, Standard, or Unimportant. Multiple Keys together form the whole Key, ie: FirstName + LastName columns
            Aaron P Scooter Software

            Comment


            • #7
              Thanks, I removed the key column settings, and I also had to go to Session Settings... "Columns" tab and check the box "Unsorted Alignment". That seems to do the job, at least with the files I'm comparing.

              Comment

              Working...
              X