Announcement

Collapse
No announcement yet.

BC3 Installation - Uninstallable - Cannot Install libc6:i386

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aaron
    replied
    What steps did you follow? Running the .deb with the default graphical installer app does attempt to add the shortcuts to the launcher.

    Also, try rebooting and then checking to see if the item then appears in your Programming menu or if you search "beyond".

    Leave a comment:


  • raywood
    replied
    Done! And now, how to run it? I know about entering bcompare on the command line (which entails leaving Terminal open until I'm ready to close Beyond Compare. But does installation add a launcher anywhere in the panel?

    Leave a comment:


  • Chris
    replied
    Linux Installation Instructions: https://www.scootersoftware.com/down..._linux_install

    Leave a comment:


  • raywood
    replied
    OK. I upgraded. I downloaded bcompare-4.3.7.25118_amd64.deb. I am having a hard time finding the installation guide. Contents, Index, and Search at the support page turn up nothing for install. Kindly give me a nudge in the right direction.

    Leave a comment:


  • Chris
    replied
    Beyond Compare 3 for Linux is not compatible with Ubuntu 20.04, you'll need to upgrade to Beyond Compare 4.

    Ubuntu 16.04 is the newest OS version that supports Beyond Compare 3.

    Linux distribution compatibility: https://www.scootersoftware.com/down...hp?zz=kb_linux

    Leave a comment:


  • raywood
    replied
    Hi, Aaron. I don't really need BC 4. I've got an old license, so it's not free. I'll go there if I have to, but if possible I'd like to try to make it work as is. I'm installing on Ubuntu 20.04.

    Leave a comment:


  • Aaron
    replied
    Hello,

    Which OS and OS version are you trying to install to?
    BC3 is a 32bit application, so it would require your Linux OS to support 32bit backwards combability libraries. Some are better at handling this than others.

    If it's an option, I'd suggest evaluating BC4, which added native 64bit as part of BC 4.1 in 2015. All 4.x updates are free for 4.x users, or you can trial BC 4.3.7 to see how it works on your system before purchase is necessary:
    https://www.scootersoftware.com/download.php

    If you are a registered BC3 user, you may qualify for an upgrade discount (usually free or half price) which you can calculate here:
    https://www.scootersoftware.com/shop...=upgradepolicy

    Leave a comment:


  • BC3 Installation - Uninstallable - Cannot Install libc6:i386

    I ran
    Code:
    sudo dpkg --add-architecture i386
    and
    Code:
    sudo apt-get update
    and
    Code:
    sudo-apt-get install gdebi-core
    .

    I downloaded bcompare-3.3.13.18981_i386.deb. I tried installing it by clicking on it in Downloads. I got this:

    Unable to intall bcompare:
    The following packages have unmet dependencies:
    It doesn't display what the dependencies are.

    Code:
    sudo apt-get -f install
    produces "0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded."

    Code:
    sudo gdebi bcompare-3.3.13.18981_i386.deb
    produces "gdebi error, file not found."

    The same command, executed in the Downloads folder, produces "This package is uninstallable. Cannot install 'libc6:i386'."



Working...
X