No announcement yet.

BC3 slow to start under OpenSuse 11.3 / 12.1

  • Filter
  • Time
  • Show
Clear All
new posts

  • BC3 slow to start under OpenSuse 11.3 / 12.1

    Hi guys,

    Another Q in the back of my mind lately is why is Beyond Compare a bit slow to load on startup on my Linux systems. This is occuring both on my work pc (opensuse 11.3) and my home pc (opensuse 12.1).

    I recall this app would start up lightning fast in Windows. I thought it may be due to the Windows OS caching a previously used application into memory so that it loads faster the 2nd time you try to run it.

    So I thought perhaps Linux didn't have this ability, but googling online, one forum is telling me that it does.

    Nonetheless, I am noticing the following:
    • Starting up BC3 is taking about 7-8 seconds on both my work/home PCs (both with fairly high specs)
    • After running bcompare once, I can minimise that window. Then if I run bcompare again, the new window appears instantaneously.

    So in the meantime, this is what I've been doing to get around this problem. I just leave a copy of BC3 running minimized, then whenever I need to diff something, the 2nd instance of the app will appear instantly.

    I can get by this way, but just wanted to mention it. Do other Linux users experience this too?

  • #2
    Originally posted by Gurce View Post
    why is Beyond Compare a bit slow to load on startup on my Linux systems
    It takes about two seconds to load in Kubuntu on a computer that's less than a year old.

    I don't remember how long it took in MS Windows but even if it's slower to load now, one thing I've noticed is that disk operations are MUCH faster in Linux than MSWin ever was (not just with BC). My folder compares and syncs are lightning fast unlike in MSWin.


    • #3

      I've run a couple quick tests of our start up speed in a virtual machine of OpenSUSE 11.3 64bit. BC3 seemed to open pretty quickly in 1-3 seconds, and that was as a virtual machine.

      Do you notice it launches faster if you disable the check for updates, in the Tools menu -> Options, Startup section?
      Aaron P Scooter Software


      • #4
        Thanks for looking into. I tried disabling the auto-update, didn't have any affect on my startup time.

        Hmm, interesting. I tried installing OpenSUSE 12.1 on a virtual-machine just now, and got the same results as you! It is starting up in 2 seconds.

        This surprised me, as several openSUSE machines here, my own and that of colleagues, my home pc, were all experiencing the 7 second delay.

        Perhaps it is due to some detail in how we set up our pc's here, perhaps some package/s we use for our development here are interfering.

        I'll slowly install such elements into this virtual-machine, testing bcompare run times along the way and see if I can find the culprit. If I find anything interesting, will add further info here.


        • #5
          That would be much appreciated. Please keep us posted.
          Aaron P Scooter Software


          • #6
            Ah, apologies, it turned out to be due to an internal java tool we use that triggers a new Beyond Compare process when it wants to do a diff. I noticed the following:
            • If we tell our internal java tool to use "bcompare" as the external diff'ing app, we experienced the 7-second delay.
            • If we tell our internal java tool to instead use "/usr/bin/bcompare", we get the more palatable 2 second delay.

            Not sure of the difference why, perhaps the java tool was having a harder time searching for it in all the potential path folders?! <shrug>

            Anyway, glad that problem's out of the way... Although... Maybe I'm being a little greedy and impatient here, but part of me still can't stand waiting 2 seconds!

            I'd prefer it to open up instantaneously, so for now, I'll still keep an instance of bcompare opened prior to doing other diff's, just to assure I see the diff instantly.

            Perhaps this'd be a nice suggestion for future versions, the option of allowing Beyond Compare to remain running in the background, minimised to the system-tray, ready to diff in an instant, at any time? Anyway, just a thought


            • #7
              Thanks for the followup.

              I don't like the slower startup for the Linux version either, but I suspect it's related to the widget set we're using, and we're going to start replacing that once the Mac version is released. If it's still an issue once that's done we'll look into more serious optimizations. We could add a hack like you're suggesting, but I'd rather put the time into making sure it just starts quickly in the first place.
              ZoŽ P Scooter Software


              • #8
                Just a further follow up. A colleague here recently installed OpenSUSE 11.4, and it ran very fast on his pc!

                One main distinction between our installations was that he installed the Gnome desktop, while I installed the KDE desktop.

                So perhaps this is a hint that the slowdown on startup is only occuring when run under KDE (and not under Gnome).


                • #9

                  While looking for a download for OpenSuse 11.4, it appears that version is no longer supported. Is upgrading an option for you? Which version of OpenSuse are you currently running, and is it 32bit or 64bit?
                  Aaron P Scooter Software


                  • #10
                    Hi Aaron,
                    Upgrading is somewhat precarious for us here, so it doesn't occur too often.

                    Nonetheless, I'm currently on OpenSUSE 12.3, which isn't too old, and still experiencing this same delay issue. I currently use KDE desktop.

                    I might give the Gnome desktop a try at some later stage, just to see if the slow open problem goes away (I suspect it will).

                    Oh, in addition, I'll mention that I'm on the 32-bit OS for 12.3, so was my colleague when he installed 11.4.
                    Last edited by Gurce; 06-Jul-2014, 10:00 PM. Reason: (added info on use of 32-bit OS)


                    • #11
                      Now that I've been on OpenSUSE KDE for a few years, another thing is dawning on me, many other Qt/KDE apps are opening up very slowly too, eg, "kwrite" and "dolphin".

                      I've done a bit of googling and this thread proved interesting:


                      The poster here suggests turning on the qt raster engine via adding this into your "~/.profile" file:

                      export QT_GRAPHICSSYSTEM="raster"

                      Hmm, it's early days with my assessment, but my initial impression is that this setting did have a positive impact. Apps like "kwrite" and "dolphin" seem to be opening up a lot faster now. As for beyond-compare, it's opening time has improved from the 7-8 seconds I mentioned initially, down to about 2-3 seconds after the setting was applied.

                      Some repliers on the post mentioned that they had an Nvidia card (and the native nvidia driver). So do I, so perhaps that is a common factor for the issue.

                      Perhaps this might also explain why the virtualboxes of opensuse+kde never seemed to suffer from the 7-8 second delay, as they wouldn't have had the nvidia driver installed.

                      All the same, the improved 2-3 sec delay is still a painful wait, and I still always find myself keeping a spare copy of beyond-compare minimised in the background, so that any future instances start up instantly.

                      It's a dodgy workaround I know, but atleast it saves me the 2-3 second wait...


                      • #12
                        Thanks for this information. I'll pass it on to a dev to see if it'll help us in future releases.
                        Aaron P Scooter Software