Announcement

Collapse
No announcement yet.

Tab closes or BC exits when SSH connection not available

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tab closes or BC exits when SSH connection not available

    BC Version 3.3.2 (build 14050)
    Ubuntu 10.04

    I think this is new behavior for this version.

    Scenario: Folder Compare session, typically from a saved workspace with multiple tabs for different remote directories.

    When a remote SSH connection on a LAN is not available, for example sftp://root@192.168.0.101//mnt/sda2, instead of simply getting an empty pane with a "Folder Not Available" label below the path box and a "Connection failed (error code is 113)" in the message pane, the session tab closes. This does not happen every time. Sometimes BC exits completely when this occurs.

    I've tried running BC from the shell, and have been able to capture these diagnostics when BC exited:

    Runtime error 231 at 08070741
    Segmentation fault

    Runtime error 231 at 08070741
    Mutex destroy failure: Device or resource busy
    Segmentation fault

    One time a diagnostic dialog popped up. It looked like a stack dump. But BC closed before I could save the contents of the dialog.
    Last edited by Dave_L; 28-Sep-2011, 05:49 AM. Reason: Fixed BC version number (was 3.2.2 instead of 3.3.2).

  • #2
    Dave,

    Sorry to not get a response in sooner. We are trying to replicate this bug here and will report back what we find.
    David J Scooter Software

    Comment


    • #3
      Hello,

      We should be able to get you a debug build to help test with this. Is the email address you registered with the forums a good point of contact for emailing it? Please email us at support@scootersoftware.com with a link to this forum post, and we can get you that debug build in (hopefully) a day or two.
      Aaron P Scooter Software

      Comment


      • #4
        Yes, that address is a good point of contact for emailing it.

        I'm sending you an email message as requested, using that same address as the sender.

        Comment


        • #5
          Using the debug build, here's the contents of ~/bccrash.txt. I got BC to crash a couple of times, and the file contents were identical both times. Evidently the file is getting truncated. Is it possible to flush or close the file after writing to it? Or is the information present adequate?

          Code:
          Beyond Compare Version 1.0 inhouse (build 0)
          Exception occurred at: 080704B5
          EAccessViolation: Access violation at address 08189AF7, accessing address 0000000C.
            $081D56BF  @Kylexceptbacktrace,  line 192 of KylExcept.pas
            $081D587F  MyRaiseException,  line 255 of KylExcept.pas
            $0805EE1A  __backtrace,  line 170 of SsCodePage.pas
            $080704B5  RaiseSignalException,  line 10718 of SysUtils.pas
            $08189AF8  @Bcforms@TBcApplication@FiberMessageLoop,  line 1973 of BcForms.pas
            $0816D8E1  ContextStartProc,  li
          I was able to do a screen capture too, and it contains a little more info:

          Comment


          • #6
            Which version were you using previous that worked, and was the "error code is 113" accurate, or were you making up a number there?
            ZoŽ P Scooter Software

            Comment


            • #7
              The previous version was 3.3.1-13971.

              "error code is 113" was the actual message, unless I made a mistake in copying it.

              I assume you're unable to duplicate the error?

              -----

              I can try reverting to the previous version and verifying that the error does not occur. Do you think that extracting the executable file from the 3.3.1 .deb would be sufficient for this?

              Comment


              • #8
                Extracting the executable would be sufficient.
                David J Scooter Software

                Comment


                • #9
                  I don't know if this is still of interest, but the same crash occurred in the latest version 3.3.7 (build 15876).

                  I'm emailing the debug log to the support address, subject "Re: Tab closes or BC exits when SSH connection not available", in case you'd like to look at it.

                  Comment


                  • #10
                    Hello,

                    Just following up here as well. I emailed you on April 8th with a few more questions and a request to see if we could get a temporary FTP account to try testing against, just in case it was missed.
                    Aaron P Scooter Software

                    Comment


                    • #11
                      I just replied to the April 8 email.

                      Sorry for the delay.

                      Comment


                      • #12
                        Ubuntu 12.04.5

                        Just noting that this problem does not occur in BC 4.1.0.20251 64-bit (beta).

                        Comment

                        Working...
                        X