Announcement

Collapse
No announcement yet.

Arch linux 64 bit

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Arch linux 64 bit

    Hi there,
    I'm on arch linux 64 bit with kde 4.3.3 (kdemod).
    I can't run BCompareLinux-3.1.8.11096.
    Basically it just displays an error message box and quits.
    The error says:
    Error reading SummaryImage.Picture.Data:Image format not recognized.
    All 32 bit libraries seem to be in place.
    See attached screenshot and ldd output.
    Any help appreciated.

  • #2
    Confirmed: I also see this same message.

    To get this far in the arch (64) setup, I installed the following 32-bit libraries:
    $ pacman -S lib32-qt3 lib32-libpng lib32-libxdamage

    Comment


    • #3
      I'm running into the same thing. Any chance you found a solution?

      Comment


      • #4
        I will download arch 64 today and give it a try

        David
        David J Scooter Software

        Comment


        • #5
          Error reading SummaryImage.Picture.Data:Image format not recognized.

          All,

          It appears that this error occurs when libqt-mt.so.3 does not include jpeg support. The error occurs during first start up when the initial startup dialog tries to load a jpeg.

          In my system I was able to bypass this by copying the attached BCState.txt as BCState.xml in my $HOME/.beyondcompare (don't forget to rename it from BCState.txt to BCState.xml) The critical part in the file is setting FirstStartup Value="False". This bypasses the dialog that loads a jpeg.

          Obviously this is not a final solution. The final solution is finding a libqt-mt.so.3 that includes jpeg. I haven't had time to search the ArchLinux packages to see if such exists with in ArchLinux or if one would have to be brought in from another source.

          We are also exploring distributing a version of libqt-mt.so.3 with beyondcompare. We will let people know when such a distribution is available.

          David
          David J Scooter Software

          Comment


          • #6
            Thanks David

            I've since switched to Ubuntu x64 mostly for Beyond Compare, but thanks for investigating.

            Comment


            • #7
              Hi,

              I just installed Beyond Compare 3 on my ArchLinux 64-bits, using the following PKGBUILD to install with pacman:
              https://bbs.archlinux.org/viewtopic.php?id=96995

              It works well so far, but when you close the last-but-one tab, the application becomes kind of unresponsive (can still be gracefully closed). After restarting the app it works well again, but the problem can still be reproduced. It's not critical as there is a workaround (always keep tab bar open, which is what I want anyway), but looks bad as a first impression of BC (luckily I already knew how good it is ).

              Steps to reproduce:
              - Start a folder comparison
              - Compare two files (opens a new tab)
              - Close the file comparison, you go back to the folder comparison but the interface is unresponsive (for example clicking on a file doesn't work anymore)

              Workaround:
              - "Options" -> "Tabs" -> Uncheck "Hide tab bar if single tab"

              Comment


              • #8
                Hi Baleg,

                Thanks for reporting the problem. Our primary test environments are Redhat and Ubuntu. We haven't seen this behavior before, so we'll get an ArchLinux test system going and let you know what we find out.
                Chris K Scooter Software

                Comment


                • #9
                  Baleg,

                  I used the same PKGBUILD script and built a bc package on a 2009-08-64 version of ArchLinux running kdemod. I followed your very straightforward steps and do not see the problem that you see.

                  There are a couple of things that you could try to help us with this. One would be to install our 3.2.1 beta and see if this makes any difference. This can be done with a few changes to the PKGBUILD script
                  - pkgver=3.1.11.12238
                  + pkgver=3.2.1.12831
                  - md5sums=('ac629c7b1ce18bd7a043a81bce2626ef')
                  + md5sums=('73c09c2c8b46750a127cec7b79aadb86')
                  - md5sums=('0459b3b905f4e1bf7d4235d4af0a33a8')
                  + md5sums=('add4c57329d1bda7902fae2744dde7bc')

                  The other thing would be to start up gdb debugger on BCompare when it is non-responsive and give us a stack trace.
                  []$ ps -C BCompare # to get the PID of the BCompare process
                  []$ gdb /usr/lib32/beyondcompare/BCompare xxxxx # where xxxxx is the PID

                  Then is 'bt' command in gdb to get a backtrace.
                  David J Scooter Software

                  Comment


                  • #10
                    I seems that it's not working anymore with the new lib32-qt4.

                    http://www.clausconrad.com/blog/inst...ro-arch-64-bit claims it works with

                    $ sudo pacman -S lib32-libxft lib32-libxinerama

                    however the dependencies are still not met:

                    Some Shared Libraries were not found
                    linux-gate.so.1 (0xf77d7000)
                    libz.so.1 => /usr/lib32/libz.so.1 (0xf779c000)
                    libqtc.so.1 => /home/werner/lib32/beyondcompare/libqtc.so.1 (0xf7286000)
                    libX11.so.6 => /usr/lib32/libX11.so.6 (0xf714f000)
                    librt.so.1 => /usr/lib32/librt.so.1 (0xf7146000)
                    libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf7129000)
                    libdl.so.2 => /usr/lib32/libdl.so.2 (0xf7124000)
                    libc.so.6 => /usr/lib32/libc.so.6 (0xf6f77000)
                    libqt-mt.so.3 => /home/werner/lib32/beyondcompare/libqt-mt.so.3 (0xf6864000)
                    libXext.so.6 => /usr/lib32/libXext.so.6 (0xf6851000)
                    libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf6767000)
                    libm.so.6 => /usr/lib32/libm.so.6 (0xf6721000)
                    libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf6707000)
                    libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf66e4000)
                    /lib/ld-linux.so.2 (0xf77d8000)
                    libXrender.so.1 => /usr/lib32/libXrender.so.1 (0xf66d9000)
                    libXrandr.so.2 => /usr/lib32/libXrandr.so.2 (0xf66cd000)
                    libXcursor.so.1 => not found
                    libXinerama.so.1 => /usr/lib32/libXinerama.so.1 (0xf66c9000)
                    libXft.so.2 => /usr/lib32/libXft.so.2 (0xf66b3000)
                    libfreetype.so.6 => /usr/lib32/libfreetype.so.6 (0xf6612000)
                    libfontconfig.so.1 => /usr/lib32/libfontconfig.so.1 (0xf65d6000)
                    libSM.so.6 => /usr/lib32/libSM.so.6 (0xf65cd000)
                    libICE.so.6 => /usr/lib32/libICE.so.6 (0xf65b3000)
                    libXau.so.6 => /usr/lib32/libXau.so.6 (0xf65af000)
                    libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf65a8000)
                    libbz2.so.1.0 => /usr/lib32/libbz2.so.1.0 (0xf6597000)
                    libpng16.so.16 => /usr/lib32/libpng16.so.16 (0xf655e000)
                    libexpat.so.1 => /usr/lib32/libexpat.so.1 (0xf6535000)
                    libuuid.so.1 => /usr/lib32/libuuid.so.1 (0xf652f000)

                    Comment


                    • #11
                      I found the AUR package to work for me.

                      $ sudo yaourt -S bcompare-beta

                      Comment


                      • #12
                        Related to your menu draw issue from your other post, we aren't familiar with this repository or package. I would recommend rolling back to your previous state, using one of the downloads on our website, and then we can figure out which dependencies you are still missing. From your earlier log, it looks like you might just need libXcursor.so.1 (xcursor)?
                        Aaron P Scooter Software

                        Comment


                        • #13
                          Strangely when I opened it today the menu was at normal speed.

                          However some other issues while testing more:

                          - Cannot customize the toolbar. After right click toolbar > Customize, I expect to drag&drop or some other way to add/remove from toolbar once I'm in the toolbar settings dialog but drag&drop doesn't seem supported.
                          - No scrollbar in the directory difference window
                          - A few rendering issues with toolbar buttons background (only some newer buttons, old BC3 button look fine)

                          I can provide some screenshots if you need.

                          Comment


                          • #14
                            Hello Wernight,

                            Thanks. Let us know about the speed issue if it crops up again. You might still want to revert the package, but this is entirely up to you. As for the other 3 issues you found:

                            - Toolbar customization is not something we are able to support in the current BC4 version and might not be able to add this functionality for BC4.0. It's something we're looking into. While it appears similar, we actually redid a lot of the fundamentals surrounding the toolbar.

                            - Scrollbars should be back in the next update. We have a fix submitted and ready.

                            - We fixed a fair number of these as well. I would suggest waiting for the next update, then take some screenshots if any persist and submit (here or by email) so we can hunt down any specific ones. OS version information is usually helpful, too, in these cases.
                            Aaron P Scooter Software

                            Comment

                            Working...
                            X