Announcement

Collapse
No announcement yet.

Beyond Compare 3 on Ubuntu 18

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Beyond Compare 3 on Ubuntu 18

    Hello,

    I had been running Ubuntu 17, and from memory the install went fine.

    Just pulled down the deb install for Ubuntu 18 and it won't start with

    russ@ubuntu:/usr/lib/beyondcompare$ ./BCompare
    ./BCompare: error while loading shared libraries: libqtc.so.1: cannot open shared object file: No such file or directory
    I see this was a problem in 2009, but I cannot find a resolution. I tried installing libqtcore4, but that hasn't helped.

    Thank you

    Russ

  • #2
    To run Beyond Compare for Linux (version 3 or 4), use the terminal command bcompare instead of trying to run the executable directly. The /usr/bin/bcompare launcher script sets up a required environment variable, the executable won't run without the variable set.

    I tested Beyond Compare 3.3.13 on Ubuntu 18.04 LTS beta 2. When I tried to run it with the command bcompare, it failed to launch with the following error:

    Code:
    scooter@ubuntu:~$ bcompare
    libpng warning: Application jmp_buf size changed
    Runtime error 230 at 080707CD
    Segmentation fault (core dumped)
    Beyond Compare 3 uses QT3 and is based on older technology. It doesn't look like it's compatible Ubuntu 18.04 beta 2. We're no longer releasing software updates for version 3. Unless Ubuntu releases a compatibility update that fixes this issue, you'll need to upgrade to version 4 to use Beyond Compare on Ubuntu 18.04.

    Beyond Compare 3.3.13 is compatible with Ubuntu 14.04 LTS and 16.04 LTS.

    Linux distributions and versions we've verified as compatible with Beyond Compare are listed on our website.
    https://www.scootersoftware.com/down...hp?zz=kb_linux
    Chris K Scooter Software

    Comment


    • #3
      Really? So there is no way of running BC 3 on Ubuntu 18 not even 10 years after I purchased my license? Sounds like you guys don't need paying customers. I guess I'll switch to open-source stuff instead.

      Comment


      • #4
        BC3.0 was launched in 2008 (preceded by a lengthy public beta and designed earlier), and had releases util 3.3.13 in 2014. This couldn't account for changes Ubuntu made 10 years later when launching 18.04 in 2018, when they removed necessary library support. BC4 is our current product and has been patched to support 18.04 starting with BC 4.1+, while also adding 64bit support.

        If your BC3 purchase was a New licenses (not upgrades) bought after January 1, 2013, you can upgrade to version 4 for free. Otherwise, BC3 to BC4 is generally available at a half-price discount, which you can calculate here:
        http://www.scootersoftware.com/shop....p_upgrade_cart
        Aaron P Scooter Software

        Comment

        Working...
        X