Announcement

Collapse
No announcement yet.

dolphin context menu folder diff between two dolphin windows fails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dolphin context menu folder diff between two dolphin windows fails

    Hi there,

    I've bumped into a scenario when using the right-click context menus in dolphin to diff between a local folder and a remote-folder that has been mounted locally via "/etc/fstab" and "sudo mount -a".
    1. I right-click the local folder in dolphin for the left-hand-side, eg "/home/freddo/frog/folder1/"
    2. I then right-click the remote folder in dolphin for the right-hand-side, eg "/mnt/server/freddo/frog/folder2/"


    Instead of diff'ing the selected folders, it diffs the parents of the selected folders, eg "/home/freddo/frog" vs "/mnt/server/freddo/frog".

    I tried this on two of my development pc's, both had the same problem, here are the specs of them:

    DEV PC1
    • OpenSUSE 11.4 (32-bit)
    • KDE 4.6.00 "release 6"
    • Dolphin 1.6
    • Beyond Compare 3.3.10-17762



    DEV PC2
    • OpenSUSE 12.3 (32-bit)
    • KDE 4.10.00 "release 1"
    • Dolphin 2.2
    • Beyond Compare 3.3.10-17762


    Just wanted to put this on your radars.
    Last edited by Gurce; 01-Apr-2014, 01:08 AM. Reason: renamed thread title (old title was based on an older assumption, which was wrong)

  • #2
    Some observations since my first post:
    • I tried diff'ing a local folder against a folder mounted with sshfs, and that worked fine.
    • I then began to suspect if it's the particular-style of mounting that was the problem in my case
    • In the faulty case, it was a mount provided by a line in my "/etc/fstab" file that looks like the following:

      //server01/data /mnt/server_data cifs rw,auto,credentials=/home/gurce/.smbcredentials,dir_mode=0777,file_mode=0777 0 0
    • So the method that was failing in this manner used cifs
    • I noticed you had mounting tips on this page:
      http://www.scootersoftware.com/suppo...z=kb_linuxtips
    • The advice on that page suggested using either smbfs (this is cifs, right?) or fusesmb.


    I haven't tried fusesmb before, I noticed that the opensuse repositories offer this package, so I might give it a try later.

    PS. I recently updated the title of this post. The new title appears fine once viewing the post, but oddly, the old title still appears in the 'Linux' forum title list. Any idea what went wrong? Can it be tweaked/fixed manually in the db? (as the old title no longer makes sense).

    To be explicit:

    OLD-TITLE = "dolphin context menu folder diff between two dolphin windows fails"
    NEW-TITLE = "problem with remote-folders in folder-diff in dolphin via context-menus"

    Comment


    • #3
      Hello,

      Thanks, and I would suggest giving Fuse a try. With so many different OS and mounting combinations, it can be tricky to troubleshoot every option available.

      If you are interested, you could also help us beta test BC4, which includes smb:// address support and mounting in the latest beta build. It does rely on some helper libraries (Gnome's gvfs/gio for example), so I'm not certain about the context menu vs. putting the address directly into BC4.

      If you can help us test, please do so with already backed up data to help avoid any potential issues with live/important data.
      http://www.scootersoftware.com/beta.php
      Aaron P Scooter Software

      Comment

      Working...
      X