Announcement

Collapse
No announcement yet.

Time stamps incorrect on copy

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Time stamps incorrect on copy

    When I use BC to copy files from one side to the other (I'm using Ubuntu 12.04), the time-stamp is current time .. not the time-stamp of the original file. How do I fix that?

  • #2
    Hello,

    What type of destination are you copying to? BC3 normally tries to preserve the Last Modified timestamp on a copy, but some destinations will not allow this behavior and set it to the time of the transfer.

    Are you using the latest release of BC3 (3.3.8)? Ubuntu 32bit or 64bit?

    Does the Touch command (right click selection, can manually override/copy a timestamp) work? Sometimes this command can work even when not preserved during the copy.
    Aaron P Scooter Software

    Comment


    • #3
      Is the user doing the copy the same as the owner of the target file? If not then you can't change the timestamp of the target file unless you are the root user or unless you delete the target file before you do the copy.

      Comment


      • #4
        p.s. Just to clarify, what I meant is that you CAN change the timestamp of the target file but unless either of those two conditions exist then you can only change it to the current time.

        Comment


        • #5
          I have been trying to copy data from a USB attached device to a network drive running on a Synology NAS.

          Yes, I'm using the latest B.C. .. I've tried with both Ubuntu 12.04 LTS and Ubuntu 13.10 (both 64 bit).

          Touch command gives me the following error:
          02/28/2014 11:53:31 AM Unable to set last modified time of /home/boba/.gvfs/AFP volume Vol2 for boba on DS410j/STM-Three_HeartCryIndia_Pt2/heartcry for india/.DS_Store: Operation not supported

          I've about given up on trying to copy files on Ubuntu. Even using file manager, I lose time-tags. Somehow, I had copied a whole bunch of files without using time-tags .. and I can't figure out how I did it (I was using the basic file manager).

          Comment


          • #6
            Originally posted by Aaron View Post
            Hello,

            What type of destination are you copying to? BC3 normally tries to preserve the Last Modified timestamp on a copy, but some destinations will not allow this behavior and set it to the time of the transfer.

            Are you using the latest release of BC3 (3.3.8)? Ubuntu 32bit or 64bit?

            Does the Touch command (right click selection, can manually override/copy a timestamp) work? Sometimes this command can work even when not preserved during the copy.
            Hmm .. I thought I posted this reply already but it didn't show up. Here it is again ..

            I have been trying to copy data from a USB attached device to a network drive running on a Synology NAS.

            Yes, I'm using the latest B.C. .. I've tried with both Ubuntu 12.04 LTS and Ubuntu 13.10 (both 64 bit).

            Touch command gives me the following error:
            02/28/2014 11:53:31 AM Unable to set last modified time of /home/boba/.gvfs/AFP volume Vol2 for boba on DS410j/STM-Three_HeartCryIndia_Pt2/heartcry for india/.DS_Store: Operation not supported

            I've about given up on trying to copy files on Ubuntu. Even using file manager, I lose time-tags. Somehow, I had copied a whole bunch of files without using time-tags .. and I can't figure out how I did it (I was using the basic file manager).

            Comment


            • #7
              Originally posted by Pete View Post
              Is the user doing the copy the same as the owner of the target file? If not then you can't change the timestamp of the target file unless you are the root user or unless you delete the target file before you do the copy.
              The target file is new, so there isn't an owner yet. Unfortunately, I'm not the owner of the source files .. which is another issue I still have to resolve. As far as ownership of the target directory, I'll have to check.

              Thanks. I'm giving up for now but will have to come back to this later.

              Comment


              • #8
                it appears that on linux it only works with local drives ... i'm running kubuntu 1604 and before 1404

                almost any file transfer and touch works correctly and i usually own my data and haven't had much trouble

                as soon as i mount my NAS drive or any other machine the problems starts ... my solution is to use a windows machine with beyond compare 3 and the left side is the linux box and the right side the NAS or even more convenient run a windows VM accessing the files via shared drives under v-box on my linux machine and do the copy (windows 2000 pro with no activation or XP 32 will do the trick with a small vm footprint)

                i admit it's a bit clumsy, but it keeps the time stamps correct

                another issue is that if i want to copy a whole folder containing either symlinks and / or preserving the time stamps, it appears that beyond compare will copy the linked to file, rather the link itself ... in this case i tar.gz the folder, copy it and then expand it on the other side

                clumsy, but it works ... if anyone has a better idea, please post it

                cheers

                Comment


                • #9
                  If you perform the same test using Kubuntu's native file explorer and the Windows machine's Windows Explorer, I expect you may see similar timestamp handling behavior. BC4's behavior generally matches that of the native OS it is running on. NAS devices can sometimes be tricky and have some issues or oddities; if so, are there any driver updates or firmware upgrades for the device? And also, please reboot the NAS as a troubleshooting step. Rebooting the Kubuntu machine is not a bad test to try either.

                  BC4's symlink handling is in the Folder Compare's Session menu -> Session Settings, Handling tab. Follow symbolic links is an option you can enable to disable, per session or as a global (all future sessions) default.
                  Aaron P Scooter Software

                  Comment


                  • #10
                    Originally posted by Aaron View Post
                    If you perform the same test using Kubuntu's native file explorer and the Windows machine's Windows Explorer, I expect you may see similar timestamp handling behavior. BC4's behavior generally matches that of the native OS it is running on. NAS devices can sometimes be tricky and have some issues or oddities; if so, are there any driver updates or firmware upgrades for the device? And also, please reboot the NAS as a troubleshooting step. Rebooting the Kubuntu machine is not a bad test to try either.

                    BC4's symlink handling is in the Folder Compare's Session menu -> Session Settings, Handling tab. Follow symbolic links is an option you can enable to disable, per session or as a global (all future sessions) default.
                    thanks for the info about the symlink setting, i set it as suggested and will check it as soon as i have symlink related comparisons or copies

                    also, i never looked at time stamps using file explorer copies ... BC just makes it so easy to copy and verify the time stamp transfer through the various color indications

                    i use BC exclusively for all of my backup operations

                    it's not too easy to to reboot the NAS and the local machines (time spent) to test the outcome of a copy / comparison, and even if it would make a difference, rebooting before the operations takes too much time

                    as indicated before, windows OS (w2k and xp32, no permissions) seems to handle all copies from / to network devices flawless ... therefore i use either a windows machine or a local virtual windows v-box implementation for network oriented BC operation, and it works ... i don't need to mount and umount devices in linux

                    as you stated, it doesn't seem to be a shortcoming in BC, rather a restriction in linux with all the inherited permissions

                    thanks for the clarifications, and thanks for creating BC

                    Comment

                    Working...
                    X