Announcement

Collapse
No announcement yet.

Feature Request: sync\copy folder structure only

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Feature Request: sync\copy folder structure only

    Sometimes all you care about is the folder structure you don't want to copy\sync the files themselves. A nice feature would be to have a checkmark in the relevant windows (copy\sync) named "Folders only" or something similar...

  • #2
    Hello,

    If you set your file name filter to -*.* instead of *.*, and set the View menu to Always Show Folders, you can perform this type of copy.

    If it is a common copy, you can also go to the Tools menu -> Customize Commands, and enable Show None in the toolbar and menu (enabling would replace the -*.* step).
    Aaron P Scooter Software

    Comment


    • #3
      Thanks

      Thanks

      Comment


      • #4
        Allow me to get back on this somewhat older thread.
        I want to copy foldernames from source to destination. It looks a bit like the above request.
        Have added -*.* to the filters, tagged 'Always show folders' from View.
        But still the whole lot is copied, instead of just the foldername only.

        What am I doing wrong here?

        Thanks
        =

        Comment


        • #5
          @bcdewul have you marked the "Include hidden items in operation" option by mistake?

          Comment


          • #6
            One step further now.

            I manually entered a '-' to the *.* in the filterbox.
            But just discovered that I should click on 'Filtersbutton', thén add a - to the 'include files' box there.

            Next step: I am seeking a way to copy just the rootnamefolders, meaning

            for example: just 'folder abc'
            x:\folder abc
            but not any (empty) subfolders under (belonging to) folder abc.

            Any suggestions?

            Thanks
            =

            Comment


            • #7
              If the subfolder is not empty, would you still want to copy it? If not, the filter you are looking for should be:
              -*.*;-.\*\...\*\


              The '-' character is important to be pasted into the Filters text box, since it indicates an Exclude filter instead of an Include filter. Paste this full filter into the filter box, replacing the default "*.*" filter (without quotes).
              Aaron P Scooter Software

              Comment


              • #8
                Hi,

                Thanks.
                Yes, just the top folder, the name only, no contents, nothing.

                See example

                Have copy-pasted the filter but regret that still all contents are copied.

                Any other suggestions?
                Thanks again.
                =

                Comment


                • #9
                  Hello,

                  From that screenshot, it looks like the subfolders are still present, but they should be excluded given that filter. Could you include more of the screen in the screenshot including the filters textbox? If you cannot post it here, please email us at support@scootersoftware.com with a link back to this forum post for our reference.

                  If an item is visible when you attempt to copy, it will copy it as well. The filter should be hiding the subfolders and items from view. Note that both filter items have '-' characters in front of them.
                  Aaron P Scooter Software

                  Comment


                  • #10
                    Hello again,
                    Most likely I am doing something wrong - somewhere along the line.
                    Pls find some snapshots attached.

                    It would be something like these steps:



                    --




                    --




                    --



                    --

                    At the bottom (6) the idea I am looking for.

                    The filter I copy-pasted.

                    Thanks again.
                    (p.s. sorry for the big screenshots)
                    =

                    Comment


                    • #11
                      Hello,

                      Copying and pasting the filter would be into the Filters text box in the main Folder Compare pane. If you are pasting directly into the Session Settings dialog, you would instead want to paste:
                      Exclude Files:
                      *.*
                      Exclude Folders:
                      .\*\...\*

                      Which, in the main pane should then translate to:
                      -*.*;-.\*\...\*\
                      Aaron P Scooter Software

                      Comment


                      • #12
                        Thank you.

                        Sorry, my mistake, I got a bit confused.

                        It seems there is a difference between entering
                        Exclude Files: *.*
                        Exclude Folders: .\*\...\*

                        via filters->name filters

                        versus
                        simply copy pasting the results , viz -*.*;-.\*\...\*\ in the main window pane.

                        The first one actually only copies the top folder with '0' contents
                        Perfect.

                        The second one, just copy-pasting the filter in the main window pane, still files are copied.

                        See attachment.


                        Anyway, matter solved.

                        best regards
                        =

                        Comment


                        • #13
                          The copying or not copying should be controlled by what is visible. Are the files visible, despite the filter toolbar textbox appearing to be the same text in both screenshots?

                          A full screen screenshot would help, as other options (like Suppress Filters) could have an impact on this.
                          Aaron P Scooter Software

                          Comment

                          Working...
                          X