Announcement

Collapse
No announcement yet.

How to stop csv data compare sorting by the first column

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to stop csv data compare sorting by the first column

    I would like to see the data compare of two csv files that doesn't sort by the first column. I can't find an option to switch off the sorting, and just compare the lines in the original file order.

  • #2
    Hello,

    By default, the first column is a Key column, and the Key is (by default) sorted and aligned by. You can disable the sorting in the Data Compare's Session menu -> Session Settings, Columns tab, enable "Unsorted alignment"
    You can also disable it as a Key if it is not by right clicking the column header and making it a Standard column. (You can also change this in the Columns tab by editing the column.)
    Aaron P Scooter Software

    Comment


    • #3
      Thanks. I would like to use BC for comparing test output with a reference folder. I have saved a folder level session pointing to the two folders, and a data compare session with the Unsorted box checked, and the left and right file names with the folder names and *.csv, which it accepted. When I double-click on a csv file in the folder view, how can I get the saved data session to be applied. Currently, I have to select the saved session for each file. I don't really want to change the defaults for all data compares.

      Comment


      • #4
        You could switch to Text Compare rather quickly.

        Session, Compare Files Using, Text Compare

        Comment


        • #5
          When you set the Data Compare settings, change the dropdown in the Session Settings dialog from "Use for this view only" to "Use for all files within parent session". This will affect all Data Compares launched from the same parent Folder Compare session, but it won't change the default for comparisons outside of that folder compare.
          Chris K Scooter Software

          Comment


          • #6
            Thank you Chris - exactly what I needed.

            Comment

            Working...
            X