Announcement

Collapse
No announcement yet.

Set all files to ignore keyword expansion

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Set all files to ignore keyword expansion

    Is there an easy way to set all files to ignore SVN keyword expansion.
    I get text compare fails on keyword expansion in asm and txt and bat files.
    I would prefer to have keyword expansion ignored in ALL files.

  • #2
    Hello,

    Defining a grammar element is specific to the File Format currently in use for the pair of files being compared. If you need to define a specific element for all files, there are two ways to tackle this:
    1) Define the element for each File Format. Go to the Tools menu -> File Formats, and give each File Format a new grammar element matching the SVN text you wish to ignore. Give the element the same element name in all file formats. It will then appear only once in the Session Settings: Importance tab of the Text Compare. Unchecking this one item in the default session settings will mark all elements with the same name as Unimportant.

    2) Make a generic File Format that captures all files: "*.*" and have it at the top of the list. Define the elements for this file format, which will then be used for any file you open. This would mean that the specific formats and their grammars would not be used, however. I would recommend option #1.

    For defining the element itself, please follow this handy guide and let us know if you have any questions:
    http://www.scootersoftware.com/suppo..._unimportantv3
    Aaron P Scooter Software

    Comment

    Working...
    X