Announcement

Collapse
No announcement yet.

After Synchronization: a different file size is shown

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • After Synchronization: a different file size is shown

    I synchronized my web server with my local folder.

    Everything worked as expected apart from about 2 dozens of files.

    After the synchronization BC shows, that the each of these files has a file size, which is slightly higher than the local one.
    Therefore these files are still marked red.

    The time stamp is exactly the same as of the local files.

    Please see my attachment.

    How can I solve the problem, please?
    Thanks.

  • #2
    Did you already checked the newlines?
    Different OS use different kinds of newlines - maybe this is the reason for different file sizes.
    see http://en.wikipedia.org/wiki/Newline

    See also http://www.scootersoftware.com/suppo...b_ftpdifferent
    Last edited by knut; 23-Jun-2011, 03:27 PM.

    Comment


    • #3
      In addition to Knut's comments, you can also try going to the Tools menu -> FTP Profiles, select the specific profile, and in the Transfer tab switch from "Auto, Binary, ASCII" to "Binary." Does this help preserve the file size?
      Aaron P Scooter Software

      Comment


      • #4
        Originally posted by knut View Post
        Did you already checked the newlines?
        Different OS use different kinds of newlines - maybe this is the reason for different file sizes.
        see http://en.wikipedia.org/wiki/Newline

        See also http://www.scootersoftware.com/suppo...b_ftpdifferent
        Thanks for your answer, Knut.

        To be honest: I don't know (yet) if there are different types of newlines in my files.

        If so:
        Should BC behave like it does?
        Or should it just copy the file as it is?
        Last edited by ibu; 23-Jun-2011, 05:27 PM.

        Comment


        • #5
          Originally posted by Aaron View Post
          In addition to Knut's comments, you can also try going to the Tools menu -> FTP Profiles, select the specific profile, and in the Transfer tab switch from "Auto, Binary, ASCII" to "Binary." Does this help preserve the file size?
          Thanks for your answer
          Yes. That works.

          But, please, what is the cause for that phenomenon?

          Comment


          • #6
            FTP servers can transfer files in two ways:

            ASCII - Converts line ending styles when files are transferred.

            Binary - Does not convert line ending styles when files are transferred.

            The "Auto" setting in Beyond Compare uses ASCII transfers for file types with extensions that are text files (.txt, .html, etc). For all other file types it uses binary transfers.

            Setting BC to Binary tells the server not to do line ending conversion for any files you transfer.
            Chris K Scooter Software

            Comment


            • #7
              Originally posted by Chris View Post

              Setting BC to Binary tells the server not to do line ending conversion for any files you transfer.
              What is the reason please, that you choosed "auto" and not "binary" as default?
              "Not to convert" seems to me as a default a user expect.

              Comment


              • #8
                System configuration files and Perl scripts won't work correctly if they have Windows line endings on Unix/Linux systems. The "Auto" setting allows these file types to be converted so they work correctly.

                Web server software like Apache and PHP works correctly if .html or .php files have Windows line endings on a Unix/Linux server, so for those files forcing binary transfers is usually OK.
                Chris K Scooter Software

                Comment


                • #9
                  Chris, thanks for your explanation.

                  I will try to find a tool, which can convert all windows linebreaks in all files (php,html,css,txt) into linux linebreaks - for consistency.
                  My editor (dreamweaver) does not match the windows linebreaks with the RegEx "\r\n" unfortunately.
                  Last edited by ibu; 24-Jun-2011, 02:41 AM.

                  Comment


                  • #10
                    BC3 can convert line endings. Open the file in the Text Compare, and use the File menu -> Save As dialog. There you will get options for:
                    File Name
                    Save As type
                    Encoding
                    and Line ending Style: Windows, Linux, Mac
                    Aaron P Scooter Software

                    Comment


                    • #11
                      Originally posted by Aaron View Post
                      BC3 can convert line endings. Open the file in the Text Compare, and use the File menu -> Save As dialog.
                      Thanks for your hint Aaron. But I have to convert about 200 files. At several places inside the file structure.

                      The most of the files have the unix linebreaks yet. I configured my editor dreamweaver to "save as" with "unix linebreaks" some time ago.

                      Bad luck, there's a bug in the search&replace function of dreamweaver that it cannot match "\r\n".
                      Last edited by ibu; 24-Jun-2011, 12:14 PM.

                      Comment

                      Working...
                      X