Announcement

Collapse
No announcement yet.

Number of problems after migrating from BC2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Number of problems after migrating from BC2

    Our company has just upgraded from BC2 to BC3 and I'm seeing a number of problems. One of my main usages of BC is to compare cobol code on the PC with ditto on z/OS (keep in mind that we're a Swedish company). FORTUNATELY, I'd written a "dummies" document for new users of BC2 so when I started receiving problems, I referred to this document.

    My first attempt was to try and compare a PC folder with one on the mainframe (MF). I'd forgotten whether I needed to specify the fully qualified "folder" name on the MF so I started by specifying the MF folder as userid.xxxx.yyyy. This was rejected (fair enough), so I changed it to 'userid.xxxx.yyyy' (note the quotes) and was able to bring up the folder contents. Next problem - in BC2, I'd specified that any files ending in CBL or COBOL (if I remember correctly) caused a prompt for the code page conversion. This would be ANSI for the PC, and 1143 for the MF - this worked fine. Now to my problems.

    I started by comparing 2 files, PC on the left, MF on the right. The MF file was shown as garbage. I noticed the pulldown as shown in BC3_screen1 - trouble is, when I expanded this for the MF files, 1143 Finnish/Swedish wasn't one of the options (which it was in BC2). I changed the option to Western European but that didn't help. I thought that this was the type of change that required closing/restarting BC, so I tried that. Now the situation got worse - when I selected the same session again, I got the results in BC3_screen2 and couldn't access the MF at all. Okay, I thought - my password has possibly been saved incorrectly (even though I deliberately unticked the box to save the password). I looked in my old BC2 notes and saw the following:_

    Clearing your password if its saved by mistake

    If by some chance, your password gets saved (thereby resulting in you never being prompted for it when you open TSO as an FTP site) you can clear/remove it in the following manner.

     Start BC and access some TSO PDS
     Select tools, options, and the FTP firewall/proxy option on the left-hand side
     Click on the Clear passwords button
     Select OK

    Trouble is - that option seems to have been changed/moved somewhere else.

    Final "complaint". I have defined some rules for cobol code (saved in an XML file) and tried to import these rules. I received the error message "BC2 rules not importable". I'm ASSUMING there's a way to convert old rules and import them, or ...........
    Last edited by misi01; 09-Apr-2010, 01:28 AM.

  • #2
    Character Encoding Pulldown:

    The dropdown in your screen shot only lists a subset of common character encodings. To see the full list, select Session > Session Settings. Go to the Format tab. Select an "Encoding override". You can choose between "Use for this view only", "Use for these files within parent session", "Use for all files within parent session", or "Update session defaults" at the bottom of the dialog, then click OK.

    If you always want a specific file extension to open using your preferred character encoding, select Tools > File Formats. Select a File Format, then go to the Conversion tab. Change the Encoding from "Detect" to your preferred encoding.

    Clearing Passwords:

    To clear a saved FTP password, select Tools > FTP Profiles. Select the profile for your FTP server. In the General tab, uncheck "Save password" and delete the password text.

    Importing BC2 Rules:

    It isn't possible to import BC2 rules into Beyond Compare 3. If you need help recreating BC2 rules in BC3, you can email the XML file to support@scootersoftware.com and we'll try to help you convert them.
    Chris K Scooter Software

    Comment


    • #3
      More on this

      Thanks Chris for the reply. Hmmmm. To see the full list, select Session > Session Settings. Go to the Format tab. Assuming we're on the same page, there is no format tab. Attached a screen capture. I selected Sessions, Session settings in the top left-hand corner.

      Clearing passwords - thanks, that did the trick. You have to remember to untick the save passwords the next time you run it though.

      Character encoding. Enclosed is another screen capture taken from Tools, FTP profiles, and the General tab. I assume this is what you meant (rather than File formats) ?????

      Finally, cannot get at any MF files in BC3. Does this log screen capture help/explain ?
      Last edited by misi01; 09-Apr-2010, 01:28 AM.

      Comment


      • #4
        The Format tab is under Session Settings for a text compare or a data compare session, not a folder compare session.

        Open a compare session on a file pair that exhibits the encoding problem.
        Click on Session Settings \ Format tab.
        Select the desired encoding override.
        Choose "Also update session defaults" if you want to apply the override to all new sessions of that type.
        Click OK.
        BC v4.0.7 build 19761

        Comment


        • #5
          Sorry Michael, but that's cheating

          Let me clarify again. In BC2, I selected folder compare, selected a folder on the PC and a mainframe PDS (sort of like a folder - contains a number of separate files). In BC2, I'd set up my session such that cobol files always prompted me for the conversion code, ansi for the PC, 1143 for the mainframe. All well and good.

          Saying that I should select the format option for a text compare doesn't help me since I can't select an FTP object that way (can I ?).

          Back to you.

          Comment


          • #6
            Hello misi01,

            This is a Session specific setting. You should have a Saved folder compare session comparing your PC to your Mainframe. Open this session and then open a pair of files exhibiting this issue. Once open in the Text Compare, go to the Session menu -> Session Settings -> Format tab. Here, at the bottom, is an Encoding Override (like the Prompt in BC2). Pick the appropriate encodings for the left and right side. Then change the dropdown in the bottom left to "Apply for All files in Parent Session". The parent session is your Saved folder compare session, which you will want to now re-save to apply these settings.

            Now every Text Compare you open in the Parent Folder Compare should apply the encoding overrides, and you will not need to be prompted each time.

            Let us know if you are still having trouble or have any questions.
            Aaron P Scooter Software

            Comment


            • #7
              Thanks Aaron

              will try it on Monday at work.

              Comment


              • #8
                Aaron - I think you're going to have to treat me like an idiot.

                You should have a Saved folder compare session comparing your PC to your Mainframe. Open this session and then open a pair of files exhibiting this issue.

                I managed to find a topic elsewhere whereby I could download a version of BC2. I include below a screen capture showing what happens when I compare a PC folder with a MF one. As you can see, no problem. When I do the same thing in BC3, I get the second screen capture from my first append, ie, I don't even get to see ANY files on the MF.

                Following on...
                Once open in the Text Compare, go to the Session menu -> Session Settings -> Format tab.
                Isn't that the same advice as Michael offered. When I try the following, Start BC3, select Text compare, I get the second attached screen capture. Where do I select an FTP folder there ????

                Sorry to be a PITA, but as a user whose migrated from BC2 to BC3, I expect new bells and whistles, but I also expect to be able to use the knowledge I have from the previous version and apply it to the new one and not have to jump through a load of hoops to get where I already was in BC2.
                Last edited by misi01; 09-Apr-2010, 01:28 AM.

                Comment


                • #9
                  Finally got the connection to the MF to work

                  I'd changed the Tools, FTP profiles, default encoding setting to 1143 (Swedish, Finnish). Seemed logical to me, but that was what was screwing up the MF member download. After changing it back to ANSI, I can now see the MF PDS members in the right hand side.

                  Comment


                  • #10
                    Originally posted by misi01 View Post
                    I'd changed the Tools, FTP profiles, default encoding setting to 1143 (Swedish, Finnish).
                    There's actually two encodings involved here. The one in the FTP profile only controls the encoding used for paths and directory listings when you're communicating with the server, and doesn't have anything to do with the encoding of the files. The file formats and session settings the others have mentioned control that.
                    Zo P Scooter Software

                    Comment


                    • #11
                      Do you mean to say

                      that the string 'misi01.inla.cobol' was being translated using code page 1143 before being sent to the mainframe.

                      Comment


                      • #12
                        Yes.
                        Zo P Scooter Software

                        Comment


                        • #13
                          Originally posted by Aaron View Post
                          Hello misi01,

                          This is a Session specific setting. You should have a Saved folder compare session comparing your PC to your Mainframe. Open this session and then open a pair of files exhibiting this issue. Once open in the Text Compare, go to the Session menu -> Session Settings -> Format tab. Here, at the bottom, is an Encoding Override (like the Prompt in BC2). Pick the appropriate encodings for the left and right side. Then change the dropdown in the bottom left to "Apply for All files in Parent Session". The parent session is your Saved folder compare session, which you will want to now re-save to apply these settings.

                          Now every Text Compare you open in the Parent Folder Compare should apply the encoding overrides, and you will not need to be prompted each time.

                          Let us know if you are still having trouble or have any questions.
                          Okay, let's see if we're on the same page. Here's the scenario of where we are at the moment

                          Start BC3 with a saved folder session with PC files on the left and MF files on the right
                          Select 2 files for comparison.(The right file - mainframe one - is unreadable because the default codepage is set to 00936).
                          One time job - select tools, file formats. Create and save NEW format called COBOL Ebcdic, and define it without any mask, but with an 1143 conversion and 80 characters per line
                          When comparing files now, the MF side is always shown with default conversion and crap as content. Select Cobol Ebcdic from the drop down as the file format and everything is hunky-dory.

                          To my question. Is there any way of specifying that for a specific FTP format a specific conversion (COBOL Ebcdic) should be used. I tried specifying that the COBOL Ebcdic mask should be *.COBOL but that didn't seem to work.

                          Comment


                          • #14
                            Hello misi01,

                            This is a Session specific setting. You should have a Saved folder compare session comparing your PC to your Mainframe. Open this session and then open a pair of files exhibiting this issue. Once open in the Text Compare, go to the Session menu -> Session Settings -> Format tab. Here, at the bottom, is an Encoding Override (like the Prompt in BC2). Pick the appropriate encodings for the left and right side. Then change the dropdown in the bottom left to "Apply for All files in Parent Session". The parent session is your Saved folder compare session, which you will want to now re-save to apply these settings.

                            Now every Text Compare you open in the Parent Folder Compare should apply the encoding overrides, and you will not need to be prompted each time.

                            Let us know if you are still having trouble or have any questions.
                            You will want to follow this, but instead of Encoding Overrides, pick specific File Formats. Uncheck the Same as Left option in the Format tab, then select your Cobol Ebcdic file format (which defines line length 80) assuming the Mainframe is on the Right side.

                            Does that work for you?
                            Aaron P Scooter Software

                            Comment


                            • #15
                              Does it work - no.

                              You will want to follow this, but instead of Encoding Overrides, pick specific File Formats. Uncheck the Same as Left option in the Format tab, then select your Cobol Ebcdic file format (which defines line length 80) assuming the Mainframe is on the Right side.

                              It's not at all impossible that I'm doing something wrong, but here's my scenario. (I'm beginning to think that we're either talking at cross-purposes or you guys have missed a VERY simple design requirement. Let's see which it is).

                              - Start BC3 and select a saved folder session, PC vs MF
                              - List of files in folder shown - no option under session settings to selected format since no files chosen as yet.
                              - Select 2 files. MF file shown with default (?) of Turkish windows (ie, unreadable)
                              - Select session, session settings and format tab. Format for left is detected, format for right is COBOL Ebcdic. Select Use for all files within parent session.
                              - Code now readable, but seeing the grey dashed lines indicating some difference even though there doesn't seem to be any (first attachment)
                              - Close this tab to return to folder view
                              - Pick 2 different files to compare, MF file shown as Turkish Windows (again)
                              - Select Session, session settings, Format tab and change to Cobol Ebcdic - code now readable again.
                              - Select Session, save as and select PC_file <--> mainframe_PDS
                              - Close BC3 completely
                              - Restart BC3 and here comes the rub. If I select the PC_file <--> mainframe_PDS session, then I'm ONLY shown the last 2 files I was comparing when I saved the session. If I select the PC/MF folder session, then the settings I saved earlier don't seem to be found/kick in.

                              Am I doing something wrong or is this some sort of design flaw/bug ?

                              Comment

                              Working...
                              X