No announcement yet.

Number of problems after migrating from BC2

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16

    Sorry about that. With further testing, it appears the File Format overrides are not saved with the "Use for All files" setting to prevent conflicts with the Folder Compare: Session Settings: Misc tab's File Format handling.

    Here's a new strategy:
    Go to Tools->File Formats. Edit your COBOL Ebcdic file format.
    Change the mask from trying to match on to a file extension, to a folder path:
    (The 2nd definition is to help match in upcoming database changes).

    Go to the saved Folder Compare, go to the Session Settings, Misc tab, and uncheck all the file formats except for the custom COBOL Ebcdic.

    Now, when you open a file, the left side (which won't match *cobol* or *cobol*\*) will use the default, and things on the right path will.

    And I just found your quote.
    such that cobol files always prompted me for the conversion code, ansi for the PC, 1143 for the mainframe
    I edited this post/removed my paragraph asking you for BC2 settings, because this quote helps explain how that was working.

    Let us know if how the *COBOL* file mask works for you, and if you run into any trouble implementing that solution.
    Last edited by Aaron; 11-Mar-2009, 05:29 PM. Reason: found quote
    Aaron P Scooter Software


    • #17
      And I just talked with one of our developers who had an easier to implement solution, but we don't have your mainframe to test against:

      Go to Tools -> FTP Profiles,
      Select your specific profile
      Transfer tab
      switch from Auto to ASCII transfers.

      This may automatically linewrap, use ANSI and will treat the files much like when you download them locally.

      Please be sure to test on **Test** or already **Backed up** data when for Comparing, and then testing Saving. (You can use a separate FTP Profile set to Auto and your current customized file format COBOL Ebcdic to test the Save correctly wrote your data back to your mainframe).

      Let us know if this works better for you.
      Aaron P Scooter Software


      • #18
        We're getting closer

        I hope I haven't mucked things up by changing too many things at a time. I'll include attachments so the results are in no doubt.

        Here are my settings for the FTP profile (attach 1)
        My file formats for COBOL ebdcic are attach 2 & 3
        My file formats for the PC files (at least I think that's what I'm specifying are attach 4 & 5
        The resulting files are shown in attach 6 (note the correct Swedish characters on the left and the incorrect ones on the right)


        • #19
          Attachment 6 couldn't be uploaded to the previous append

          Here it is instead


          • #20
            Misc tab

            Go to the saved Folder Compare, go to the Session Settings, Misc tab, and uncheck all the file formats except for the custom COBOL Ebcdic.
            Sorry - but where was the Misc tab. Couldn't see it anywhere


            • #21

              These are two different solutions for tackling the same problem. You don't want to test both concurrently.

              1) The FTP solution should convert to ASCII, which may convert your text to ANSI and help with the wrapping. This would then not use your customized COBOL Ebcdic file format or the other customization. To make sure you are loading from the customized FTP Profile, and not another FTP Profile, open a new Folder Compare, click the Browse button next to the Folder Path (where you would type the path in). This dialog has two tabs, select the FTP tab, and manually load your FTP Profile with the Profile button. Since you can have multiple Profiles pointing to the same FTP site with a slightly different configuration (username, ip, port), please be sure you select your modified one.

              **Also, please test with already backed up files, in case the ASCII transfer does not work as expected.

              2) The alternative would be to use the default FTP settings, and attempt the Ebcdic conversion:

              In the screenshots, you show COBOL Ebcdic checked, and then unchecked. Did you recheck it before launching the Text Compare?

              Instead of a creating a number of screenshots, you can email us your support package (Help menu -> Support; Export) and we can take a look at your settings that way.
              I do not recommend attaching it to the forums, because it may contain information about your sessions and computer you do not want public. Please include a link back to the forum post if you email us.

              The File Format's dialog should have just the COBOL Ebcdic file format checked (though, in theory, you should also be able to check the Cobol rule, since COBOL Ebcdic is higher in the list it will be used first on the right side. So, try once with just Ebcdic checked, then try a second time with both checked.

              If that isn't working, then try:
              Cobol rule associated with .cbl on the top.
              Cobol Ebcdic rule right below that, associated with *.*

              A screenshot of your now working Folder Compare may help us figure out a better filter solution. You can email this information if you wish to keep it private.

              The Misc tab is a BC3 Pro feature that allows you to control the File Format checks on a session by session basis. For now, we can test the same functionality by globally changing the options under Tools -> File Formats.

              In summary, I recommend emailing us:
              -You BC Support package (Help meu -> Support; Export)
              -screenshots of your Folder Compare showing the selection of two files you want to compare and the full BC3 screen.
              -screenshots of the files loaded when using the different file format combinations:
              a)Ebcidic with *cobol* checked
              b)Ebcidic with *cobol* checked and Cobol with *.cbl checked
              c)Cobol moved to top and checked, Ebcdic changed to *.* and moved right below (2nd position) also checked.
              -Let us know if the FTP solution works (but doesn't look like it did from your screenshots)
              -A link to this forum post, so we can track/respond back here and via email.

              Sorry this is taking so long to troubleshoot. It is hard for us to test exactly how BC will compare against your mainframe without access to one.
              Aaron P Scooter Software