Announcement

Collapse
No announcement yet.

Wrong subfolder for auto-saved sessions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wrong subfolder for auto-saved sessions

    Hi,

    I keep having the following problem: when I start a new session by right-clicking on two folders in the windows explorer, the session then appears under "auto-saved sessions" in the subfolder "more than 6 days ago" (and there is no other subfolder displayed than this one). I would expect it to appear under "Today", right?

    Thierry

  • #2
    I saw a similar bug in the past. I just set "Max Auto-Saved Sessions" to zero in the options. That's one way to fix it.

    Comment


    • #3
      I dropped the question, hoping it would be fixed in an upcoming release, but as of 3.0.4, it is not. The bug seems to appear when you import BC3 settings into a fresh install. Any news?
      Thanks
      Thierry

      Comment


      • #4
        Thierry,

        I haven't run into this problem before. Do you remember if you deleted existing settings when you did the import, or did you add to the existing settings?
        Chris K Scooter Software

        Comment


        • #5
          Hi Chris,

          I do not remember deleting anything: as far as I remember, I just installed BC3, checked that it was working, then selected Tools > Import Settings... I'm surprised you cannot reproduce the bug: it appears on all the computers where I installed it, and then loaded a configuration exported from another machine. The only machine that does not have the problem is the one where I have set things up "from scratch", not importing anything. If you want, I can give you one of the "guilty" .bcpkg I used.
          Thanks for your help

          Comment


          • #6
            Thierry,

            I've tried reproducing this, but I haven't had any luck so far.

            Is the date and time correct on all the computers you're using to export and import settings? If one of the computers has the wrong date it might make things show up as older than they should be.

            Also, please send me one of the problem .bcpkg files and I'll try duplicating the problem. You can send it to support@scootersoftware.com and I will investigate further.
            Chris K Scooter Software

            Comment


            • #7
              Hi Chris,

              I finally found the configuration that causes the bug! It is linked to the Regional & Language Options (in Control Panel, Windows XP). All my machines use "English (United States)" as main setting in "Regional Options", but deeply customized. In particular, on the machine where "it works", and was the source for exported configurations, the short date format is "dd-MM-yyyy". On the machines where "it does not work", the short date format is "dd-MMM-yy". I did a few tests, and to summarize:
              - if the short date format is "dd-MM-yyyy", sessions are correctly sorted in time
              - if the short date format is "dd-MMM-yy", new sessions are always "more than 6 days ago".

              Can you now reproduce it?
              Thanks,

              Thierry

              Comment


              • #8
                Thierry,

                Thanks for the follow up. I reproduced the problem after changing the short date format. We'll have this fixed in our next release of Beyond Compare.
                Chris K Scooter Software

                Comment


                • #9
                  Great news. ^_^
                  Cheers
                  Thierry

                  Comment

                  Working...
                  X