Announcement

Collapse
No announcement yet.

18414 FC failure to show folder content

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 18414 FC failure to show folder content

    On the Skins folder here http://i.imgur.com/hGLoeC4.png the BC display shows no content, yet the BC display shows a non-zero size, and an error message saying the folder is non-empty, and Explorer shows content - one file tree.bmp.

    This looks like a BC fail to me.

    If there is any way this could be NOT a BC fail , please say. Else tell me what information I can give to help get this fixed.

  • #2
    Here's a further instance: http://i.imgur.com/UNfU92F.png

    Then I pressed CTRL+F5. The content appeared.

    Comment


    • #3
      This is a duplicate report as your other thread, which included both BC4 and BC3 screenshots.

      As asked in the other thread, what is displayed in Windows Explorer when viewing the location? You had a screenshot showing the folder was also empty in Explorer when it should not have been. Please provide information as to why the screenshot of Explorer showed an empty folder.
      Aaron P Scooter Software

      Comment


      • #4
        Originally posted by Aaron View Post
        This is a duplicate report as your other thread
        No. This is a report specifically about failure to show folder content.

        Originally posted by Aaron View Post
        As asked in the other thread, what is displayed in Windows Explorer when viewing the location?
        Precisely what the report's screenshot shows.

        Originally posted by Aaron View Post
        You had a screenshot showing the folder was also empty in Explorer when it should not have been. Please provide information as to why the screenshot of Explorer showed an empty folder.
        Please do not get confused by the instances in another report. This report does not include any instance of Explorer showing an empty folder.

        Again: if there is any way this (the instance in this report) could be NOT a BC fail , please say.

        Comment


        • #5
          Sorry, this is not something we can help troubleshoot without your help answering our questions. We've had no other reports of this behavior, so it is unique to your system and hardware, and the first troubleshooting step is to verify Explorer. If you are unwilling to do so, there is nothing more we can do for this report.
          Aaron P Scooter Software

          Comment


          • #6
            Originally posted by Aaron View Post
            Sorry, this is not something we can help troubleshoot without your help answering our questions.
            I'm not asking you to troubleshoot it.

            Originally posted by Aaron View Post
            the first troubleshooting step is to verify Explorer. If you are unwilling to do so,
            I have already provided the Explorer information you requested. It is in the screenshot in the root post.

            Regardless, can you tell me: Are there any circumstances under which BC is supposed to show no content for a folder but non-zero size for that folder?
            Last edited by chrisjj; 03-Nov-2014, 10:24 AM.

            Comment


            • #7
              If Explorer also shows inconsistent or odd behavior, then that instability will apply to other programs on your system, including Beyond Compare.
              Aaron P Scooter Software

              Comment


              • #8
                Originally posted by chrisjj View Post
                Are there any circumstances under which BC is supposed to show no content for a folder but non-zero size for that folder?
                No. If a folder has a non-zero size then using "Suppress filters" should show files that add up to that size. Since it appears that isn't the case, steps for how you got into that state would help immensely.
                ZoŽ P Scooter Software

                Comment


                • #9
                  Originally posted by Aaron View Post
                  If Explorer also shows inconsistent or odd behavior
                  I don't know why you keep on suggesting that Aaron. The screenshot shows no odd behaviour in Explorer. Only in BC.

                  Originally posted by Craig View Post
                  No. If a folder has a non-zero size then using "Suppress filters" should show files that add up to that size. Since it appears that isn't the case, steps for how you got into that state would help immensely.
                  I'll takes that as a No to "Are there any circumstances under which BC is supposed to show [with filters suppressed] no content for a folder but non-zero size for that folder?". Thanks. Will do.

                  Comment


                  • #10
                    Using S:\BCtestL+R.zip attached and BCsupport.zip attached:

                    1 On session "BCtest 1 Prep L", do Sync Now, F5 -- see http://i.imgur.com/HZabwWT.png
                    2 On session "BCtest 1 Prep R", do Sync Now, F5 -- see http://i.imgur.com/O5MFnD0.png
                    3 On session "BCtest 2 Run", do Sync Now -- see http://i.imgur.com/AmVQE4i.png ( log attached )
                    4 Expand this folder: http://i.imgur.com/BA9qlnE.png -- see no content, yet size non-zero.
                    5 Inspect in Explorer: http://i.imgur.com/Oec6JoV.png -- see content.
                    Attached Files

                    Comment


                    • #11
                      Hello Chris,

                      Thanks for the detailed steps and sample files. The problem did not reproduce with these steps, however we were able to reproduce it with 2 additional steps:

                      6) Go back to open tab BCtest1 Prep R, Sync Now, Refresh
                      7) Go back to BCtest 2 Run, Sync Now

                      This was reproducible in BC3, but has been fixed in BC4. Please verify that the steps you follow is also fixed when using BC4. I'll open a tracker entry for BC3; the workaround is to perform a Full Refresh in BC3, which will then allow the sync to load the subfolders and work normally.
                      Aaron P Scooter Software

                      Comment


                      • #12
                        Originally posted by Aaron View Post
                        6) Go back to open tab BCtest1 Prep R, Sync Now, Refresh
                        7) Go back to BCtest 2 Run, Sync Now
                        Here, that does not reproduce the problem on that folder, but does on a different folder: http://i.imgur.com/yMzE43L.png

                        Originally posted by Aaron View Post
                        I'll open a tracker entry for BC3; the workaround is to perform a Full Refresh in BC3, which will then allow the sync to load the subfolders and work normally.
                        Here, that did fix the reported problem, but the result was a sync failure, saying "The directory is not empty" http://i.imgur.com/cWXnP4U.png . Repeating the Full Refresh and Sync Now gave success: http://i.imgur.com/72n0OV4.png .

                        Originally posted by Aaron View Post
                        This was reproducible in BC3, but has been fixed in BC4. Please verify that the steps you follow is also fixed when using BC4.
                        Verified not occuring in 18847:http://i.imgur.com/JrgXx68.png .

                        Thanks Aaron and Craig.

                        Comment

                        Working...
                        X