Announcement

Collapse
No announcement yet.

Editing Disabled for Comma Delimited Files

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Editing Disabled for Comma Delimited Files

    Hi guys,

    I'm trying to edit large comma delimited files. When I launch BC, I go into "Data Compare" - which tells me "Editing Disabled" - but I need it as it gives me a nice column delimited view w/out actually changing the file from CSV format - Kinda like Excel when I open up a CSV. Folder Compare seems to provide the same great viewing functionality.

    But I'm finding I can't make edits in this view - I need to either open in text-compare (which gives me an ugly long string of commas on each line) or right-click > open with text edit, which suffers from the same visibility issue.

    Is the lack of functionality intentional here or am I missing something?

    Thanks in advance for any assistance.

  • #2
    Hello,

    By default, our settings should allow editing of CSV files in the Data Compare.

    We do have options that can be enabled to prevent editing, usually in cases where editing would be undesirable or could result in corrupting data. For example: Excel files have editing disabled because any save would replace the .xls file with a plain text equivalent. Another example: if you launched BC3 from a version control system, we usually instruct the user to configure /ro1 or /ro2 to prevent writing over the version protected file.

    If you are certain you aren't in a case like this, you can disable the editing disabled behavior if we can find which option is triggering it. It might be in the Tools menu -> File Formats, select the gold icon Comma Separated Values data format, and in the Conversion tab is there a conversion and Disable Editing enabled?

    Or is it in the Data Compare's Session Settings, Specs tab?
    Aaron P Scooter Software

    Comment


    • #3
      Hi Aaron,

      Thanks for the response. My session settings don't disable editing:

      http://imgur.com/iAbiABg

      The file format also doesn't disable editing:

      http://imgur.com/Btts1G4

      But when I open up Beyond Compare 3.3.12, start a new Data Compare session, I get greeted by this:

      http://imgur.com/tPyAn4t

      I then drag and drop my two CSVs, and the comparison works perfectly, but I'm unable to make edits in here. Any other idea as to what might be breaking for me? I have the standard edition, build 18414 and I'm operating in a Windows 7 Enterprise environment.

      Thanks again for your help!

      Comment


      • #4
        Hello,

        It doesn't look like you've opened/loaded a CSV file in that last screenshot. Without a loaded .csv file, we can't edit it. If you create and load a simple test .csv (with a couple columns and rows), this allows editing like you expect, correct?
        Aaron P Scooter Software

        Comment


        • #5
          I did drag-and-drop two csv files in there (here's the fourth screenshot from my last message again):

          http://i.imgur.com/ugtXufs.png

          I'm unable to make changes on this screen.

          The only way to make changes is to right click > "Open with text Edit". By comparison, when I open CSVs (or other files) in a "Text Compare" session - I'm always able to make changes directly on the screen, which is what I'm expecting here but can't seem to unlock.

          Comment


          • #6
            Hello,

            Editing Disabled doesn't appear in that screenshot. If you click in the Line Details area (F2), can you edit the text in this area?

            BC3 doesn't support editing in the top pane; the edits themselves are done in the bottom status bar.
            Aaron P Scooter Software

            Comment


            • #7
              Editing Disabled doesn't appear in that screenshot. If you click in the Line Details area (F2), can you edit the text in this area?

              BC3 doesn't support editing in the top pane; the edits themselves are done in the bottom status bar.
              Ok, thanks, so I guess the functionality I expected was not there but I am able to edit elements in the Row Details area w/ F2 or Right-Click>Edit for each element. Thank you.

              Comment


              • #8
                Hey Aaron,

                I have a follow-up question. I'm noticing that when I open in Data Compare 3, it picks up strings and what have you just fine. But it treats my numbers as numbers.

                So it views "02" and "002" as the same, and likewise, I'm unable to make edits with leading zeros. Is there a way to set it to recognize all elements as strings - so I can keep my leading 0s?

                Comment


                • #9
                  Hello,

                  On the Home screen, in the Saved Sessions list, in the Edit session defaults folder, select Data Compare. Here you can select 'Edit default' for default column handling, and switch Type from Detected to Text if you want to override detection and set it to always be text. Or, you can right click a specific column when viewing files, and switch from Numeric/Detected to Text on a per column basis.
                  Aaron P Scooter Software

                  Comment


                  • #10
                    Originally posted by Aaron View Post
                    Hello,

                    On the Home screen, in the Saved Sessions list, in the Edit session defaults folder, select Data Compare. Here you can select 'Edit default' for default column handling, and switch Type from Detected to Text if you want to override detection and set it to always be text. Or, you can right click a specific column when viewing files, and switch from Numeric/Detected to Text on a per column basis.
                    Excellent, thank you Aaron!

                    Comment

                    Working...
                    X