Announcement

Collapse
No announcement yet.

Beyond compare sends wrong mdtm timestamp

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Beyond compare sends wrong mdtm timestamp

    I have yet another timestamp problem when synchronizing local files to a IIS 7.5 FTP server, client and server in UTC+01 with DST.

    When I synchronize with a regular FTP Site, everything works fine.

    When synchronizing with an FTP site using virtual host names, timestamps are correctly displayed, but when uploading a new file, the timestamp on the server and displayed in Beyond compare is 2 hours off (2 hours older than it should be). I did test this on the same server, restarting ftp services and beyond compare.

    The problem seems to be in the MDTM command issued: For the same file, BC uses the following command to synchronize with a standard FTP site:
    Code:
    MDTM 20120724143520 file.txt
    with the ftp site using a virtual host name it's
    Code:
    MDTM 20120724123520 file.txt
    As far as I understand, this command should always send the local file's UTC time, independently of the server's time zone.

    I tried unsuccessfully various timezone settings in the FTP Profiles settings.

    Is there some way to deactivate server timezone detection, or any other workaround? Is this a known problem?

  • #2
    MDTM isn't standardized. Some servers expect it in the server timezone and some expect it as UTC; we differentiate between them based on how they report MDTM support in response to the FEAT command. Using virtual host names really shouldn't affect things unless it makes IIS work or report things differently.

    BC doesn't currently have any way to adjust how the timestamps are set, but we may be able to tweak things by special-casing IIS support. Email full logs for both connections to support@scootersoftware.com and I'll look into it further. Please include a link to this thread in the message.
    ZoŽ P Scooter Software

    Comment


    • #3
      Originally posted by Craig View Post
      MDTM isn't standardized.
      Ok that explains a lot.

      I've just sent you two log files. Thank you for your help!

      Comment


      • #4
        I found the solution, in case somebody else is having the same problem:

        In FTP Profiles, for the profile used (default) in the Connection tab, uncheck "Use HOST before login".

        Comment


        • #5
          Hello, I just registered so I could share what I found. Unchecking "Use HOST before begin" didn't fix my issue, while manually setting the time zone did the trick. This is what I did (Italy here):
          Tools >
          FTP Profiles... >
          ftp://YOUR-USERNAME@YOUR-HOST >
          General >
          Server >
          disable "Use default"
          Time zone >
          (UTC +00:00) Dublin, Edinburgh, Lisbon, London

          Comment

          Working...
          X