Announcement

Collapse
No announcement yet.

bc4 PASS failed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • bc4 PASS failed

    Did anything change from v3 to v4 regarding PASS command? previously used BC3 to connect to MVS mainframe. Left company and returned and had V4 installed. Connects and sends user successfully but then fails on PASS command. I can cut the password from the dialog box and paste into tso logon session and it works fine. Other co-workers still on V3 have no issues.

  • #2
    Nothing was intentionally changed for PASS specificially. I think the timing for when the server's character encoding is applied changed though, so it only takes effect after a successful login. If your password has any non-ASCII characters (accents, CJK, emoji, etc) it probably won't work anymore.
    ZoŽ P Scooter Software

    Comment


    • #3
      Thanks for the quick reply. We do have a password requirement to have a # or $, but that is it. I would assume that if there were firewall issues that would prevent the connection in the first place. This is one of my favorite tools, and was quite happy to see that it was authorized for use here. authorized but unsupported so I'm on my own to figure this out.

      Comment


      • #4
        Hello,

        One quick test is you can install the BC3 trial and verify it works on the same machine with the same connection and profile settings. BC3 and BC4 can be installed at the same time on Windows, with separate install folders and settings:
        http://www.scootersoftware.com/download.php?zz=dl3_en

        This way, we can make sure BC3 works (and this would also get you up and running). We can then troubleshoot the difference between BC3 and BC4 behavior.

        Would it be possible to get a pair of connection logs, so we can see if there are any differences in logged behavior? You can enable the debug logging in BC4 under the Tools menu -> Options, Tweaks tab, and scroll to Log Panel and enable the additional options for ftp and debugging. In BC3, hit Ctrl+Shift+T to enter the Tweaks dialog and in the Folder Views tab enable the debug logging. Then email both logs to support@scootersoftware.com along with a link back to this forum thread for our reference.
        Aaron P Scooter Software

        Comment


        • #5
          Thank-you again for all your help. As it turns out, they added a new security requirement in order to submit FTP jobs. Once that was granted this morning all is good.

          Comment

          Working...
          X