Announcement

Collapse
No announcement yet.

SFTP not working when connecting to hosting company

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SFTP not working when connecting to hosting company

    I have an FTP account set up on my hosting provider. I've tested with Filezilla and it works using SFTP. When I try in BC, it looks like it is connecting, but it's not displaying any files. In the log, it looks like it's going to passive move and it just sits there until it times out. Not sure what to do, but here is the log:

    11/8/2017 11:27:53 AM Stat> Connected.
    11/8/2017 11:27:54 AM Recv> 220 ProFTPD 1.3.5b Server (ProFTPD) [216.70.106.90]
    11/8/2017 11:27:54 AM Sent> AUTH TLS
    11/8/2017 11:27:54 AM Recv> 234 AUTH TLS successful
    11/8/2017 11:27:54 AM Sent> USER xxxxxxxx
    11/8/2017 11:27:55 AM Recv> 331 Password required for xxxxxxxx
    11/8/2017 11:27:55 AM Sent> PASS ********
    11/8/2017 11:27:55 AM Recv> 230 User xxxxxxxxx logged in
    11/8/2017 11:27:55 AM Sent> FEAT
    11/8/2017 11:27:55 AM Recv> 211-Features:
    11/8/2017 11:27:55 AM LANG en-US*
    11/8/2017 11:27:55 AM EPRT
    11/8/2017 11:27:55 AM EPSV
    11/8/2017 11:27:55 AM MDTM
    11/8/2017 11:27:55 AM SSCN
    11/8/2017 11:27:55 AM TVFS
    11/8/2017 11:27:55 AM MFMT
    11/8/2017 11:27:55 AM SIZE
    11/8/2017 11:27:55 AM PROT
    11/8/2017 11:27:55 AM CCC
    11/8/2017 11:27:55 AM PBSZ
    11/8/2017 11:27:55 AM AUTH TLS
    11/8/2017 11:27:55 AM MFF modify;UNIX.group;UNIX.mode;
    11/8/2017 11:27:55 AM REST STREAM
    11/8/2017 11:27:55 AM MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX .mode*;UNIX.owner*;
    11/8/2017 11:27:55 AM UTF8
    11/8/2017 11:27:55 AM Recv> 211 End
    11/8/2017 11:27:55 AM Sent> OPTS UTF8 ON
    11/8/2017 11:27:56 AM Recv> 200 UTF8 set to on
    11/8/2017 11:27:56 AM Sent> TYPE A
    11/8/2017 11:27:56 AM Recv> 200 Type set to A
    11/8/2017 11:27:56 AM Sent> SYST
    11/8/2017 11:27:56 AM Recv> 215 UNIX Type: L8
    11/8/2017 11:27:56 AM Sent> TYPE A
    11/8/2017 11:27:56 AM Recv> 200 Type set to A
    11/8/2017 11:27:56 AM Sent> PWD
    11/8/2017 11:27:56 AM Recv> 257 "/" is the current directory
    11/8/2017 11:27:56 AM Sent> PBSZ 0
    11/8/2017 11:27:57 AM Recv> 200 PBSZ 0 successful
    11/8/2017 11:27:57 AM Sent> PROT P
    11/8/2017 11:27:57 AM Recv> 200 Protection set to Private
    11/8/2017 11:27:57 AM Sent> PASV
    11/8/2017 11:27:57 AM Recv> 227 Entering Passive Mode (216,70,106,90,163,165).
    11/8/2017 11:28:58 AM Sent> QUIT
    11/8/2017 11:28:58 AM Recv> 221 Goodbye.
    11/8/2017 11:28:58 AM Stat> Disconnected.
    11/8/2017 11:30:01 AM Unable to load sftp://xxxxxx@21.7.16.9/: Read timed out.

    I hope it's something simple. Thanks.

    - PR

  • #2
    It might help to try active FTP instead of passive. To change the setting, open Tools > Profiles. Select the profile for your server. Go to the Connection tab. Uncheck Passive transfers (PASV), then Save.
    Chris K Scooter Software

    Comment

    Working...
    X