Announcement

Collapse
No announcement yet.

DATA Compare Ignore Unimportant Differences?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DATA Compare Ignore Unimportant Differences?

    Hi there!
    I am trying to ignore unimportant differences in my data compare.
    For instance, two files are spelt identically, but one has a captial and the other does not - so they show up as different.

    Another differences is when one file has one space between words and the other has two. They are spelt the same, but they show up as different.

    I have found advice for this in folder and text compare, but not data compare.

    Thanks!

  • #2
    Hello,

    Unimportance is controlled either per column in the data compare, or a default for all columns. This is per session, which can also have a default set for all future sessions.

    To set the session defaults, go to the Home screen, in the Saved Sessions list, Edit session defaults, and select the Data Compare. Then either select a specific column or click the "Edit default" button in the lower right.

    Here you can set a few different options of unimportance, such as a Character case option or numeric tolerance for numeric columns.

    Alternatively, you can set this for a specific column within your specific session comparing two files, in the Session menu -> Session Settings, Columns tab.

    Please let us know if you have any questions.
    Aaron P Scooter Software

    Comment


    • #3
      Thank you Aaron! That helps a lot!

      Comment


      • #4
        I have another troubleshooting question. This only began Monday, so I don't know if I accidentally clicked the wrong button or something and it only happens to the only spreadsheet. But I am comparing two XLSX documents and will change the order in which the columns appear and click refresh. When I do this, the one file is completely changed (not just the column order) - the data within each column is completely altered to Dates and 'undef') && $obj->parsedDate ....

        Any idea why this might be happening or how I can restore the previous data???

        Thanks!

        Comment


        • #5
          Hello,

          The first thing to check is in the Tools menu -> File Formats dialog, the MS Excel format (gold icon for Data Compare) has the Factory defaults button disabled in each tab. If it is enabled, that means you can click it to give the current tab the Factory default settings.

          Next, when you view your files in the Data Compare, in the Session menu -> Session Settings, Format tab, are they detecting as MS Excel? You can also see this information in the main pane in the upper status bar found in each pane.

          Would it be possible to post or email us a screenshot? If you email us, you can also include a link back to this forum thread, your BCSupport.zip from the Help menu -> Support; Export, and a pair of sample files. Our email is support@scootersoftware.com
          Aaron P Scooter Software

          Comment


          • #6
            Thanks Aaron!
            I am off to a meeting, but will try that soon.

            Another quick question (I think quick). In data compare again, I want to change all the columns to UNIMPORTANT, except the key column. Is there a quick way to do this, or do I have to right click each column individually?

            Thanks for all of your quick responses
            KS

            Comment


            • #7
              You can change the default in the Data Compare's Session menu -> Session Settings, Columns tab. Here you can Edit Defaults, or select any specific column and edit it. You can set the default to Unimportant, and then edit the specific Key column.
              Aaron P Scooter Software

              Comment


              • #8
                Perfect!

                Ok - sorry - another question. Like the error one from before, but this is slightly different.

                When I make changes (especially editing file titles) and click Reload, there are often "Conversion Errors".
                First, I don't know what is causing this ...
                But then I also I don't know how to Undo what I did... do I have to start at the beginning again?

                Thanks for the excellent and prompt responses Aaron! I appreciate it
                KS

                Comment


                • #9
                  Hello,

                  I see your email. If you'd like to continue troubleshooting that way, that is fine. The screenshot did not seem to show the Conversion Error, but a key column alignment issue. Just let us know how you would like to work that out.
                  Aaron P Scooter Software

                  Comment

                  Working...
                  X