No announcement yet.

Unable to copy/delete ... Access is denied?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to copy/delete ... Access is denied?

    I am setting up a new laptop running Win 7 Pro 64 bit and BC Version 3.3.3 (build 14128).

    I connected an external USB hard drive to sync some files and got errors such as this:

    "2012-01-15 00:47:17 Unable to delete f:\d\Home\Computer\SONY VGN-NS130E\N360S200.exe: Access is denied"

    The files intended to be deleted or overwritten are not read-only. What prevents BC from deleting or overwriting the files on the external USB hard drive?

    Please help. Thanks!

  • #2
    Check the permissions on the USB drive. Win 7 is a lot more picky about exactly who can do what than earlier versions of Windows. If you (or at least the user you are running BC as) aren't the owner of the files, someone with administrator rights may need to give that user permission to delete file in that directory or the whole USB drive.


    • #3
      I am logged in as an administrator. I can also copy orphaned files to/from the USB hard disk. Just can't delete/overwrite existing files on the USB drive.


      • #4
        Right click on Beyond Compare's shortcut and select "Run As Administrator". Windows 7 doesn't run programs with full admin rights unless you "Run As Administrator".
        Chris K Scooter Software


        • #5
          OK I will give that a try. Thanks!


          • #6
            Seemingly random "Access is denied" errors during network copy

            I am having a similar problem that affects copies with BC from my Win7 machine over the network to a Mac (running OS X 10.7.2). It seems to primarily (if not exclusively) affect files that I have updated on the Windows machine and am copying over to the Mac. Running BC as administrator unfortunately does not get rid of the "Access is denied" errors.

            I initially thought the problem was with permissions on the files that I am updating on the Mac. However, they are not read-only on the Mac and I can even delete them from within BC by selecting them on the Mac side of the folder comparison. Even after the old file is deleted from the Mac, I cannot copy the updated version of it from Win7, so it seems there is something going on on the PC side. However, if I do the copy manually in Explorer (or from the Mac), there are no "Access is denied" errors, everything works just fine; the same files also copy without difficulty from within BC to an external (NTFS-formatted) hard disk.

            Any idea what could be going on here?

            Thanks in advance,


            • #7
              I have found that an older external USB hard drive has the access problem while a newer one does not. Go figure.


              • #8

                Thanks for the report. So it only occurs randomly when overwriting files on the Mac side. For the "random" aspect, does it fail and then if you retry the same file it could then copy and work? Or once a pair of random files fails, it will give the "Access denied" error if you attempt the copy of that file again? Or does it always fail for any operation where an overwrite would occur?

                If you can see it repeat for a specific pair of files, do you see an error if you then immediately call up Windows Explorer or My Computer, and try the same copy to the Mac (using Explorer instead of BC3 to perform the copy)?
                Aaron P Scooter Software


                • #9
                  Thanks for the update. If there is newer firmware for the older external device, that might help. And the older device is just connecting over USB2? Does the older device also support other modes, such as acting as a NAS device if plugged directly into the network?

                  And, you are able to perform the delete using Windows Explorer, correct? Or does this give an error on the older device, too?
                  Aaron P Scooter Software


                  • #10

                    Thanks for the reply. Once it decides that "Access is denied" for a file, the error recurs more or less consistently with that file -- even after I delete the Mac file that is to be replaced and usually after I restart BC3. It is therefore probably not "random" in the sense that BC is being arbitrary, but there is no noticeable pattern as to which files are affected or what I can do to prevent it. It does not occur with every overwrite, but it seems to happen only to updated files, not new ones.

                    Is there any particular information I should look for the next time this happens?


                    • #11
                      Next time it happens, one good test would be to try the same copy on just one file a couple of times (to see if it is reproducible), and then try the exact same copy of that one file with Windows Explorer. You should be able to open two Explorer windows, and copy/paste the folder paths from BC3 into Explorer and open the two locations; then select the file and try to copy from the same source to the same destination. Does this work or throw additional errors?
                      Aaron P Scooter Software


                      • #12
                        OK, this evening I tried to use BC3's "update" function to copy new versions of several files from my PC over the network to my Mac, where older versions of the files are stored. One file did not update successfully; BC3 reported "Access is denied" while trying to overwrite the old file on the Mac and apparently deleted the old file while doing so: it no longer appears in BC3, Win7 Explorer or the Mac Finder.

                        Even though the file to be overwritten is gone, I continue to receive "Access is denied" errors when attempting to copy this particular file to that one location using BC3. Attempting to "update" or "copy" a second time returns the same error. The file does not appear to have any strange permissions set (see screenshot). Restarting BC3, running BC3 as administrator, restarting the Win7 machine and restarting the Mac also do not help: "Access is denied" keeps coming up.

                        Oddly though, I was able to use BC3 to copy the same newer file from the PC to a backup USB stick, where it successfully overwrote the old version of the file without reporting any errors.

                        In the interest of figuring out what is going on, I have not yet tried to copy using Windows Explorer as you described. However, on the many occasions when this error has come up in the past, I have never had any problem using Windows Explorer or the Mac Finder to copy the files in question. Only BC3 seems to think that "Access is denied"

                        What could be going on here?


                        • #13
                          Just a quick note: there seems to be a problem with the screenshot showing the file's security properties, which shows no checkmarks indicating permissions. This is a problem with the screenshot, not with the file: when I view security properties for the file that cannot be copied due to "Access is denied" errors, there are checkmarks under "Allow" for all items except "Special permissions". The users SYSTEM, andrew and Administrators all have Full Control, Modify, Read & Execute, Read and Write permissions for the file.


                          • #14
                            BC3's copy method uses a standard Windows method to perform the copy. It would be important to know if Explorer exhibits similar behavior. That would help let us know if there's a problem with the method we are using or if there is somehow another factor.
                            Aaron P Scooter Software


                            • #15
                              Just copied successfully with Explorer. As in the past, it gave no errors.