Announcement

Collapse
No announcement yet.

Remember Default File Format for a Folder Compare Session

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remember Default File Format for a Folder Compare Session

    For example, a folder compare session contains many text files. I want to compare them with a specified format. When I open a child session, it uses the default format. I have to manually switch to the format I want again and again.

    So is it possible to define the default File Format for a parent session?

    I tried the [Use for all files within parent session] option after I selected the specified format. But could not achieve the purpose.

  • #2
    Hello,

    Use for all files within parent session should be the option you are looking for. You would need to re-save the parent Folder Compare session and re-open that parent Folder Compare session in the future to use those settings.

    You can also go to the Folder Compare's Session menu -> Session Settings -> Misc tab. Here you can disable all file formats, and leave only the one you want to use enabled. This one file format could be associated with "*.*". Then, in the Tools menu -> File Formats, uncheck this one file format. That way, default/new folder compare sessions will not use it, since it is unchecked in the main File Formats dialog, but the specific session would use only it.
    Aaron P Scooter Software

    Comment


    • #3
      Thank you.
      Really tricky for me. I think the Knowledgebase should include such an article.



      The 1st method won't work for me.

      My operations:
      Open the folder compare session.
      Open a child session from it.
      Select the file format I want.
      Open [Session Settings]. Select [Use for all files within parent session]. Click [OK].
      Close the child session.
      (The parent session doesn't have * in the name. Anyway,) Save the parent session.
      Close the parent session.
      Reopen the parent session.
      Open a child session. Still the default file format is used. Not the one I want.

      Is there anything I missed?



      The 2nd method:
      This one file format could be associated with "*.*".
      This is the key for me.
      I left the Mask empty for that format before. This caused the format never to be used.

      Comment


      • #4
        Hello,

        Thanks. Sorry for the confusion, I misread the initial part of your first post. The Specs and Formats tabs are not saved settings when using the Apply to Parent Session option. Only the options that can be set as default (Importance, Alignment, Replacements) can be pushed up this way.

        The mask does need to be set to be used. A blank mask would allow you to pick a file format manually, but have it never applied automatically.
        Aaron P Scooter Software

        Comment

        Working...
        X