Announcement

Collapse
No announcement yet.

13298 Workaround for FAT32 file corruption on copy with accent in name?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 13298 Workaround for FAT32 file corruption on copy with accent in name?

    I'm hoping a user here has a workaround to this.

    When BC copies a FAT32 file the name of which differs from another only in accent, the copy can end up having the content of the wrong file. See attached. This is particularly troublesome for me, since it corrupts the backups of FAT32 drives I'm making using BC. Windows Explorer fails similarly, but I know some other BC users don't get this problem, so I'm hoping there is a workaround within BC.

    Support suggests the only safe thing is to change the filenames, but this is of course not an option in a backup. Does anyone else have a workaround within BC? Thanks.

  • #2
    Hello Chris,

    If there are any other users with insight or have any workarounds, we would definitely appreciate hearing about them. The bug with Windows is an issue with Windows accessing the FAT device; an NTFS device would not exhibit this problem. All applications will hit this issue.

    @Chris did you get a chance to contact Microsoft?
    Aaron P Scooter Software

    Comment


    • #3
      Further info.

      I find this corruption occurs on a machine with Language for non-Unicode programs at English (United States), but not on a machine with it set to English (United Kingdom).

      Rather mysterious, since Windows says "It does not affect Unicode programs" and I thought BC was a fully Unicode.

      And making that change on the US machine works around the problem... but note this change is for all non-Unicode programs and all users, so risks breaking other operations relying on the setting.

      If anyone has a better workaround, please say.

      Comment


      • #4
        As I mentioned in my first email about this, it affects every Windows application, Unicode or not. Calling notepad.exe with one of the affected filenames will show the same behavior. Since it doesn't occur on NTFS drives, it's either a bug in the FAT32 driver or an intentional compatibility tweak. Changing the Language for non-Unicode programs either disables that tweak or affects a different set of characters.

        If Microsoft doesn't get back to you with details on disabling the behavior, the only safe thing to do is avoid the situation. Either convert your backup drive to NTFS or rename the files. Just changing the filesystem is better from a backup point of view, but I still recommend renaming the files so you aren't caught by it again copying the files to a flash drive or to another computer without whatever tweaks are necessary.
        ZoŽ P Scooter Software

        Comment

        Working...
        X