Announcement

Collapse
No announcement yet.

Copy Folder Contents Only

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Copy Folder Contents Only

    I THOUGHT I'd asked this before a while back, but a search on my username came up with nothing.

    I have a folder (let's call it "Full"), with both file contents AND other folders with File contents. I know I can "open all sub-folders" to see contents. I have another folder (we'll call it "Empty").

    From "Full", I want to copy the FILEs (CONTENTS only *NO folder structure) to "Empty". So if in FULL I have 100 folders with 1203 files total, EMPTY will now have 1203 files and NO folders.

    I KNOW somebody gave me a solution, but I can find nothing in my searches. Thanks in advance for any help!!
    -Grant

  • #2
    Load "Full" on one side, then use "Expand All" and "Select All Files". Once that's done use the "Copy to Folder" command and change the "Folder structure" option in the confirmation dialog to "Don't keep folder structure". Change the target to "Empy", and you're done.

    The other way to do it is to load "Full" and "Empty" on the two sides, the folder structure option to "Ignore Folder Structure", either from the "View" menu or the dropdown toolbutton next to the display filters. Right now if you copy files across to an empty space when "Ignore Folder Structure" is active it copies it to the root of the other base folder ("Empty"), so it will be copied without any folder structure. We may add an option to change that at some point, but for now it will do exactly what you want, and you can compare the files afterwards. The "Copy to Folder" approach will always work.
    ZoŽ P Scooter Software

    Comment


    • #3
      Craig, I did find the "Don't keep folder....' thing and had tried that, but it's grayed out. No matter which of your versions I try, that option is not available. In any case, the button, while grayed out, is selected, but when I copy it copies everything.

      I'm using version 2 on Windows 7 (I HATE "7" BTW).

      Comment


      • #4
        Make sure you're using "Select All Files" and not "Select All (Ctrl+A)". Whether the radio buttons are enabled or not depends on the selection.
        ZoŽ P Scooter Software

        Comment


        • #5
          And... under the view menu (between Search and Tools), I have no choice to "Ignore Folder Structure"

          Comment


          • #6
            "Ignore folder structure" was introduced in BC3.
            ZoŽ P Scooter Software

            Comment


            • #7
              THAT did it. The "select all" thing... Thanks!!!!!!!

              Comment

              Working...
              X