Announcement

Collapse
No announcement yet.

10554 File corruption upon FTP

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 10554 File corruption upon FTP

    I copied HD>FTP (Mac OS X Server 10.3.9 003 - +GSSAPI) one folder containing 16 folders each containing 28-40 files of 1-8Mb each. One file in each of nine folders got truncated from 5-8Mb to 1-6Mb. The log was not saved.

    When I repeat this operation, what apart from the log should I save to aid investigation?

  • #2
    Hello Chrisjj,

    The Log, and full screen screenshots showing before and after transfer would be useful. Also are you running into this:
    http://www.scootersoftware.com/suppo...pdifferent.php

    If you run a Binary Content Compare, do the files come back as equal?

    If you set the FTP Profile (Tools menu -> FTP Profiles) to transfer in only Binary does that help?
    Aaron P Scooter Software

    Comment


    • #3
      > The Log, and full screen screenshots showing before and after transfer would be useful.

      Thanks.

      > Also are you running into this:
      "Text files (HTML, source code, etc) can be stored in a slightly different format on FTP sites, and that can make the file sizes increase or decrease by a small percentage. " ?

      No. "truncated from 5-8Mb to 1-6Mb" is more than a small percentage!

      > If you run a Binary Content Compare, do the files come back as equal?

      No.

      > If you set the FTP Profile (Tools menu -> FTP Profiles) to transfer in only Binary does that help?

      Transfer is Auto. How could that cause this failure?

      Comment


      • #4
        I think it's far more likely to be an issue with an auto-resumed transfer than anything related to ASCII transfers.
        ZoŽ P Scooter Software

        Comment


        • #5
          Originally posted by Craig View Post
          I think it's far more likely to be an issue with an auto-resumed transfer than anything related to ASCII transfers.
          How does one disable that in BC? Help Search "resume" finds nothing. Thanks.

          Comment


          • #6
            Upgrade to a server that doesn't have bugs or configure the one you're using to disable the REST command. We can consider adding an option to disable it; right now there isn't a way to do so, and it will always resume if it's a binary transfer, if we can immediately reconnect, and if the server says it handles resume correctly.
            ZoŽ P Scooter Software

            Comment


            • #7
              > Upgrade to a server that doesn't have bugs

              Which server is bug-free, and how have you proved it to be?

              > or configure the one you're using to disable the REST command.

              Sadly mere users do not have that option.

              > We can consider adding an option to disable it; right
              > now there isn't a way to do so

              May I ask why, since you apparently know this behaviour causes silent data corruption, there is no option to disable it?

              Comment

              Working...
              X