Announcement

Collapse
No announcement yet.

Can BC 2.4 integrate with VSS 6.0?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can BC 2.4 integrate with VSS 6.0?

    Hi, I have upgraded to 2.4 of BC. I see that this version has "Added support for checking in and out of most version control systems.". Does that include VSS 6.0.

    When I go to Option | Source control it only shows "No source control providers detected."

    /HŚvar

  • #2
    Re: Can BC 2.4 integrate with VSS 6.0?

    I have the same symptoms using the SUBVersion configuration control system

    Comment


    • #3
      Re: Can BC 2.4 integrate with VSS 6.0?

      Subversion does not include built-in support for the SCC API. These are the projects I know of that try to add support for it. I haven't tested any of them, and it appears most are beta at best, so comments on which ones work and how to set them up would be appreciated.
      <ul type="square">[*]SVNScc (free).[*]TortoiseSVN SCC Plugin (free). It may be included as part of the standard TortoiseSVN package.[*]Subway (free).[*]PushOk SVN SCC proxy (commercial, free trial).[*]sourcecross.org SCC Provider (free?). I couldn't find a working download link for this, but contacting the authors may work.[/list]
      ZoŽ P Scooter Software

      Comment


      • #4
        Re: Can BC 2.4 integrate with VSS 6.0?

        Yes, Visual SourceSafe 6 is supported and I have tested it with Beyond Compare. It's possible you don't have the necessary DLL installed, though I don't know why VSS would have that as an option.

        Check in your VSS/Win32 directory for a file named SSSCC.DLL, and check your registry at HKLM\Software\SourceCodeControlProvider\InstalledS CCProviders. It should have an entry labeled "Microsoft Visual SourceSafe" probably with a value of "Software\Microsoft\SourceSafe". If either of those are missing you must not have it installed; try running the VSS installer again and see if it adds it.
        ZoŽ P Scooter Software

        Comment


        • #5
          Re: Can BC 2.4 integrate with VSS 6.0?

          Thank you, now it works!

          Regards,

          HŚvar

          Comment

          Working...
          X