Announcement

Collapse
No announcement yet.

Delete fails in synch when scheduled

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Delete fails in synch when scheduled

    When I run a synch from a script everything works except deletes fail (although BC log says the deletes happened). When I run the same synch interactively the delete actually happens. The destination drive is a networked one. What can make the delete (unknowingly to BC) fail when running on a schedule but work OK interactively. The same user account is used in both cases and the network drive mapping is a permanent one. Machine is WinXP SP2 and destination is a Maxstor NAS.

  • #2
    Re: Delete fails in synch when scheduled

    BC might be trying to prompt for confirmation of the delete.

    Adding "option confirm:yes-to-all" will confirm any file operation prompts.

    Also, adding a log command should help diagnose the problem.

    Here's an example:

    Code:
    log verbose c:\mirrorlog.txt
    option confirm:yes-to-all
    load c:\source c:\target
    sync mirror:lt->rt
    The above script will make the target folder identical to the source folder, including deleting files that only exist on the target side.

    The log will also list the user account the script is running as, so you can use it to verify the script is running with the correct permissions. If it still doesn't work, please post a log from running the script as a scheduled task.

    Also, please try running the script from the command line when you're logged on and see if it has the same delete problem as running the script as a scheduled task.
    Chris K Scooter Software

    Comment

    Working...
    X