Announcement

Collapse
No announcement yet.

JPG compare - ignore date / time

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • JPG compare - ignore date / time

    Hi guys,

    I've taken a bunch of photos, then after I shot them, I realised that my camera date and time were wrong. I used Sony PlayMemories Home to adjust the dates by the required offsets (only program I could find that did it, recommendations welcome). I'm now trying to confirm that every photo is archived on my HDD before I wipe the memory card, but every photo has a different date. Is there any way to ignore these two fields in the JPG Metadata? I don't want to manually compare a few thousand photos!

    Thanks for your help,
    Cheers,
    Critcho

    Click image for larger version

Name:	Beyond Compare 4 JPG File Dates.PNG
Views:	23
Size:	37.6 KB
ID:	81059

  • #2
    Hello,

    BC4 does not support ignoring specific tags, but if you toggle off the Meta toolbar button, it will remove the metadata from the Rules-based comparison. If you close the tab and run the Rules-based scan from the Folder level, it will also then not use the (now closed) Meta button information.
    Aaron P Scooter Software

    Comment


    • #3
      Hi Aaron,

      thanks for the quick response, but I'm still missing something. Turning off the Meta toolbar works on an individual file comparison, and when I return to the folder view, each file that I've compared individually shows they are Rules-based same (no IOIO next to the =). However, selecting a bunch of files (or all of them) from the folder view and requesting compare, still shows they are binary different. If I have one item selected in the folder view, Quick Compare shows they are the same, but the folder view still shows they are binary different, and I can't run Quick Compare on more than one file. How do I run Rules-based compare on all selected files in one go, without having to do an individual file compare and hitting next until I'm through the whole list?

      Thanks,
      Critcho

      Comment


      • #4
        Hello,

        You might have disabled the Compare Contents dialog box (which allows selection). You can re-enable it from the Tools menu -> Options dialog, File Operations tab, enable "Confirm Content Compare". Then, when right-clicking and selecting Compare Contents, you will see a dialog that allows you to select Rules-based compare.

        Alternatively, you can also navigate to the Folder Compare's Session menu -> Session Settings, Comparison tab. Leave timestamp, size, override, defaults enabled, and also enable Content: Rules-based. Clicking ok will then begin performing the rules-based scan on all items.

        A rules-based scan will sometimes return the Binary 0101 equal icon, since running this scan is faster and if binary equal the files must be rules-based equal. However, when selecting rules-based, it will fall back to a rules-based compare as soon as it needs those results (files are not binary equal).
        Aaron P Scooter Software

        Comment


        • #5
          Originally posted by Aaron View Post
          enable "Confirm Content Compare". Then, when right-clicking and selecting Compare Contents, you will see a dialog that allows you to select Rules-based compare.
          Looks like that's cracked it, Thanks! Working now.

          Comment

          Working...
          X