No announcement yet.

BC2 Front End not loading

  • Filter
  • Time
  • Show
Clear All
new posts

  • BC2 Front End not loading

    Hello, long time lurker, first time poster! I am having a strange issue that is almost certainly related to so sort of setting on my computer that has recently changed. Allow me to explain:

    At work we use Beyond Compare 2 to compare our code and test files. It was working fine last week. Yesterday I went to compare two TXT files and nothing happened. I attempted opening BC by right clicking the two files and using the Compare context menu. I then tried to open it by going to the start menu and clicking it. I tried separate ways like this a couple times and the program would just not open. I checked the Task Manager and lo and behold, BC2.exe was in there a bunch of times, so it was running but for some reason it wasn't opening the front end of the program.

    I restarted my computer. I went as far as to uninstall and then reinstall the program. It keeps happening. I'm using a 32 Bit machine with Vista Enterprise Service Pack 2. It's not happening to any of my co-workers.

    Has anyone come across problems like this before?

  • #2
    Thanks for writing in.

    Which version of BC2 are you currently using? If it isn't the most recent (2.5.3), does updating help?

    You can also try creating a portable install of BC2 on your Desktop. This would use a fresh batch of settings and be separate from the main install that is having trouble. Just follow these steps, but instead of a USB device, it can just be a Folder on your user's Desktop\.
    Aaron P Scooter Software


    • #3
      I am using 2.5.3.

      I did the portable method and that works! Thanks, now I just have to change some scripting settings to look for it on the desktop.


      • #4
        Interesting - I've gotten it to work again.

        We use scripts that open BC with certain settings to analyze our test files and look for differences. I went to change one to get it to find the new location of BC2.exe and it opened up the ORIGINAL BC2.exe location (with the same result as my previous problem). Now, the thing is that I had already uninstalled the original from my machine (did the required restart and everything), but for some reason all of the files still remained in the Program Files folder. Upon noticing that, I deleted the folder. Wondering if that's why resinstalling wasn't fixing the problem before, it kept the same (what I believe to be) corrupted file and was trying to use it to do my compare.

        I reinstalled and lo and behold everything is working now. Going to keep the "portable version" on a CD in case this ever happens again. Does your uninstalling process not remove the files from the machine or is it a problem with Vista and access control that the uninstall program attempted to remove the files but the OS wouldn't allow it to happen? I AM on a machine that is fairly locked down in regards to permissions.


        • #5

          No, our uninstall process removes the application but leaves some of your settings files in place in case you install at a later date. There must have been something in your old settings that was causing the issue; the portable install would be using a set of factory default settings, which is why that helped track it down.
          Aaron P Scooter Software