Announcement

Collapse
No announcement yet.

indent option

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • indent option

    Hi,
    It seems to me that the Indent option (in File viewer settings) is not functionnal: Tab or space always write a tab while editing a line.
    Any idea ?
    Manfred

  • #2
    Re: indent option

    It's working in 2.1.2 here. Are you sure you clicked OK and not Cancel in the Options dialog? If you use the Show Whitespace option in the View menu you can double-check whats inserted.
    ZoŽ P Scooter Software

    Comment


    • #3
      Re: indent option

      Always the same problem. strange...
      When I swap the radio button (ident uses: tabs or spaces), the apply button state doesn't change (it stays grey)and apply or ok does not change anything). When I set 'show whitespaces', the inserted character is tab (>>) not space (~). So worse but coding with tab is horrible so when I edit a line of a source file in the file viewer, I have to convert after in my editor the tab in spaces. A small pain.
      Thanks for this great job at low price. I plan to buy 1 or 3 licences.

      Comment


      • #4
        Re: indent option (tabs vs spaces; indent size)

        Hi -
        Great tool; I've been using it for 7 years now. It is time to write in to request a bugfix and perhaps a feature:


        Item 1) Indent option does not work properly.
        From: Tools->Options, File Viewer, Indent uses.
        (I change the radio button from Tabs to Spaces)
        The Apply button remains disabled. I press OK.
        My change is never applied. I have tried exiting the app prior to the next edit, nothing matters.

        I am viewing files using the View->Show Whitespace option, so I am confident this description is correct.

        Could you look into this?


        Item 2) I wish to set the indent size. I cannot find a way to do this - can you assist me?
        My preferred editor settings are:
        indent size=2,
        tab size=2,
        insert spaces, not tabs.

        I've looked through your site including the "hacks" section... no luck. I've tried Tools->Edit Current Rules->Whitespace Includes. Still no luck.


        I'm running BC 2.4.1, Windows XP SP2

        Thanks, and please thank the current and original team (if you still stay in touch w/ them).

        Regards,
        +sean

        Comment


        • #5
          Re: indent option (tabs vs spaces; indent size)

          1) Thank you for bringing up the problem with "Indent Uses". I checked on my own system, and regardless of the setting it always used tabs. I will add this to our bug list to be fixed.

          2) To change the size of tabs in the File Viewer, select Tools|Edit Current Rules. Go to the General tab. Change the "Tab stops = " value.
          Chris K Scooter Software

          Comment

          Working...
          X