Announcement

Collapse
No announcement yet.

Column inclussion / exclussion

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chris
    replied
    Re: Column inclussion / exclussion

    Hi Bret,

    To see whitespace differences, select View|Show Whitespace.

    To ignore whitespace differences, select Tools|Edit Current Rules, go to the Importance tab, and check the leading, trailing, and embedded whitespace options.

    If that doesn't solve the problem, please send example code along with an export of your settings using Help|Support and the Export button to support@scootersoftware.com and I'll look into the problem further.

    Leave a comment:


  • BretSutton
    replied
    Re: Column inclussion / exclussion

    I too am having problems with the comparison of comments in COBOL code. I would like to be able to see differences in comments. In my case, the lines of one file are padded with trailing blanks out to column 80; the other file has no trailing whitespace. Most comment lines compare equal; however, a number indicate differences in the text when the text is identical; and others indicate differences within the trailing whitespace (but only some of the trailing whitespace on the line!).

    I will be happy to send you some short code snippets and my BC2 configuration.

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Re: Column inclussion / exclussion

    Thanks for the answers Chris. (Still trying to get the powers here to buy a multiple license. Talk about slow-moving, like all larger companies)

    Leave a comment:


  • Chris
    replied
    Re: Column inclussion / exclussion

    1) For anyone else monitoring this thread, to download the COBOL rules you'll need to right click on the link and Save As.

    2)The line length setting is a maximum line length. If your lines are shorter than the maximum it won't hurt anything, I think it will make BC will use a little bit more memory. Unless you're comparing extremely large files, leaving the setting at the default of 4096 should be fine.

    If you set the max length longer than your max number of characters it will force lines to wrap.

    The maximum line length counts line terminators, so If your files are 80 columns you'll need to set 81 to include the terminator or you'll get a wrap. You can see the terminator by selecting View|Show Whitespace.

    3) The default Cobol rules should ignore text in lines starting with a * in column 7. The regular expression "^......\x{2A}.*" is the line that refers to comments. As long as that expression is set to unimportant text, lines beginning with * should be ignored. If you want to see comment differences, but ignore lines that only have the * character, just change the regexp to "^......\x{2A}". If that doesn't help, please send me a pair of example files and a zip of your settings using Help|Support and the Export button. You can send them to support@scootersoftware.com

    Leave a comment:


  • misi01
    replied
    Re: Column inclussion / exclussion

    I can't believe how flexŪble BC2 is !!! I'm trying to compare COBOL programs and obviously want to limit the comparison to columns 7-71 and found this append. Having said that, I'm having a couple of "problems". I tried downloading the cobol link frmo the address above, but simply get a new explorer window with a load of test starting with <bc_settings>. How am I supposed to download this ? *** Solved that ***

    A second query that is puzzling me. Theoretically, I should (?) set the line length (edit current rules, general, max line length) to 80. If I do that though, I seem to get a blank line inserted after EVERY line. If I instead set the value to 81, the programs lokk as expected. (I don't see this as a problem, but it does surprise me a bit). What is the explanation for this ?
    (I see that the imported COBOL rules set the line length to 4096 - why ?)

    Finally, using the ideas above, I set the unimportant text as being both "From column 1 to column 6" and "From column 73 to end of line" and all seemed well. However .... what is also surprising me is that lines with ONLY an asterisk in column 7 are being marked as different. If there is an explanation for this, fine, otherwise, if needed I can easily send the 2 files offline. *** Changed the example COBOL rules and removed the line ^......\x{2A}.* after which I was seeing changes in commented lines with changed text highlighted in red (as I wanted), but a line with ONLY * in col 7 was still being marked as changed (albeit as an unimportant difference). Which "rules" do I also need to remove to accept lines starting with * in col 7. (Tried removing all others that "seemed" to refer to asterisk, but the line is still marked as changed/unimportant differences)

    Leave a comment:


  • ZoŽ
    replied
    Re: Column inclussion / exclussion

    v2 actually has a more powerful version of it, but you set it up differently. Edit your rules (Tools | Edit Current Rules) and switch to the Importance tab. Click the New button in the Unimportant Text section. In the new dialog change the Category to Columns and put the columns you want to ignore in the start and stop columns. The is opposite of BC 1 where you put in the columns you wanted to compare, so to limit the comparison to columnns 7 to 70 you'll need to set up two ranges (1-6 and 70-end of line).

    If you're comparing Cobol files you should consider upgrading to the 2.1 beta. One of our users put together a very complete set of Cobol rules that you can import, available here: http://www.scootersoftware.com/downl...c=kb_morerules

    Leave a comment:


  • PGallucci
    started a topic Column inclussion / exclussion

    Column inclussion / exclussion

    In the older versions, I used to be able to limit the columns used in comparisons, (i.e. only compare columns 7 to 70, etc). The new version doesn't appear to have this option. Has it been eliminated? If so, I really would like to see it included in future versions.
Working...
X