Announcement

Collapse
No announcement yet.

problem with timestamps when copying to ftp server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Chris
    replied
    Re: problem with timestamps when copying to ftp server

    Adam,

    Checking "Ignore daylight savings difference" in Session|Comparison Control should ignore any differences you might see after daylight savings time switches.

    Timestamps on FTP sites can be pretty tricky, and the behavior varies depending on what FTP server software you're connecting to.

    Some FTP servers get time or set time in GMT/UTC time, and it might not be adjusting it to local time correctly.

    To try to fix this, please send me a zip of your settings (using Help|Support and the Export button in Beyond Compare), and the name of the FTP server software running on the server you're connecting to.

    Leave a comment:


  • adamjoby
    started a topic problem with timestamps when copying to ftp server

    problem with timestamps when copying to ftp server

    I'm copying files to an FTP server from Windows XP running BC 2.5.2. Problems with file timestamps being off by one hour led me to investigate the whole NTFS daylight savings time mess.

    I've discovered that if I copy two files to the FTP site, one with a date in the winter, and another in the summer, that the date on the resulting new copy of the summer file on the server is off by one hour. BeyondCompare seems to be intentionally assigning the new file a time one hour earlier. The file created during the winter has the correct timestamp.

    My hypothesis is that BeyondCompare is doing this on purpose, anticipating that files created during daylight savings time need to be adjusted by one hour in order to correct for the mismatch that occurs between Windows and UNIX timestamps on files created during these periods.

    The problem is that I don't want this behavior. I simply want the file timestamps on the target to match the source, regardless of when the file was created. Right now, I cannot correctly sync any files that were created during the summertime!

    The Session|Comparison Control option to ignore DST does not seem to apply here; the problem is not in comparison, but in the creation of the new file.

    I should note that it is currently winter. I don't know what will happen after DST kicks in again. I presume there is already a feature that prevents every single file from appearing to be off by one hour. Also I'm hoping that disabling the "automatically adjust clock for daylight savings time" in XP will help me avoid hassles.

    Thanks. BTW - this program has one of the best interfaces I've worked with in recent years; nice job!

    Adam
Working...
X