Announcement

Collapse
No announcement yet.

Windows Vista

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows Vista

    Update:

    Listed issues are resolved in Beyond Compare 2.5 beta.

    Download the BC 2.5 beta from: http://www.scootersoftware.com/download.php?c=beta25

    ------
    Please post any Windows Vista related issues in this thread.

    Beyond Compare 2.4.3 works on Windows Vista with only a few minor issues.

    We're testing with Vista in house, and we're working hard to resolve the issues that we've run into.

    Known Issues:
    <ul type="square">[*]Shell Extension icon background isn't transparent (but shell extension works fine).
    [*]Due to Vista User Access Control, turning the shell extension on or off after installation requires you to right click the BC icon and select "Run As Administrator".
    [*]Manipulating files owned by other users may also require you to use "Run As Administrator" even if you have Administrative rights.
    [*]Selecting Alt-Tab in an options dialog in BC will cause some of the window to redraw incorrectly.
    [*]Context help doesn't work because Vista dropped support for HLP format help files.[/list]
    We plan to release a Windows Vista compatible version of BC2. We're also working on BC3, due out later this year, and it will be fully Vista compatible.
    Chris K Scooter Software

  • #2
    Re: Windows Vista

    Hi,

    I've just install BC 2.4.3 on my PC running Windows Vista Business x64 and I'm having one issue with the shell extension. About 80% of the time when I try to compare a mapped network drive with something else, the explorer context menu doesn't include "Compare to ..." after the first selection.
    I can't really reproduce it, and it only seems to happen when I compare the top level 'mount point', and not something below.

    For example, I have \\laptop\step mounted to Y: and want to compare it to D:\users\step

    Selecting Y:\ first and comparing to D:\users\step [often] doesn't work
    Selecting D:\users\step first and comparing to Y:\ [often] doesn't work either.

    But:
    Selecting Y:\code and comparing to D:\users\step\code works fine.

    Hope that makes sense; if more information is needed I'll be happy to make a few more tests.

    Cheers,
    -Stephan

    Comment


    • #3
      Re: Windows Vista

      Thanks for the report.

      I just checked, and this looks like a general problem with our x64 shell extension. I repeated the problem you described on both Windows Vista x64 and Windows XP Pro x64.

      I'll add this to our bug list and we'll work on a fix.
      Chris K Scooter Software

      Comment


      • #4
        Re: Windows Vista

        Hi there, I am having problems with the context menu in Vista. The menu is there, buit does nothing when I click it - either when there are 2 folders selected, and I click 'Compare', or when I click one file and choose 'Select left side', when I click another file, the option is still 'select left side'

        Comment


        • #5
          Re: Windows Vista

          Are you running Windows Vista 32-bit or 64-bit?

          Are you using the release version of Windows Vista?

          What other shell extensions do you have loaded on your computer?
          Chris K Scooter Software

          Comment


          • #6
            Re: Windows Vista

            I have serveral Vista machines and on all of them when i will try to get a big folder the connection will be lost for every 10 files, i tried it in XP against the same websites and it works fine, any known connection probelm with vista?

            Comment


            • #7
              Re: Windows Vista

              Are you connecting to a folder by FTP, or is it a network drive on your LAN?

              If it is an FTP server, try the suggestions on our FTP problems page:
              http://www.scootersoftware.com/support.php?c=kb_ftp.php

              What error messages do you get when you have connection problems?
              Chris K Scooter Software

              Comment


              • #8
                Re: Windows Vista

                Upgraded my PC to a new HP Vista box:

                - Reinstalled my bc 2.4.3.243
                - Running bc as administrator
                - Browsing for base folder on desktop/computer/U: (Network Unix drive)
                - I can navigate down the Unix directory structure
                - When I hit enter to open I get "Folder Not Available"
                - No problems accessing Unix drives from Vista mail, notepad, etc
                - No problems accessing Unix drives with BC from my Windows 2000 server
                - No problems accessing other networked windows platform drives
                - Running SCO Open Server V with FacetWin file service
                - Id like to retire the W2K server but can't until this issue resolved
                - Willing to buy a second license if that will fix the problem

                Do I need an upgrade? Other suggestions?

                Comment


                • #9
                  Re: Windows Vista

                  We also discussed this by email yesterday.

                  We haven't tested BC on Windows Vista with FacetWin yet.

                  The first thing to try is right click on the BC2 icon and select "Run As Administrator" to make sure BC runs with full administrative rights.

                  BC 2.4.3 is still our current version, so there isn't a newer version to upgrade to for Vista compatibility fixes.
                  Chris K Scooter Software

                  Comment


                  • #10
                    Re: Windows Vista

                    I want to add "my error" to the list of Vista issues. I have BC 2.4.3 (build 243) and it works great, but I can't get it to work in FTP mode. I've tried the "common ftp suggestions" that you have on your website. I use BC in 'portable mode' and when I use USB key in my windows XP machine it works perfectly to my website, but from my vista machine, i get errors. Any suggestions?

                    Comment


                    • #11
                      Re: Windows Vista

                      Please make sure Beyond Compare is listed in the Firewall Exceptions in Windows Vista. If it isn't listed as an exception, the firewall can cause FTP connection problems.

                      If that doesn't solve the problem for you, what error message do you get? What FTP server software is running on the server you are trying to connect to?
                      Chris K Scooter Software

                      Comment


                      • #12
                        Re: Windows Vista

                        Chris,

                        I think I'm having the same problem as MarkAndrew. It is definitely firewall related but also definitely specific to BC, as other apps work fine with my firewall on, and BC works great with the firewall disabled.

                        I do have BC added and checked as an exception to the firewall; it just doesn't seem to recognize that the returning packets are related to the FTP connection that was opened by BC. I've fiddled with every setting in BC to no avail; the only thing that fixes it is disabling Vista's firewall.

                        The error I get is "425 Unable to build data connection: No route to host".

                        I'm using DreamHost shared hosting. I don't know what FTP server software they're using but I can find out if you'd like.

                        Hope that helps

                        Comment


                        • #13
                          Re: Windows Vista

                          Update -- this problem seems to have solved itself.

                          After I disabled the firewall it worked, so I synchronized my files and re-enabled the firewall. After doing so, BC continued to work. At first I figured Vista's firewall had somehow discovered the BC session and was allowing it, but now even after reboots, it is working fine. Not sure what to make of it, but I'm glad it's working!

                          Comment


                          • #14
                            Re: Windows Vista (forum problem)

                            Replying here to see if that fixes it...

                            This thread keeps coming up as if it's "new" (with a new post added) - and there never is. Meanwhile the number of views keeps growing... I'm sure mostly due to its floating upward every time, even though there's nothing new to see.

                            It would be helpful if this could be fixed!

                            Comment


                            • #15
                              Re: Windows Vista (forum problem)

                              This thread keeps getting flagged as new because for whatever reason all of the spam we've gotten recently has targeted it. Since the known Vista issues are fixed in 2.5 anyway, we're locking the thread now, so it should drop off the front page soon.
                              ZoŽ P Scooter Software

                              Comment

                              Working...
                              X