Announcement

Collapse
No announcement yet.

Time control

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Time control

    I aplogise if I'm just blind here. I've been putting up with this for some time, but I thought I'd ask....

    I'm using BC to sync files between WinXP and Linux (using vsftpd or whichever comes with RHEL4 by defaul).

    I'm seeing two behaviours that cause equal files to be shown as different:

    1) The files on the Linux machine have the seconds all set to zero ("00").

    2) After I copy files from the Win32 laptop to the Linux box the files on the Linux box are all shown one hour ahead of the date/time on the WinXP side... (with seconds truncated to zero per item #1 above).

  • #2
    Re: Time control

    You could disable "Compare Timestamps" in the Comparison Control dialog and rely on a "Rules", "Binary", or "Size and CRC" comparison.

    Comment


    • #3
      Re: Time control

      I haven't tested with RHEL4's FTP server, but VSFTPD on RHEL3 displays 0's for the seconds portion of timestamps.

      It also doesn't support the command necessary to set timestamps on uploaded files. You can verify this by using the Actions|Touch command on the FTP server. It should give an error message like "Operation not supported".

      So, it might be that the FTP server in RHEL4 just doesn't support setting timestamps. If this is the case, you can work around it by copying timestamps back to your local files after upload. To do this, select Session|Comparison Control and check "Touch local files when copying to an FTP site".

      You can also add whole hour or seconds tolerances for timestamp comparison in Session|Comparison Control.
      Chris K Scooter Software

      Comment

      Working...
      X