Announcement

Collapse
No announcement yet.

BUG: Exclude doesn't take into account of CTRL-sel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BUG: Exclude doesn't take into account of CTRL-sel

    When I do CTRL-A to select all. I press CTRL and select a folder. Then I right-click on one of the selected rows/files/folders and chose Exclude...

    and it' excludes everything.

    Bug!

  • #2
    Re: BUG: Exclude doesn\'t take into account of CTRL

    The Exclude command should only remove selected files and folders from the display.

    If you have folders A, B, C, D and A, C, D are selected, the Exclude command should limit the display to folder B.
    Chris K Scooter Software

    Comment


    • #3
      Re: BUG: Exclude doesn\'t take into account of CTRL

      Sorry, just read my post and it was a bit ambiguous.

      Yes that's exactly what I meant from what you wrote. I used the short-cut key CTRL-A to select all. Then I used CTRL & mouse click on a specific folder/file to unselect it.

      Then used the exclude command and it excludes all folders and files... even unselected ones.

      Comment


      • #4
        Re: BUG: Exclude doesn\'t take into account of CTRL

        First, please make sure you're running our latest version, 2.4.1.

        If you're running the latest release and it still shows up, this might be something specific to your file/folder names or BC settings.

        Please send screen shots or a directory listing of the files you're comparing, along with which file or folder isn't selected when the bug shows up, to support@scootersoftware.com and I'll look into this further. Also, please include a zip of your settings using Help|Support and the Export button.
        Chris K Scooter Software

        Comment


        • #5
          Re: BUG: Exclude doesn\'t take into account of CTRL

          Yep, am using latest 2.4.1 version.

          The file folder settings are as follows:

          File Filters - ALL DEFAULT
          Show All
          Comparison Control
          General TAB
          Compare Timestamps
          2 second tolerance
          Ignore Daylight Savings difference (1 hour)
          Compare Versions
          Compare Contents Size alone
          File Attributes ALL
          Automatically scan subfolders in background

          Advanced TAB
          Case sensitive filenames

          Comment


          • #6
            Re: BUG: Exclude doesn\'t take into account of CTRL

            This might be due to case sensitive file names.

            With case sensitive filenames turned on, BC will match files up for comparison based on character case. However, filters are not case sensitive.

            This means if you right click and exclude a folder named FOO, if there is also a folder named foo, it will be excluded by this filter as well.
            Chris K Scooter Software

            Comment


            • #7
              Re: BUG: Exclude doesn\'t take into account of CTRL

              Okay, I don't think this has anything to do with File/Folder filters & settings. I started a new folder comparision leaving all settings default. I click CTRL-A on keyboard (or Edit menu, Select All) and all files/folders are selected. I hold down CTRL key and click on one folder. Then I right-click and Exclude. All files/folders are excluded.

              This doesn't follow your description of folders A, B, C, D story, where folder A B D are selected and excluded and you are left with C. I am left with no folders.

              However, if I hold down CTRL key and select the specific folders then it works. Note that I did not use CTRL-A (or Edit menu, Select All) this time.

              So you are telling me that this works okay for you?

              Comment


              • #8
                Re: BUG: Exclude doesn\'t take into account of CTRL

                Yes, this scenario works fine for me.

                If I have folders A, B, C, D, and I select and Exclude A, B, D, I am left with folder C displayed.

                If you have folders A, B, d, D, and you select and Exclude A, B, D, all of the folders will be hidden from the display because filename filters are not case sensitive.
                Chris K Scooter Software

                Comment


                • #9
                  Re: BUG: Exclude doesn\'t take into account of CTRL

                  Did you chose "Edit menu, Select All" as the very first task/step upon first loading Beyond Compare?

                  Comment


                  • #10
                    Re: BUG: Exclude doesn\'t take into account of CTRL

                    Yes, here are the steps I used, including exact directory names.

                    Start with directories:

                    C:\w\source\A
                    C:\w\source\A\aa.txt
                    C:\w\source\A\bb.txt
                    C:\w\source\B
                    C:\w\source\B\aa.txt
                    C:\w\source\B\bb.txt
                    C:\w\source\C
                    C:\w\source\C\aa.txt
                    C:\w\source\C\bb.txt
                    C:\w\source\D
                    C:\w\source\D\aa.txt
                    C:\w\source\D\bb.txt
                    C:\w\source\aa.txt
                    C:\w\source\bb.txt

                    Load c:\w\source as a base folder.

                    Edit|Select All.
                    Ctrl click on folder C to deselect it.
                    Right click on selected folder D and select "Exclude".

                    Only folder C is visible.

                    This leaves the Filters: toolbar with:
                    -.\aa.txt;-.\bb.txt;-.\A\;-.\B\;-.\D\
                    Chris K Scooter Software

                    Comment


                    • #11
                      Re: BUG: Exclude doesn\'t take into account of CTRL

                      Okay, I think I found out my problem.

                      When I do CTRL-A (or Select All from menu), then both left & right columns are fully selected. Then I press CTRL-deselect a number of files/folders and right-click on one of the remaining selected file/folder to Exclude.

                      However, I only CTRL-deselect from the left-column and forget that the right-column is also still fully selected.

                      I must remember I need to CTRL-deselect both columns.

                      Comment

                      Working...
                      X