Announcement

Collapse
No announcement yet.

deleting directiories fails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • deleting directiories fails

    I have a Linux server which exports an ext3 filesystem via Samba. I then map that to a drive letter on my PC. I can delete directories via Windows Explorer, but using BC2 [v2.4.1 (Build 241)], if I try to sync _to_ the drive letter of the Samba share, the directory disappears, but is not actually deleted.

    Example:

    I have:
    Y:\temp\directory1\ which contains a few files
    C:\temp\ which contains some files and directories, but no directory1

    I attempt to sync C: -> Y: by selecting C:\temp and clicking Synchronize to Right. The directory disappears, but if I open Explorer afterward, the directory is still present, and will reappear in BC2 if I refresh.

  • #2
    Re: deleting directiories fails

    After the folder dissapears, does it reappear if you select View|Suppress Filters?

    If this makes it show up, sync didn't try to delete the folder. Instead the folder was filtered out of the display. BC hides folders that don't contain visible files unless View|Always Show Folders is selected.

    With the default settings, Actions|Synchronize Folders|Synchronize to Right and Actions|Synchronize Folders|Synchronize to Left won't delete files and folders that only exist on the target side. It will only copy newer files from the source to the target.

    If you've changed your sync settings or you use Actions|Synchronize Folders|Custom Sync and select Mirror, it should make the target identical to the source, including deleting folders that only exist on the target.
    Chris K Scooter Software

    Comment


    • #3
      Re: deleting directiories fails

      I had the same problem, but on a WindowsXP machine.
      What I had to do to solve this problem was disabling the "Only affect visible files" option in the "Sync Options" ("Tools"-->"Options"-->"Sync Options"; make sure to disable it for both left and right side sync).

      Hope this helps.

      Comment

      Working...
      X