Announcement

Collapse
No announcement yet.

Touching apparently created mismatches?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Touching apparently created mismatches?

    I'm trying out this program to update a web site via ftp. After figuring out I needed to touch my local files (not allowed on ftp), I did that & now I have lots of red mismatches on both sides, many of them file size differences of a couple bytes. I read something in help suggesting maybe my server is linux & my Windows XP just makes the files differently. This appears only to effect TXT files but I've got thousands of those. The differences vary in mysterious ways, sometimes doing a manual comparison will clean it up, sometimes not. Copying back from ftp to local doesn't even fix this. I don't see any way to get out of this situation!

  • #2
    Re: Touching apparently created mismatches?

    The size difference is due to line terminators. Windows marks the end of a line of text with two characters, while Unix & Linux use one character. Usually the File Viewer ignores that difference, but you can see the line terminator character by using View|Show Whitespace.

    There are two ways to deal with this difference:

    1) Only compare using timestamps.

    2) Switch to binary mode transfers. Normally text files are translated to correct line endings when you transfer them by FTP. If you select Binary as the transfer type in the FTP section of Tools|Options, it won't translate them, so the files will always stay in the Windows format. Most web servers are tolerant of either line terminator style. You might run into problems using Binary mode if you're uploading scripts, or if you edit the files directly on the machine.
    Chris K Scooter Software

    Comment


    • #3
      Re: Touching apparently created mismatches?

      How do I compare only using timestamps in the file browser view, not just the manual compare?

      Comment


      • #4
        Re: Touching apparently created mismatches?

        To compare only using timestamps, select Session|Comparison Control from the menu. In the Comparison Control dialog, make sure "Compare Timestamps" is the only criteria checked.
        Chris K Scooter Software

        Comment

        Working...
        X