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1
Welcome

Beyond Compare is a utility for comparing files and folders.  It can help you find and
reconcile differences in source code, folders, images and data, even if your files are
contained in zip archive files or on remote services (e.g. FTP sites).  It can synchronize
your folders, and validate your copies.

Beyond Compare seamlessly coordinates the entire comparison job, from the folder
structure down to individual differences in files.  Specialized file views communicate
difference info back to the folder session, helping you quickly concentrate on important
differences.  Beyond Compare remembers your various sessions so that you can come
back to the same comparison job time after time.

This document describes both the Standard and Pro editions of Beyond Compare.
Features that are only available in the Pro edition are indicated by this green icon:  

Beyond Compare is available for computers running Windows, Mac and Linux.  Items in this

document that refer to a specific platform are indicated by these icons:    
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1.1 What's New

Here are some of the significant new features in Beyond Compare 4.  Items flagged with 
 are only available in the Pro edition.

Mac version

Beyond Compare now runs natively on Mac.

BC for Mac has all the power and functionality you've come to expect from Beyond
Compare, now with native look and feel, speed, and enhancements to make it feel at
home.

Overhauled Home view

The new Home View adds session search and web resources.  The layout is easier to
manage with on-screen controls.

3-way Folder Merge 

Three-way merging now extends to folders.  Compare independent changes against a
common ancestor to quickly merge your changes with someone else's.  It makes merging
your customizations into a new release a snap.

Ad hoc unimportant text

It is now easier to define unimportant text in your Text Compares.  Define unimportant
terms directly from the Session Settings dialog, rather than having to edit your file
formats.

WebDAV, Subversion, Dropbox and Amazon S3 support 

In addition to FTP, you can access WebDAV resources, subversion repositories, Dropbox's
cloud storage, and Amazon S3 cloud storage directly from within Beyond Compare. 
Organize your remote service profiles with friendly names and folder hierarchies.

Overhauled Picture Compare

Picture Compare has a new look, with automatic zoom, pixel-level details, and simplified
controls.  Tolerance comparison mode uses grayscale to reveal the image along with the
differences.

Overhauled Options dialog with search

The reorganized Options dialog includes a search feature for finding specific settings
quickly.  Commands for all comparison types can be customized without first having to
open a view.
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Other significant features

Data Compare is now called Table Compare.

Hex Compare wraps lines to fit the window, and adds in-line editing.

New View Patch command shows diff/patch files as a text comparison.

Added new text comparison algorithm choice based on Bram Cohen's Patience Diff.

HTML folder comparison reports can now embed links to file comparisons.

Improved appearance on high DPI (retina) displays.

Version Compare now compares the fixed PE header in addition to the version resource.

Zipx archives can be compared, complete with PPMd, LZMA, WavPack, and WinZip's

JPEG compression.

Added support for portable media devices (aka "MTP") including Android 4.0+ phones

and cameras. 

1.2 Standard vs. Pro

The Standard edition of Beyond Compare is a powerful full-featured comparison tool, not a
stripped-down "lite" version.  The Standard edition has full-screen editing, full Unicode
support, syntax highlighting and much more.

However, the Pro edition adds these advanced functions:

3-way merging 

Compares independent changes against a common ancestor to create new merged
content, for folders or individual files.

Text replacements 

Specifies text as unimportant if it is changed to a specific value on the other side.  For
example, you can make apple found on the left when compared to orange on the right an
unimportant difference.

Folder Compare alignment overrides 

Overrides how files are aligned in a Folder Compare session.  For example, you could
compare your .gif files on one side with .png files of the same name on the other side.

Source control integration 

Adds commands for checking files in or out of SCC-compliant version control systems.

SFTP support 

Rather than relying on third-party solutions, Beyond Compare Pro has integrated support
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for secure FTP protocols (SFTP and FTP over SSL).

Registry Compare 

Compares live registries, both local and remote, as well as registry files.

Note  The trial download of Beyond Compare actually contains both Standard and Pro
editions.  You can disable Pro mode in the Help > About dialog in order to limit your trial to
Standard functionality.

Your license key will unlock the appropriate edition for permanent use.  If you choose the
Standard Edition license, you can upgrade later to Pro for the difference in price.
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2
Using Beyond Compare

Beyond Compare handles a wide variety of comparison tasks.  It has specialized views for
different kinds of files and different approaches to reconciling differences.

Each comparison task is called a Session.  Sessions can be individualized, named and
reused.  Many of Beyond Compare's settings are managed and stored by session rather
than as program-wide options, to give you greater flexibility.  You can save different
sessions with quite different settings, to accommodate differing tasks.

A Child Session is a file session that originated from a folder session.

Sessions can be opened in separate windows, or as multiple tabs on a single window.  We
refer to open sessions as View s.  You can have multiple windows open, each with multiple
tabs.  You can drag a tab from one window to another, or right-click on a tab and pick 
Move Tab to New Window to move that tab onto its own window.  (See Tab Options.)

You can save currently open sessions as a Workspac e, and load them again later with the
same configuration of windows and tabs.  (See Managing Workspaces.)

The session settings that control how comparisons are performed are called Rules.  Rules
help you concentrate on important differences.  Beyond Compare also maintains a list of 
F ile  Form ats to specify how various types of files are to be handled.  You can modify the
built-in file formats or create your own.

Credentials and other settings for remote services (FTP, WebDAV, Dropbox and others)
are stored as named Profiles.  (See Profile Management.)

This part of the documentation provides an overview of the various types of sessions and
program concepts mentioned above.
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2.1 Home View

When you open a new window or tab, Beyond Compare displays the Home view:

From the Home view, you can:

Start a new comparison session of any type

Open one of your previously saved sessions

Open an auto-saved session

Search for a session

Manage the settings for your saved sessions

Edit the default settings to use for new sessions

You can also drag and drop files or folders from a file manager such as Windows Explorer
onto this view to compare them.  Drag and drop onto one of the large buttons to start a
session of that specific type.

2.1.1 Managing Sessions

Beyond Compare automatically saves your most recent sessions so you can come back to
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them easily.  If you want to retain a session indefinitely, you can save it with a
descriptive name.  You can also organize your named sessions within session folders.

Use the Home view to manage all your sessions in one place.  In the Sessions tree, you
can right-click on a saved session and pick Edit to show the management panel.  Click on

the Pin Session Management Panel button or mark View > Show Session Management to
force it to always be shown in the Home view.  Delete and Rename are also available in
the right-click menu for saved sessions.

A named session can be locked to guard against accidental modifications.  Right-click on
it in the Sessions tree and pick Lock.

Once a session is opened in a view, the Session menu contains common commands for
manipulating it.  If you make a change to the primary parameters of a named session, you
will be prompted to save it on exit.

To change default session settings

In the Home view's Sessions tree, under the New branch, select a session type.  Right-
click on it and pick Edit to show the management panel.  Changes to these default
settings will now be used for any newly created sessions of that type.

2.1.2 Sharing Sessions

Multiple users can share sessions by using a shared sessions file.

To create a shared sessions file

1. Pick Tools > Export Settings to create a .bcpkg settings package with any subset of
your sessions.

2. Place the package file in an appropriate shared folder.

To access a shared sessions file

1. Pick Tools > Options .

2. On the Tweaks page, in the Shared Sessions File section, enter the location of the
package file.

Shared sessions will then appear as a new branch in the Sessions tree:

Note that shared sessions are read-only, and cannot be edited within Beyond Compare. 
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To make changes to shared sessions, you need to recreate the package file as described
above.
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2.2 Folder Compare

A Folder Compare session compares two folder structures side-by-side, in a variation of
the familiar Windows Explorer style.  The comparison may be of folders on your hard drive
or network, but either side also may be a remote service (e.g. FTP site), an archive file,
or a snapshot taken earlier.  All of these have a structure – folders and subfolders
containing files – and Beyond Compare treats them equivalently.

2.2.1 Understanding the Display

The Folder Compare display uses color cues to highlight the differences between the two
base folders.  By default, the color meanings are:

Gray Unknown or older

Black Same

Purple Orphan (does not exist on other side)

Red Newer or different
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Pick View > Legend to display a guide to the various folder icon color combinations.

To change the default colors, pick Tools > Options , switch to the Colors, Fonts > Folder
Views page, and find the Compare colors settings.

You can click on a column header to sort by that column, or right-click the header to pick
different columns to display.

Files in the display

In the following example, the file on the right side is colored red to show that it is newer.

The icon in the center column  shows that a content comparison has found differences.

The color spot to the left of a filename show the difference color cue, even when a
selection obscures the coloring of the other elements on the line.

The center column shows the results of a content comparison, if one has been performed.

The content comparison results can override the file colors.  For example, the above line
would change to all black if the content comparison determines the files match.  To

disable this behavior, pick Session > Session Settings , switch to the Comparison tab,
and unmark the Override quick test results checkbox.

 On Windows file systems, the filename may be followed by letters in parenthesis that
represent the DOS attributes of read-only (r), hidden (h), archive (a), and system (s).

Some file types, such as zip archive files, can be a container for other files.  Beyond
Compare can handle these like regular folders.  The following example shows our compiled
help file with a newer version on the right side.  Notice the special "zipper" icon.

You can double-click the file to expand it and compare each of the contained files.

Folders in the display

Folders are colored to give you hints about their contents.  For instance, the comparison
below lets you know that the folders contain at least one file that is newer on the right
(red), and that both sides have at least one orphaned file (purple).

Folders may appear hollow when you first start the comparison.  This happens when the
background scanning process has not yet completed those folders.  They will change
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color when the process is finished.

A folder will be yellow if auto-scan is turned off and you haven't opened the folder yet. 
Once you manually open the folder (and possibly its subfolders) it will be colored
appropriately.

Folder icons will include a small arrow glyph if the folder is a junction point or symbolic link.
 Folder icons will include a small red "X" glyph if there was an error trying to open the
folder.  The following example shows a folder with both conditions.

2.2.2 How to Compare

There are several ways to compare folders and files.

If you want a quick look at what has changed between two folders, it might be sufficient
to just look at the dates and sizes of the files.  If you are validating a CD copy, then a
byte-by-byte comparison of every file is important.  If you are comparing versions of
source code, perhaps you want to consider only significant changes and ignore
differences in whitespace or comments.

Session settings define how, overall, a Folder Compare session should compare folders
when the session is loaded.  Comparison criteria include file timestamps, sizes, attributes
and contents.  Once the session is loaded, you can selectively recompare files by picking 

Actions > Compare Contents  or by opening the files in a file session.

Generally, these criteria are used to compare files, and not folders directly.  For instance,
a folder's timestamp does not affect the comparison.  A folder is classified as "newer" if it
contains newer files.  Folders are compared by aggregating the comparisons of files within
them.

Certain facts about a file can be determined quickly while others take some time.  In the
Session Settings dialog, the Comparison tab is organized into Quick tests and Requires
opening files.  File systems typically provide fast access to file names, sizes, and
timestamps (the date and time last modified).  But to get the CRC of a file, the entire file
will need to be read.  Keep this in mind when selecting folder comparison criteria.

The display aligns files and subfolders of the same name, left and right.  Pick View >

Ignore Folder Structure  to align files regardless of what subfolder they are in.

 You can modify the alignment by defining alignment overrides. 

2.2.3 Filtering the View

There are three overall type of filters you can use to control a Folder Compare's scope:  
F ile  F ilt ers that include or exclude files based on their name or attributes, Display F ilt ers
that show or hide lines of the comparison based on comparison status, and Folder Display
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F ilt ers that control when folders appear.

For instance, you can set the display filter to View > Show Left Newer  to display only
those files that are newer on the left side of the comparison.  Or you can set a file filter
to exclude *.bak files if you don't want to see or manipulate them.

By default, commands that act on a selected folder's contents (such as Copy, Move,
Delete, etc.) will respect the current filters.  That is, if the selection includes a folder, the
folder's filtered-out contents are skipped.  To change this default behavior, pick Tools >

Options , switch to the File Operations page, and mark the Include hidden items by
default checkbox.  In either case, action dialogs allow you to override the default
behavior on a case-by-case basis.

Pick View > Suppress Filters  to temporarily suppress file filters and display filters.  Files
and folders that were hidden will appear colored teal (blue-green) and can be processed.

File Filters

You can specify the type of files you want to include in (or exclude from) the session. 
For instance, if you are comparing Delphi projects you could include file types such as *.
pas, *.dfm, and *.dpr.  Or, you could include all files except *.dcu and *.~* by excluding
these file types.

To specify a simple "include these types" filter, use the Filters toolbar edit.  Enter the file
types separated by semicolons, or use the dropdown list to select from presets.  Include
a minus sign (-) in front of files to be excluded.

In addition to these simple wildcard filters, you can specify more complex filters that

include or exclude files or folders by name.  Pick Session > Session Settings , and switch

to the Name Filters tab.  Or, simply click the Filters  toolbar button.

Files can also be filtered based on their modified date, size, file attributes or text content.
 In the Session Settings dialog, switch to the Other Filters tab.  (Folders are not directly
filtered based on their attributes, but are affected by the filtering of their contents.)

Display Filters

Display filters limit the view to certain comparison results.  The comparison results are
determined by the session's comparison rules.  For instance, you can pick View > Show

Differences  to remove all the matching files so that you can concentrate on the
mismatches.

Folder Display Filters

By default, folders only appear if at least one file they contain is visible.  However, you
can switch to one of the other folder display filters.
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View > Always Show Folders  causes all folders to appear (unless they have been
explicitly excluded by file filters), regardless of the other display filter selection.

View > Compare Files and Folder Structure  causes folders to respect the display filters.

For example, if the main display filter is Show All  then all folders appear.  If it is Show

Orphans , only orphan folders and folders that contain orphan files are shown.

View > Only Compare Files  suppresses all empty folders, both truly empty folders and
folders whose entire contents are hidden by other display or file filters.

View > Ignore Folder Structure  hides the folder tree and aligns files regardless of what
subfolder they are in.

2.2.4 Reconciling Differences

A Folder Compare session provides commands, such as Copy, Move, Delete and
Synchronize, to help you reconcile differences on the folder level.  It also is a platform for
spawning file views to understand and reconcile differences within files.

Actions generally require a selection.  You can select specific files or folders from either or
both sides and then perform some action on them.  (If you want to synchronize the entire
contents of the base folders, consider using a Folder Sync session instead.)

To select items in the Folder Compare view

Click on an item on either side of the display to select it.  You can click in the center
column to select both sides at once.  Hold down the Ctrl key and click to add items to
your selection.  To select a range of items, press the mouse button over the first, swipe
to the last, and release the button.  If your swipe crosses the middle column, entries on
both sides will be selected.

To select all items on one side

Pick Edit > Select All  (or Edit > Select All Files ).  Hold down the Shift key and press
the left arrow key to limit the selection to the left side.  Press the right arrow key instead
to limit the selection to the right side.

To compare files with different names

Click the first file, hold down the Ctrl key and click the second one, and then pick Actions
> Open.  To use the keyboard instead, position on the first file and press the space bar,
then position on the second one and press the space bar.
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2.2.5 File Action Details

2.2.5.1 Content Comparison

In the Actions menu, the Compare Contents  command performs content comparisons
on the selected pairs of files to determine if they match.

Content comparison methods

CRC comparison compares files using their CRC values.

Binary comparison compares files byte-by-byte.

Rules-based comparison compares files based on their file format associations.  It allows
you to define unimportant differences, such as changes in whitespace or source code
comments.  A rules-based comparison can also ignore differences in file encoding or line
endings.

Results of content comparisons

CRC and Binary comparisons return one of these results:

Binary same The files are exactly the same.

Binary differences At least one byte is different between the files.

Rules-based comparisons have a built-in binary comparison and return one of these
results:

Binary same The files are exactly the same.

Rules-based same The files have binary differences, such as character encoding,
that can be ignored.

Unimportant
differences

A rules-based comparison found only unimportant differences.

Important
differences

A rules-based comparison found important differences.

When content comparisons are performed

Content comparisons are performed:

when a folder session is loaded, and its session settings call for automatic content
comparisons
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explicitly, when the Compare Contents  command is used

when a pair of files is opened in a file session

2.2.5.2 Copy

In the Actions menu, the Copy to Right, Copy to Left and Copy to Side commands copy the
selected files and folders from one side of the view to the other, overwriting any existing
files on the target side.

If a folder is selected, only its filtered contents will be copied (same as if the folder was
expanded and all visible contents selected).  However, if an open folder is selected and
any of its children are selected as well, then the folder's selection is ignored and only the
selected children will be copied.

By default, a confirmation dialog appears before the copy.  To skip the confirmation when
the direction of the copy is unambiguous (Copy to Left, Copy to Right), pick Tools >

Options , switch to the File Operations page, and unmark the Confirm file copy checkbox.

2.2.5.3 Move

In the Actions menu, the Move to Right, Move to Left and Move to Side commands move
the selected files and folders from one side of the view to the other, overwriting any
existing files on the target side.

If a folder is selected, only its filtered contents will be moved (same as if the folder was
expanded and all visible contents selected).  However, if an open folder is selected and
any of its children are selected as well, then the folder's selection is ignored and only the
selected children will be moved.

By default, a confirmation dialog appears before the move.  To skip the confirmation when
the direction of the move is unambiguous (Move to Left, Move to Right), pick Tools >

Options , switch to the File Operations page, and unmark the Confirm file move
checkbox.

2.2.5.4 Exchange

In the Actions menu, the Exchange command moves the selected files and folders from
one side of the view to the other.

If a folder is selected, only its filtered contents will be exchanged (same as if the folder
was expanded and all visible contents selected).  However, if an open folder is selected
and any of its children are selected as well, then the folder's selection is ignored and only
the selected children will be exchanged.

By default, a confirmation dialog appears before the exchange.  To skip the confirmation,

pick Tools > Options , switch to the File Operations page, and unmark the Confirm file
move checkbox.
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2.2.5.5 Copy to Folder

In the Actions menu, the Copy to Folder  command copies the selected files and folders
to a given folder, optionally with the path intact.  You can select items on one side of the
Folder Compare view or the other, but not both.

If a folder is selected, only its filtered contents will be copied (same as if the folder was
expanded and all visible contents selected).  However, if an open folder is selected and
any of its children are selected as well, then the folder's selection is ignored and only the
selected children will be copied.

When you pick Copy to Folder, you can make the target an archive file (such as .zip).  If
the archive file does not exist, Beyond Compare will create it for you.

Path options example

In this example, three items are selected:  The file 10.txt, the folder Q and the file 30.txt.

The pictures below show how the items look in the target folder, using each of the three
available path options.

Keep relative folder structure

Determines the minimum difference between all of the selected files' paths, and creates
that in the target folder.  In this example, folders D and P were not selected, but they
were created in the target folder in order to keep the same relative structure.
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Keep base folder structure

Creates the entire path (back to the base folder) in the target folder.

Don't keep folder structure

Ignores all path information and copies all selected files and folders into the target folder
together.  In this example, only the Q folder was created in the target folder, because it
was specifically selected.

2.2.5.6 Move to Folder

In the Actions menu, the Move to Folder  command moves the selected files and folders
to a given folder, optionally with the path intact.  You can select items on one side of the
Folder Compare view or the other, but not both.

If a folder is selected, only its filtered contents will be moved (same as if the folder was
expanded and all visible contents selected).  However, if an open folder is selected and
any of its children are selected as well, then the folder's selection is ignored and only the
selected children will be moved.

When you pick Move to Folder, you can make the target an archive file (such as .zip).  If
the archive file does not exist, Beyond Compare will create it for you.

Path options example
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In this example, three items are selected:  The file 10.txt, the folder Q and the file 30.txt.

The pictures below show how the items look in the target folder, using each of the three
available path options.

Keep relative folder structure

Determines the minimum difference between all of the selected files' paths, and creates
that in the target folder.  In this example, folders D and P were not selected, but they
were created in the target folder in order to keep the same relative structure.

Keep base folder structure

Creates the entire path (back to the base folder) in the target folder.
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Don't keep folder structure

Ignores all path information and moves all selected files and folders into the target folder
together.  In this example, only the Q folder was created in the target folder, because it
was specifically selected.

2.2.5.7 Delete

In the Actions menu, the Delete  command deletes the selected files and folders from
one or both sides of the comparison.

If a folder is selected, only its filtered contents will be deleted (same as if the folder was
expanded and all visible contents selected).  However, if an open folder is selected and
any of its children are selected as well, then the folder's selection is ignored and only the
selected children will be deleted.

Mark the Use recycle bin if possible checkbox to move files and folders stored on a local
drive to the recycle bin instead of being completely removed.  This option is ignored for
deletions from network drives, remote services and within archive files.

2.2.5.8 Rename

In the Actions menu, the Rename  command renames the selected files and folders.

In the Action subsection, you can pick either DOS compatible or Regular expressions
rename.

DOS rename

To rename files using DOS wildcards, pick DOS compatible in the Rename dialog.  In the
New mask edit, enter the new name.

If multiple files or folders are selected, a base mask is computed which represents the
overlap of all the names.  An asterisk (*) is used to represent one or more characters,
while a question mark (?) is used to represent a single character.  Leave these characters
alone, but change others to produce unique names for each of the selected files or
folders.

Examples:

Assume that you've selected the following files to rename:

     abc1.txt
     abc2.txt
     abc3.txt
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If you enter "abc?.bak" as the new mask, the files will be renamed to:

     abc1.bak
     abc2.bak
     abc3.bak

If you enter "xyz?.txt" as the new mask, the files will be renamed to:

     xyz1.txt
     xyz2.txt
     xyz3.txt

Regular expression rename

To rename files using Perl compatible regular expressions, pick Regular expressions in the
Rename dialog.  In the Old mask edit, enter a regular expression that is matched against
the original filename.  In the New mask edit, enter a template used to generate a new
filename.

Examples:

Assume that you've selected the following files to rename:

     abc1.txt
     abc2.txt
     abc3.txt

If you enter "txt" as the old mask and "bak" as the new mask, the files will be renamed to:

     abc1.bak
     abc2.bak
     abc3.bak

If you enter ".*(\d\.txt)" as the old mask and "xyz$1" as the new mask, the files will be
renamed to:

     xyz1.txt
     xyz2.txt
     xyz3.txt

2.2.5.9 Attributes

In the Actions menu, the Attributes command modifies various operating system
attributes of the selected files and folders.
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 For Windows file systems, the DOS attributes (Read-only, Hidden or Archive) are
modified.  You cannot modify the System attribute.

  For Mac and Linux file systems, the owner and group access permissions are
modified.

If a folder is selected, its attributes are modified but not those of its contents.  To modify
the attributes of folder contents, you need to expand the folder and select the contents.

The checkboxes initially show the current state of the selected items.  If a checkbox is
unmarked, that attribute is disabled on all the selected files.  If a checkbox is marked,
that attribute is enabled on all the selected files.  If a checkbox is marked and gray, that
attribute is only enabled on some of the selected files.

Unmark a checkbox to clear that attribute from all selected files, or mark it to set the
attribute.

2.2.5.10 Touch

In the Actions menu, the Touch  command modifies the timestamp (date/time last
modified) of the selected files.

If Copy timestamps from other side is marked, then the timestamps of the selected files
will be set to match those on the other side.  If Set timestamps to --> is marked, then
any date/time can be selected from the calendar.

The Default selection controls how the calendar is initialized.  Mark Current system time to
use the current time.  Mark Last touch to use the timestamp from the last touch
operation.  The Default selection only initializes the calendar -- you can still change it to
any date or time.

If a folder is selected, the Touch command will attempt to change the folder's timestamp
but not that of its contents.  This command will fail if the operating system does not allow
changing folder timestamps.

2.2.5.11 Exclude

In the Actions menu, the Exclude command filters out the selected files and folders from
the current session.  It is a handy alternative to opening the Session Settings dialog and
entering file/folder exclusions on the Name Filters tab.

If you select one or more files of the same type, the Exclude command will offer to
exclude all files of that type.

To remove an exclude, click the Filters  toolbar button and remove the entry from the
Exclude files (or Exclude folders) list.
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2.2.5.12 New Folder

In the Actions menu, the New Folder  command lets you create a folder at the current
position.  If you have a file or closed folder selected, the new folder will be created with
the same parent folder as the selected item.  If you have an opened folder selected, the
new folder will be created as a subfolder of the selected one.

If both sides are selected, a new folder will be created on both sides.

You can create an archive file by including an appropriate extension (such as .zip) in the
name.

To create a new folder to use as a base folder, type the path for the new folder into the
left or right edit controls, and press the Enter key.  In the warning dialog that appears,
click the Create button.

2.2.5.13 Synchronize

In the Actions menu, the Synchronize submenu has commands that synchronize the
current selection.

Update Right Copies newer and orphan items from left to right.

Update Left Copies newer and orphan items from right to left.

Update Both Copies newer and orphan items from left to right and from right
to left.

Mirror to Right Replaces all different items on right, deletes any right-side
orphans, and copies any left-side orphans to the right.

Mirror to Left Replaces all different items on left, deletes any left-side
orphans, and copies any right-side orphans to the left.
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2.3 Folder Merge

A Folder Merge session displays two or three folder structures side-by-side.  The left and
right panes hold two versions of a folder structure.  Beyond Compare helps you combine
changes from both versions into a specified output folder.  The optional center pane holds
an older version of the folder structure, a common ancestor of the left and right versions.

2.3.1 Understanding the Display

The Folder Merge display uses color cues to highlight the differences between the base
folders.  By default, the color meanings are:

Gray Unknown or older

Black Same

Teal Left change

Magenta Right change



Using Beyond Compare 31

Copyright © 2014 Scooter Software, Inc.

Orange Mergeable

Red Conflict

Pick View > Legend to display a guide to the various folder icon color combinations.

To change the default colors, pick Tools > Options , switch to the Colors, Fonts > Folder
Views page, and find the Merge colors settings.

You can temporarily hide the Center Pane  to give the left and right panes more room.

Merge actions

Regardless of merge target:

No action required

Automatic merge

Manual merge required

When merging to left:

Copy to left

Delete left

When merging to right:

Copy to right

Delete right

When merging to other:

Take left

Take center

Take right

Delete
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2.3.2 File Action Details

2.3.2.1 Copy to Output

In the Actions menu, the Copy to Output  command copies the selected files and folders
to the output side.

If a folder is selected, only its filtered contents will be copied (same as if the folder was
expanded and all visible contents selected).  However, if an open folder is selected and
any of its children are selected as well, then the folder's selection is ignored and only the
selected children will be copied.

By default, a confirmation dialog appears before the copy.  To skip the confirmation, pick 

Tools > Options , switch to the File Operations page, and unmark the Confirm file copy
checkbox.

2.3.2.2 Merge

In the Actions menu, the Merge  command performs a merge of the selected files and
folders.

If a folder is selected, only its filtered contents will be merged (same as if the folder was
expanded and all visible contents selected).  However, if an open folder is selected and
any of its children are selected as well, then the folder's selection is ignored and only the
selected children will be merged.

By default, a confirmation dialog appears before the merge.  To skip the confirmation,

pick Tools > Options , switch to the File Operations page, and unmark the Confirm file
merge checkbox.
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2.4 Folder Sync

A Folder Sync session is a specialized folder session that synchronizes folders by copying
or deleting files.  Once you set up a Folder Sync session you can save it for future use.

2.4.1 Understanding the Display

Sync actions

Right file will be copied to the left

Left file will be copied to the right

Left file will be deleted

Right file will be deleted

Files will be left alone unless you pick an override from the Actions menu

Right folder contains files that will be copied to the left
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Left folder contains files that will be copied to the right

Left folder contains files that will be deleted

Right folder contains files that will be deleted

Left folder contains files that will be copied to the right and files that will be
deleted

Right folder contains files that will be copied to the left and files that will be
deleted

2.4.2 How to Sync

Setting sync parameters

In the upper part of the view, specify the Left folder and Right folder involved.  Either or
both base folders may be on remote services.  (You can use the Browse buttons to
specify a remote service.)

Pick one of these standard sync methods from the dropdown list in the middle of the
view:

Update Left 

Copies newer and orphan files from right to left.

Update Right 

Copies newer and orphan files from left to right.

Update Both 

Copies newer and orphan files to the other side.

Mirror to Left 

Replaces all different items on left, deletes any orphans on left, and copies any right side
orphans to the left.

Mirror to Right 

Replaces all different items on right, deletes any orphans on right, and copies any left side
orphans to the right.

Click the Rules  button to define what constitutes a difference.

You can also specify Filters  to limit the scope of the sync.

Previewing the sync

Click the Accept  button if necessary to accept changes, and a preview of all copy and
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delete operations will appear in the lower part of the view.

You can double-click any file pair to examine the differences in detail.  To skip selected
operations, pick Actions > Exclude.

Starting the sync

Click the Sync Now  button to begin processing.
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2.5 Text Compare

A Text Compare session visually compares two text files, in a side-by-side or over-under
layout.  It helps you analyze and reconcile differences, with a variety of display, search,
and editing functions available.

In addition to files on your hard drive or network, you can specify files from a remote
service, from within an archive file, or the content of a webpage.  Example file specs:

C:\MyArchive.zip\MyFile.txt

/home/username/Desktop/MyFile
ftp://username@ftp.hostname.com/file.txt
http://www.scootersoftware.com/index.html

You can also compare against text on the clipboard by picking File > Open Clipboard.

The Text Compare view displays files in two editor panes that scroll together.  Text is
colored to highlight differences between the files.  By default, the color scheme uses red
to flag important differences (insertions, deletions, and changes) and blue for unimportant
differences.  The session's rules and file formats control how text is classified.

The display background is also colored to help you spot the differences.  A light red
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background indicates an important difference somewhere on the line, while light blue
indicates an unimportant difference.  The light red background takes precedence over the
light blue.  This makes it easy to find differences, even if they are horizontally scrolled out
of view.  You can adjust these colors to suit your preferences.  (See File View Color, Font
Options.)

On the left edge of the display is the optional thumbnail.  It represents each line of the
comparison as a colored line, one pixel high.  At a glance you can see the pattern of
differences throughout the comparison.  The white rectangle represents the main display's
current view, and the small triangle represents the display's current line.  Click on a line in
the thumbnail to position the display at that location.

Below the main panes, the current line from each file is displayed using the entire width of

the window.  In the View menu, pick Text Details  for an editable text view, Hex Details

 for a read-only hexadecimal view, or Alignment Details  for an editable view of the
character alignment.

2.5.1 Editing Text

Each pane of the Text Compare view is a full-featured text editor.  You can enter and
edit text like any other text editor, although as you do the comparison is continually
updated to reflect differences between the panes.

Line mode vs. character mode

The Full Edit  command toggles the editor between Line Mode and Charac ter Mode.  In
line mode, editing occurs on a line-by-line basis, so selection, cut, copy, paste, delete,
etc. all affect entire lines.  While in line mode you can edit individual lines using the Text
Details area.  Line mode supports disjointed selections.  In character mode the main panes
support editing text.  Selection and editing commands all affect individual characters or
spans of characters.  Character mode can only have a single, continuous selection.

Visible whitespace

Enabling the Visible Whitespace  command allows you to see where spaces, tabs, and
line endings occur in your files.  The following example illustrates each of them.

Space

Tab

Windows line ending

Mac line ending

Unix line ending
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Editing disabled

Beyond Compare disables editing of a file for any of the following reasons:

The comparison encountered an error.

The comparison was cancelled.

The location of the file is read-only (e.g. 7zip/CHM/RAR archives, CD-ROMs, DVD-ROMs).

The file format conversion doesn't support saving.

Editing in the parent folder session has been disabled.

Editing in the file session has been disabled.

Command line switches have disabled editing.

2.5.2 Walking Through Differences

In the Search menu, the Next Difference Section  and Previous Difference Section 
commands help you step through all the differences in your files, and all your files with
differences.  In the Text Compare, pick Next Difference Section to position at the next
range of lines with differences or Previous Difference Section to go back to the previous
range of lines with differences.

The arrow icons will either be disabled or change color from bright yellow to dull yellow to
indicate that there are no more differences in that direction.  To configure what happens
when there are no more differences, see File View Next Difference Options.

In Text Compare sessions, the current file format controls whether Next and Previous are
on a line-by-line basis or a section-by-section basis.  To access the current file format

from a Text Compare session, pick Session > Session Settings , switch to the
Importance tab, and click the Edit Grammar button.  Then, on the Text Format dialog's
Misc tab, toggle Lines are independent.

In the Search menu, pick Next Difference or Previous Difference to position on individual
differences in long lines with multiple differences.

In the Search menu, pick Next Difference Files  or Previous Difference Files to jump
directly to the next files with differences in the associated folder view.

2.5.3 Searching for Text

To search for text in a Text Compare session, pick Search > Find .  Type the text or a
regular expression pattern in the edit, or pick a previous search from the dropdown list. 

Click on the Insert Regular Expression Element  button to pick from a list of common
regular expression terms.  Pick one from the list to insert it in the edit.
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Click the Next button to move the cursor to the next match.  If the editor is in line mode,
you can click the Select All button to select all the lines that contain a match.

The Find panel options are:

Option Meaning

Regular expression Interpret search text as a Perl compatible
regular expression.

Match character case Only match text with the same character
case (uppercase or lowercase).

Whole words only Searching for apple will not match on apples
, applesauc e or snapple.

Wrap search When one end of the file is reached,
continue searching at the other end.

Sides Select which side(s) of the comparison to
search.

Close automatically Panel will hide after search is started.

Pick Find Next  or Find Previous  to continue searching for the same text.

To find and replace text, pick Replace .
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2.6 Text Merge

A Text Merge session contains two or three non-editable source panes and an editable
output pane.  The left and right panes hold two versions of a file.  Beyond Compare helps
you combine changes from both versions into the output pane.  The optional center pane
holds an older version of the file, a common ancestor of the left and right versions.

You can temporarily hide the Center Pane  to give the left and right panes more room.

You can also use the Detached Output Pane  to move the output into a separate
window.  If you have a second monitor, you can then move this window onto it.

The output content is constructed automatically as the comparison loads.  You can
manually edit the output, or use the Take commands to pull text from a specific source
file, overriding the default merge.

It is important to note that any prior copy of the output file is ignored.  If it existed
before the merge session, or was changed during the session, the existing content will be
lost if you save the merge session output.
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2.6.1 Using Text Merge

Once Beyond Compare has completed the comparison it will show up to four panes:  The
left, center, and right panes at the top, with an output pane below it.  If you include a
center file Beyond Compare will be able to compare both files to it and mark changes as
additions, modifications, or deletions on each specific side.  Changes on the left are
marked in teal and changes on the right are marked in magenta.  Overlapping changes are
considered conflicts and are marked in red.  (You can change the color scheme if you
like.)

Conflicts

Any time there are different changes in the left and right side that are on the same lines
or within two lines of each other those sections will be considered a conflict and will be
colored red in the three input panes.  The output will be considered a conflict.  If the
same change is made in both the left and right side it isn't considered a conflict.

Display Filters

When merging, the display filters switch from Beyond Compare's traditional ones to new
ones that check the merging status of each line.  Using those filters you can limit the
display to just conflicts or just changes on one side or the other.

Merging

You can navigate from difference to difference in both the input and output panes and
the windows will stay synced up.  When you are positioned on a difference you can use

the Take Left , Take Center , and Take Right  commands to accept the changes
from the left or right or keep the original from the center.  The "Take" commands are
available on the toolbar, in each edit's popup menu, and as buttons next to each section
in the output pane.  When it first loads, the output pane will match the center except
when it can automatically take non-conflicting changes.  Each change will be colored to
match the pane it originally came from.  While merging you can also edit the output pane
directly, which will change the section to yellow.  If you want to revert to one of the
original inputs just use the "Take" command again.
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2.7 Table Compare

A Table Compare session compares text files containing tabular data, such as .csv
(comma separated values) files, in a side-by-side or over-under layout.  The files are
displayed in two grids that scroll together and the data is compared cell-by-cell.

The display shows comparison columns, not necessarily the columns as they are organized
in the data files.  For example, the first comparison column may be comparing the third
column of the left data file against the fifth column of the right file.  See Table Compare
Column Settings.

By default, Table Compare sorts your files before comparing them and aligns rows with
matching key columns.  You can define any combination of comparison columns as the
key.  If you specify an unsorted alignment, Beyond Compare will not sort the files, but will
still only align rows with matching keys.

The display uses color to highlight differences.  A row with a light red background
indicates an important difference somewhere on the line, while light blue indicates an
unimportant difference.  The light red background takes precedence over the light blue. 
This makes it easy to find differences, even if they are horizontally scrolled out of view. 
You can adjust these colors to suit your preferences.  (See File View Color, Font Options
.)
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2.8 Hex Compare

A Hex Compare session visually compares the raw content of two files, either in a side-
by-side or over-under layout.  It displays file content byte-by-byte, using the
hexadecimal notation typical of hex editors.
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2.9 Picture Compare

A Picture Compare session compares a pair of image files visually, showing the differences
between them.

Supported image file types

By default, the file types associated with the Picture Compare are:

  GIF (*.gif)
  Icons (*.ico)
  JPEG (*.jpg)
  Portable Network Graphics (*.png)
  TIFF (*.tif)
  Windows bitmap (*.bmp)

Depending on which version of the operating system and third-party codecs have been
installed, the Picture Compare could also handle:

  Adobe PDF (*.pdf) 
  Alias/Wavefront (*.rla;*.rpf)

  Apple Icons (*.icns) 
  Autodesk (*.cel;*.pic)
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  Camera RAW images (*.3fr;*.arw;*.cr2;*.crw;*.dcr;*.dng;*.erf;*.fff;*.
fpix;*.fpx;*.mos;*.mpo;*.mrw;*.nef;*.nrf;*.orf;*.pef;*.raf;*.raw;*.rw2;*.

rwl;*.sr2;*.srf;*.srw) 
  Dr. Halo (*.cut)
  Encapsulated Postscript (*.eps)

  FAX images (*.efx;*.fax;*.g3;*.jfax;*.jfx) 
  JPEG (*.jpeg;*.jpe;*.jfif;*.exif)

  JPEG 2000 (*.jp2;*.jpf) 

  JPEG XR/HD Photo (*.jxr;*.wdp) 
  Kodak Photo-CD (*.pcd)

  Macintosh PICT (*.pct;*.pic;*.pict) 

  MacPaint (*.mac;*.pnt;*.pntg) 

  Misc (*.cur;*.epi;*.exr;*.hdr;*.jps) 
  Netpbm (*.pbm;*.pgm;*.ppm)
  Photoshop (*.psd;*.pdd)

  Postscript (*.ps) 

  QuickTime image (*.qti;*.qtif) 
  SGI (*.bw;*.rgb;*.rgba;*.sgi)
  TIFF (*.tiff)
  Truvision (*.tga;*.icb;*.vda;*.vst;*.win)
  Windows bitmap (*.dib;*.msk;*.rle)
  Windows metafile (*.emf;*.wmf)

  X PixMap (*.xpm) 
  ZSoft Paintbrush (*.pcc;*.pcx;*.scr)

2.9.1 How to Compare

Aligning image content

You can compare images that have been resized, rotated, reflected or cropped.

Pick Auto Scale  to automatically enlarge the smaller image to match the scale of the
larger one.

Pick Rotate Clockwise  or Rotate Counterclockwise  to rotate the current image ninety
degrees to the right or to the left.

Pick Flip Horizontally  or Flip Vertically  to reflect the current image across its y-axis
or x-axis.

If one image is a cropped version of the other, you can drag the mouse over the
difference pane to adjust the position of the right image's top left corner.  To reset the
offset back to (0,0) pick Reset Difference Offset or simply click on the offset label.  For
finer control, use the arrow keys to nudge the offset one pixel at a time, or Ctrl+arrow
keys to move by a larger amount.  Note that the difference pane must be selected for the
keyboard nudge function to work.



Beyond Compare46

Copyright © 2014 Scooter Software, Inc.

Tolerance Mode

Pick Tolerance Mode  to have difference pixels indicate matches, unimportant
differences, and important differences.  It uses a configurable Tolerance to define the
greatest degree of difference that is considered unimportant.  You can also define 
Replacements to ignore specific color changes between images.  By default, shades of
gray are used for matches, shades of blue are used for unimportant differences, and
shades of red are used for important differences.  You can adjust these colors to suit
your preferences.  (See Picture Compare Colors.)

Mark Ignore Unimportant Differences  to ignore any differences less than or equal to the
tolerance.  They will be handled the same as matching pixels.

Mismatch Range Mode

Pick Mismatch Range Mode  to have difference pixels represent the degree of difference
between the images.  Black pixels are used for matches and yellow ones are used for
differences.  Brightness represents the degree of difference.

Blend Mode

Pick Blend Mode  to use a configurable Blend percentage to combine the images.
Decrease the percentage to make the right image more dominant.
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2.10 Registry Compare

A Registry Compare session compares live registries on your computer or other computers
on your network, and .reg export files, either in a side-by-side or over-under layout.

Keys and values are sorted and aligned based on their names.  Keys will be colored based
on whether they contain differences or orphans.  Values will be colored to highlight
character differences.  Red indicates a difference and purple indicates an orphan.

Once the comparison is loaded, you can directly edit live registries.  You can copy items
between registries, delete or rename existing items, and add new items.  Double-clicking
on a value also allows you to change its type and data.
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2.11 Text Edit

A Text Edit view is a single-pane text editor.
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2.12 Text Patch

A Text Patch view recreates a comparison represented in a patch file.  Patch files can be
generated using a Text Compare report or a another diff program.
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2.13 Other View Types

MP3 Compare

An MP3 Compare session compares two MP3 files with differences in tag fields highlighted.

Version Compare 

A Version Compare session compares version info in a pair of executable files.
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2.14 File Formats

Beyond Compare uses file formats to specify how certain types of files are to be handled.
For example, files with a .jpg or .png extension are associated with Picture Compare, while
.c and .cpp files are recognized as having C/C++ syntax and are handled by Text
Compare.  You can modify the built-in file formats or create your own.

File formats determine:

The type of view used for visual comparison

What conversion, if any, should be performed before comparing or saving

The syntax, or grammar, of the file's content

Case sensitivity of grammar elements

Tab stops

Line weights to help the alignment process

File formats primarily control how the file views handle your files, but they can also affect
how a folder session compares file contents.  If you use rules-based content comparison,
then the folder session can limit the display to only files with important differences.

2.14.1 Grammars

A file format specification can include a grammar definition, used for syntax highlighting,
and to help define which differences are important.

For example, our standard file format for C/C++ source code includes a grammar that
recognizes keywords, comments, and literal strings.  By flagging differences in comments
as unimportant, you can better concentrate on important differences.

A grammar definition in Beyond Compare is fairly simplistic.  It does not support nested or
context-specific definitions, so it doesn't handle tagged languages like HTML and PHP very
well.  On the other hand, it is a big step up from Beyond Compare 2's functionality.

To edit a grammar, pick Tools > File Formats  and find the appropriate file format.
Switch to the Grammar tab and edit the grammar items.

2.15 Reports

Comparison reports allow you to save the information from a comparison to view later
without re-running the comparison.  These reports can be printed directly from Beyond
Compare, or saved in HTML or plain text format.

The report feature is available on the Session menu in various types of sessions.  For

instance, in a Folder Compare session you would pick Session > Folder Compare Report .

The style of reports available differs for the various session types, but the options are
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much the same.  You can output a report to any of these locations:

Printer
HTML report (file or clipboard)
Plain text (file or clipboard)

The Printer and HTML choices support difference highlighting with color.

You can preview a Printer report with the Print Preview button, or an HTML report with
the View in Browser button.

2.16 Specs

A Spec is the name of a folder or file.  Beyond Compare supports several different types of
specs.

Local and network drives are represented using the syntax native to each platform:

 C:\MyFile.ext

 \\MyServer

 \\MyServer\MyFolder

  /MyFolder

  ~/MyFolder

  smb://MyServer/MyFolder

 Portable media devices (Android phones, MP3 players, cameras) are represented using
the MTP syntax:

mtp://MyDevice/MyFolder

Webpages are represented using the HTTP syntax.  This support only works for individual
files, and cannot be used for base folders:

http://www.example.com

 Live registries are represented using the standard syntax:

reg:\\HKEY_LOCAL_MACHINE\MyKey
reg:\\MyComputer\HKEY_USERS\MyKey

The clipboard is represented using this syntax:

clipboard://

2.16.1 Archive Files

Archives are files that contain other files, such as .zip.  Beyond Compare displays them as
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folders, with a zipper icon, but by default treats them as files when copying or comparing
them.  Once you have expanded the archive by double-clicking on it, the files within will
be compared.  Many of the formats support both reading and writing, so you can use all
of the usual file operations on the files within the archives, including comparing the
content, copying, renaming, etc.

Common archive formats

  7z archive (*.7z;*.7z.001) 
  BZip (*.bz;*.bz2)
  BZipped Tar (*.tbz;*.tbz2;*.tar.bz2)
  Beyond Compare Snapshot (*.bcss;*.bcs)

  Compiled HTML Help (*.chm) 

  Deb archive (*.deb) 
  GZip (*.gz)
  GZipped Tar (*.tgz;*.tar.gz)

  Microsoft Cabinet (*.cab) 

  RAR (*.rar) 

  Rpm archive (*.rpm) 
  Tar (*.tar)
  Zip (*.zip;*.zipx;*.jar;*.ear;*.war;*.bcpkg)

To view the full list of archive formats or change the file extensions associated with them,

pick Tools > Options  and switch to the Archive Types page.

Beyond Compare snapshots

These files are similar to other archives, but only include the file names, dates, and sizes,
without including the file content itself.  Since they are so small, you can save a snapshot
of an entire hard drive and compare against it later.

Total Commander "packer" plug-ins 

Beyond Compare can also use Total Commander "packer" plug-ins to support additional
archive formats.  For example, there are plug-ins to support ISO disc images (.iso) and
Microsoft Installer Packages (.msi).

To add one of these third-party plug-ins, on the Archive Types page, click the Add Plug-in
button, and follow the instructions.

2.16.2 Remote Services

Remote services include FTP and Subversion.

FTP sites are represented using the standard syntax:

ftp://username@ftp.hostname.com
ftp://username:password@ftp.hostname.com
ftp://ftp.hostname.com
ftp://username@ftp.hostname.com/subfolder
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ftp://username@ftp.hostname.com//subfolder
 sftp://username@hostname.com
 ftps://username@hostname.com

Subversion servers are represented using the standard syntax:

svn://hostname/subfolder
svn://hostname/subfolder@1234
svn+http://hostname/subfolder
svn+https://hostname/subfolder
svn+ssh://hostname/subfolder

Named profiles are necessary for Amazon S3, Dropbox, and WebDAV.  The are represented
using this syntax:

profile:MyProfile
profile:MyProfile?MyFolder/MyFile.ext

2.17 Snapshots

In the Tools menu, the Save Snapshot  command saves a compressed read-only listing
of the specified folder and all of its subfolders, including each file's timestamp, size, and
file attributes.  Snapshots have a .bcss file extension.

Snapshots are useful for detecting changes over time.  Snapshot files can be loaded at a
later date and compared to a live folder.  You can load a snapshot just like any other
base folder.  Binary and rules-based content comparisons do not work on snapshots, since
the files in the snapshot do not really exist.

If CRCs of the files are included in the snapshot, then CRC comparisons can be used to
determine whether the contents of files have changed.  This can be useful for detecting
data corruption and other subtle changes to your data.

A snapshot remembers the name of the base folder it was produced from.  If you load a
snapshot on the command line (or drag a snapshot file onto the Beyond Compare icon),
the program will automatically compare the snapshot with the original folder.

2.18 Calling Beyond Compare from Other Applications

As you would expect, Beyond Compare's setup program creates shortcuts to the main
executable file, such as:

  C:\Program Files\Beyond Compare 3\BCompare.exe

However, if you call Beyond Compare from a batch file or a version control system, we
recommend using "BComp" instead of "BCompare.exe".  BComp is a helper program which
launches Beyond Compare and waits until it is closed.  For more technical details, see 
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Command Line Reference.

2.19 Moving Beyond Compare to Another Computer

To copy or move Beyond Compare to a different computer

1. On the new computer, download and install the latest version of Beyond Compare.

2. Enter your registration key in the new installation.

3. Run Beyond Compare on the old computer and pick Tools > Export Settings to save all
desired settings in a file.

4. Copy this settings file to the new computer.

5. Run Beyond Compare on the new computer and pick Tools > Import Settings to load
the settings file.

Note  If you have Beyond Compare version 2.0 or older on the old computer, you will not
have an Export Settings command.  You can contact Scooter Software for assistance in
transferring your settings.

2.20 Scripts

Beyond Compare provides a script processing feature which allows you to automate
routine tasks.  A script is a simple text file containing a list of commands which can
control the program and automatically perform file operations or produce reports.  See 
Scripting Reference for a list of all scripting commands.

Scripts run without displaying the usual Beyond Compare user interface, but might require
input for certain confirmations.  Scripts essentially manipulate an invisible folder session:
file operations require selections, the "display" can be limited with filters, and folders can
be "expanded" to recurse into them.  Any folder name argument can be a folder on your
system, on the network or a remote service, or the name of an archive file such as .zip, .
cab, or Beyond Compare Snapshot file.

Running a script

Specify the filename of the script on the command line with a leading '@' symbol, as in:

BCompare.exe @"C:\My Folder\My Script.txt"

bcompare @"My Folder/My Script"

Creating a script

Scripts are processed line by line, with a single command per line.  Scripts are not case
sensitive, and blank lines and comments (anything after a '#') are ignored.  Arguments are
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separated by spaces.  To include a space in an argument, surround the argument with
quotes (").  To continue a long command on a second (or third) line, add an ampersand
(&) at the end of every line but the last.

A parameter specified on the command line can be referenced by inserting a percent sign
(%) followed by a single number from 1-9.  The script name and command line switches
starting with / are not included in the 1-9 list.  Given the command line:

BCompare.exe @"My Script.txt" /silent "My Session"

the session named "My Session" can be loaded by adding the following to the script:

load "%1"

An environmental variable can be inserted by enclosing its name in percent signs.  The
character case of the environmental variable must be correct.  The system's temporary
folder can be loaded by adding the following to the script:

load "%TMP%"

There are several dynamic variables that Beyond Compare can fill in at each line of the
script.  The %date% variable fills in the current date in the format yyyy-mm-dd.  The %
time% variable's format depends on your computer's regional settings.  The %fn_time%
variable outputs the time as hh-mm-ss, which can be used for filenames.

Scripting command line switches

  Note  Mac and Linux users should prefix the switches with "-" instead of "/".

The command line switches that affect scripting are /closescript, /leftreadonly, /

readonly, /rightreadonly, and /silent.  Normally, script processing adds an entry on

the Task Bar and displays a Scripting Status Window detailing its progress and any errors.
 The /silent switch bypasses the Task Bar entry and Scripting Status Window, allowing

Beyond Compare to process the script invisibly.

Scripting options

To change the script processing options, pick Tools > Options , switch to the Tweaks
page, and then scroll to find Scripts.  Mark the Beep when finished checkbox to have
Beyond Compare sound an audible beep when it completes script processing.  This beep
can alert you to check and close the Scripting Status window.  Close when finished
causes Beyond Compare to automatically close its Scripting Status window when it
completes script processing.  When used in conjunction with Beep when finished, the beep
simply tells you the process has completed.

There is also a place to designate a Shared scripts folder.  When you provide a script
name argument on the command line with no path designation, and there is no file of that
name in the current folder, Beyond Compare will look in the Shared scripts folder for that
script.
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2.20.1 Sample Scripts

The following are some sample scripts to show how Beyond Compare can use scripts.  You
can either use these scripts as is or model your own scripts after them.

Here is a basic script which copies all of the newer and orphaned files from one folder to
another, using a previously created session:

  load "Sync Laptop"
  sync update:left->right

Syncing two folders

Here is a more advanced script which syncs two specific folders using advanced filters. 
This works the same as loading the folders in a Folder Compare session and performing a
"Mirror Left to Right" folder synchronization.

# Turn logging on.
log normal "C:\My Log.txt"
# Load the default session and exclude all but certain file types.
load <default>
filter "*.html;*.htm;*.png;*.jpg"
# Load the base folders.
load "C:\My Folder" ftp://user@website.com/folder
# Copy different files left to right, delete orphans on right.
sync mirror:left->right

Comparing two files by name

This script compares two files by name.

file-report layout:side-by-side &
  options:display-mismatches &
  output-to:%3 %1 %2

A sample command line, calling the above script:

BCompare.exe @"My Script.txt" "My File.txt" "Your File.txt" "My Report.
txt"

Note  An ampersand (&) at the end of a line means that the command continues on the
next line.

Note  %1, %2, and %3 refer to the 1st, 2nd and 3rd command line argument,
respectively.

Generating a report

This script compares two files by name and generates an html report showing differences
with context:
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text-report layout:side-by-side &
  options:ignore-unimportant,display-context &
  output-to:%3 output-options:html-color %1 %2

Keeping a web site in sync

This script keeps a web site in sync with development files.

# Turn verbose logging on.
log verbose append:"C:\My Log.txt"
# Set the comparison criteria.
criteria timestamp size
# Load source and target folders.
load "C:\My Folder" ftp://user@website.com/folder
# Filter to only include source files, ignore CVS subfolders.
filter "*.htm;*.html;*.php;*.jpg;*.gif;-CVS\"
# Sync the local files to the web site, creating empty folders.
sync create-empty mirror:left->right

Performing a rules-based comparison and logging results to a file

This script logs the script results to a file that uses the current date as part of the name.
 The variable %date% is expanded by the script in the format 2012-12-31 on U.S. English
systems, on other systems it will match the system locale.  It performs a rules-based
comparison of Pascal source files and generates a report of mismatches.

# Log to a file of the form "C:\My Log 2012-12-31.txt".
# The exact format depends on your regional and language settings.
log verbose append:"C:\My Log %date%.txt"
# Compare the text contents of the files.
criteria rules-based
# Only compare Delphi source files, ignore the archive folder.
filter "*.pas;*.dfm;*.dpr;*.inc;-archive\"
load "C:\My Folder" "C:\Your Folder"
folder-report layout:summary &
  options:display-mismatches,column-attributes,column-timestamp,column-
size &
  output-to:"My Report.txt"

Comparing current folder state to a snapshot

This script compares the current state of a folder to a snapshot from the last time
updates were sent out.  Then it copies the changed and new files to an archive file and
updates the snapshot of the folder.

option confirm:yes-to-all
# Compare using crc.
criteria crc
# Load current files against snapshot from the last patch.
load "C:\My Folder" "C:\My Snapshot.bcss"
# Expand to affect subfolders and files.
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expand all
# Select updated files.
select left.diff.files left.orphan.files
# Copy changes to an archive file.
copyto left path:relative "C:\My Archive.zip"
# Update the snapshot.
snapshot save-crc left output:"C:\My Snapshot.bcss"

Generating a report of differences

This script generates a report of only differences.

# Set up basic comparison features.
criteria timestamp:2sec
# Filter out log files.
filter "-*.log"
# Load first comparison.
load "C:\My Folder" "C:\Your Folder"
# Compare files with timestamp differences.
select newer.files older.files
# Generate a report of the differences.
folder-report layout:summary options:display-mismatches output-to:"C:\My
Report.txt"

2.20.2 Scheduling a Script

You can use Beyond Compare's script processor to perform certain tasks, such as
synchronizing folders, without interaction.  For example, to automate a backup of "C:\My
Folder", enter the following script commands into Notepad:

load "C:\My Folder" "C:\My Backups"
expand all
select left.newer.files left.orphan.files
copy left->right

Save this text file as "C:\My Scripts\Sync.txt".

To run a Beyond Compare script at any desired time:

1. In Windows Task Scheduler, pick Action > Create Basic Task to get a wizard.

2. In Action, pick Start a program.

3. In Program/script, pick the Beyond Compare 4 executable.

4. In Add arguments, add a reference to your script file:
@Sync.txt

5. In Start in, pick the script folder:
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C:\My Scripts

We recommend including a log command in your script.  If you have trouble with your
script, check out the Scheduled Tasks error log: "SchedLgU.txt" in your Windows folder.
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3
Settings Reference

Beyond Compare is highly configurable, and it sometimes can be hard to know where to go
in the program to change a specific setting.  Here's where to look:

Program Options

General user preferences are set in the Options dialog.  Pick Tools > Options  to open it.
 From here you can set startup options, control confirmation messages, and customize
display colors and fonts.

Session Settings

Most of the options that define the scope and rules of a comparison can be found in the 
Session Settings dialog.  Each session type has its own session settings dialog.  Pick

Session > Session Settings  to open the dialog, or simply click the Rules  toolbar
button.

Session settings are stored with your saved sessions.

File Formats

Specific file types can be configured in the File Formats dialog.  Pick Tools > File Formats

 to open it.

Profiles

Specific remote services can be configured in the Profiles dialog.  Pick Tools > Profiles to
open it.

Source Control Integration 

Specific source control associations can be configured in the Source Control Integration
dialog.  Pick Tools > Source Control Integration to open it.
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3.1 Program Options

To set program preferences

1. Pick Tools > Options  to open the Options dialog.

2. In the list at the left, click the item containing the options you want to set:

Startup

Tabs

Colors, Fonts

Folder Views

File Views

Picture Compare

Text Editing

Next Difference

Backups

File Operations

Archive Types

Toolbars, etc.

Open With

Tweaks

3. Modify the desired settings, and then click the Apply button to accept the changes,
or the OK button to apply and close.

3.1.1 Startup

Startup options

When Beyond Compare starts up, it normally shows the Home view.  To have the program
automatically start up with the same sessions that were open the last time you used
Beyond Compare, specify the same workspace name in the Load workspace and On Exit,
save workspace as edits.  In the Session menu, you can also use the Save Workspace As
and Load Workspace commands for further control.

When you start Beyond Compare with a pair of files specified, the program can display a
dialog with a comparison summary, rather than taking the time to display the entire side-
by-side comparison.  To preface a file comparison with the Quick Compare dialog:

1. Mark the When starting with file comparison, show quick compare dialog checkbox.

2. Pick Binary quick compare to perform a byte-by-byte comparison, or Rules-based quick
compare to use the file format settings appropriate for the specified files.
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3. Mark the Open view automatically if files are different checkbox if you want the dialog
to only appear when the files match.

To add Beyond Compare to Explorer's right-click menu 

Mark the Include Beyond Compare in Explorer context menu checkbox.

Pick any of the optional commands listed in the table and pick Main menu or Submenu to
include it in the context menu.  Enable Compare Using to add a submenu that lists specific
views, such as the Table Compare view and the Hex Compare view.  This allows you to
override the view that would normally be selected via the file formats list.  Enable Merge
to add 3-way merge support to the context menu.  Enable Sync to support synchronizing
folders from Explorer.  Enable Edit to support editing a single file from Explorer.  Enable
Compare to Registry to support comparing a registry file to the live registry.

3.1.2 Tabs

When working with multiple sessions simultaneously, Beyond Compare can open them in
independent windows, or under tabs in a single window.  These options control that
behavior.

To control new sessions

Pick either A new window or A new tab for newly created sessions.

To control child sessions

Pick either A new window or A new tab for newly created file sessions that are opened
directly from a folder session.

To control miscellaneous tab behavior

Set the various options to reflect your preferences.

If you unmark both the Closing last remaining tab closes the window and Hide tab bar if
single tab checkboxes then closing the last tab will return to the Home view.

3.1.3 Colors, Fonts

Click the item containing the options you want to set:

Folder Views

File Views

Picture Compare
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3.1.3.1 Folder Views

These options allow you to customize overall colors and fonts used in folder views.

Font

By default, the font used for folder displays is the same as what the operating system
uses.  To change it, unmark the Use system font checkbox and click the Font button.

Selection

The Selection element controls the treatment of selected text.  By default, Beyond
Compare uses a medium blue color for selections so that difference coloring is not
obscured.  If you prefer the operating system's standard treatment for selections, mark
the Use system checkbox.  Selected files will then lose difference coloring, although the
color spot to the left of each filename will still be colored appropriately.

Miscellaneous

Pick the colors to be used for Filtered out items (when Suppress Filters  is used), and
for items whose comparison state is Unknown.  Mark the Use Stripes checkbox to tint the
background on every other line of the comparison.

3.1.3.2 File Views

These options allow you to customize visual aspects of the various types of file views.

Pick an element from the list to change its visual treatment.  You can change the Text
color and Background color of each element on the list.  For some elements you can
change the font Style to bold and/or italic.

Lower elements in the list override higher ones.  Pick Default to leave unchanged a color
set by an element higher on the list.

Mark the Use stripes checkbox to tint the background on every other line of the
comparison.

The Selection element controls the treatment of selected text.  By default, Beyond
Compare uses a medium blue color for selections so that difference coloring is not
obscured.  If you prefer the operating system's standard treatment for selections, mark
the Use system checkbox.  Selected text will then lose difference and syntax coloring,
although the statusbar will still describe the current position's comparison and grammar
type.

The Important difference and Unimportant difference settings control the treatment of
differences.  The Background color affects the entire line, allowing you to spot lines with
differences even when the actual differences are scrolled off-screen.  The Text
background color can be used to further highlight text that is different.

The list also includes syntax highlighting elements.
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Click one of the font buttons to change the overall font used to display text.  The Editor
Font is used in Text Compare, Text Merge and Table Compare views.  The Hex Font is used
in Hex Compare views, as well as the optional hex details display at the bottom of other
views.  The Listing Font is used in all other views.

3.1.3.3 Picture Compare

These options allow you to customize colors used in Picture Compare views.

Set the Background colors used in Tolerance mode for same, different, and similar pixels.

3.1.4 Text Editing

These options apply to Text Compare and Text Merge sessions.

Auto indent

When marked and a new line is created, it is automatically indented to match the leading
whitespace on the previous line.

Backspace unindents

When marked and the edit cursor is positioned immediately after the leading whitespace of
the line, pressing the Backspace key deletes enough whitespace to match the previous
indentation level, as defined by preceding lines.

Allow positioning beyond end of line

When marked, the edit cursor is not constrained by the end of text on a line.

Initialize "Text to find" to be current word

When marked and there is no selection, the current word is filled in as the search text for

the Find  command.

Show filtered line counts

When marked, a summary of lines hidden by display filters is shown:

Number of context lines

Defines the number of matching lines to display before and after a difference section

when Show Context  is used.

3.1.5 Next Difference

Set these options to reflect your preferences concerning how to peruse differences.

When loading new files, go to first difference

When marked, position at the first difference when a new file comparison starts.

Go to next difference in files after copying to other side
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When marked, position at the next difference item after copying the current item to the
other side.

Limit "Next Difference Files" to current folder

When marked, the Next Difference Files  command will only find files with the same
parent folder.

Wrap around to first difference

When marked, position back at the first difference in the comparison after the end is
reached.

Show message panel

When unmarked, suppress the message panel (and beep) when a difference is not found.

3.1.6 Backups

Beyond Compare can create a backup of your files before overwriting them during a copy
or move operation, or before saving an edited file.  Set these options to control how
backup files are named and where they are stored.

3.1.7 File Operations

Confirmations

By default, Beyond Compare prompts for confirmation before performing various actions. 
Unmark any of these checkboxes to suppress the confirmation dialogs.

Synchronize confirmations

Pick Prompt, Yes to All or No to All to control confirmations that might appear during a
Folder Compare session's synchronize command.

How filters affect file actions

By default, file filters and display filters are respected during file actions (such as Copy,

Move and Delete), unless Suppress Filters  is on.  To change the default behavior, mark
the Include hidden items by default checkbox.

3.1.8 Archive Types

Specify the file types to be associated with each of the supported archive formats.  Pick
a format and enter the associated file types separated by semicolons in the Mask column.
 You can leave it blank to drop support for that format.  You can add support for
additional archive formats by clicking the Add Plug-in button and following the
instructions.  For more information, see Archive Files.
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3.1.9 Toolbars, etc.

These options allow you to control which commands appear in menus and on toolbars, and
allow you to set keyboard shortcuts for commands.  Since the menus and toolbars change
depending on the type of window, you need to pick the appropriate session view.

In the  search edit, type the name or description of the command you are looking for in
order to limit the list of commands.

Pick a command in the list to edit.  The command's description will appear below the list.

Checkboxes in the Menu and Toolbar columns control where commands are shown.

To change the keyboard shortcut, focus on the Shortcut edit and press the desired
keystroke.  Click the Remove button to remove an assigned shortcut or the Default
button to revert it to the factory default setting.  If a keyboard shortcut is already
assigned elsewhere, a warning appears and you have the option of reassigning it.

Most session types have display filter commands available.  The Display filter mode can be
changed to DropDown, Favorites or Toggles.  It can also be changed by right-clicking on
the view's toolbar.

Large buttons with text labels can also be changed by right-clicking on the view's toolbar.

For documentation of specific commands, see Commands Reference.

3.1.10 Open With

You can configure external applications to appear in the Open With submenu.

Click the New button to add an "Open With" Application.

3.1.11 Tweaks

Tweaks are advanced or obscure program options that we group here to avoid cluttering
other areas.

Check for Updates

By default, Beyond Compare checks our website for new versions of the software.  You
can change the number of days between checks or unmark the Check every checkbox to
never check.

Editor Display

Most of the display settings for text views are found on the File View Colors, Fonts page
of the Options dialog.  Settings specific to the text editors are here.

Syntax highlighting is normally suppressed on difference lines so that it doesn't interfere
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with difference coloring schemes.  Mark the Show syntax highlighting on difference lines
checkbox to change this behavior. 

Use crosshatching for lines beyond the end of file helps identify the end of your text files,
particularly when comparing a longer file with a shorter one.

Right side gutter for left editor (compare only) positions the copy buttons close together
in the center of the view, and keeps the scrollbars at the outer edges.  It has no effect if

you are using the View > Over-under layout .

Enable font linking in editors allows the text editor to use additional fonts in order to
support characters from multiple languages.

Use orphan color causes file views to use a separately configurable color for items that
are only on one side of the comparison.

You can add or subtract pixels from Extra line spacing to change the density of text in the
view.

To show a vertical line at a specific column position, set Show column line at to the
desired value.  Set it to zero (0) to hide the line.  If you use a proportionally spaced font,
the column position will be determined by the width of the space character.

Dim inactive pane by darkens the non-active side of the comparison in order to help you
focus on the active side.

 To use an alternate font for the narrower input panes in a Text Merge session, mark
the Use different font for merge input panes checkbox.

File Operations

Beep after long file operations causes an audible sound when file operations such as copy
and move are completed, unless they take less than 3 seconds.

 The read-only attribute is normally preserved when copying files.  On read-only media
such as CDs or DVDs, all files will still be marked read-only when they are copied to
another location.  To avoid this, mark the Remove read-only flag when copying from a CD
or DVD checkbox.

Mark the Check for files changed on disk checkbox to check for a newer copy of a file
when returning focus to a file view.  If found, Beyond Compare will prompt "File changed
on disk, reload?"  Mark the Automatically reload unless changes will be discarded checkbox
to have Beyond Compare automatically load the newer file as long as you haven't made
changes to the displayed file.

Comparison priority can be changed to affect the order in which background work is
performed.

Buffer size for binary compare can be changed to affect speed.
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Home View

Sticky session selection can be set to remember the last session picked from a Home view
instead of the last session updated in the application.

Interface

Here is what a toolbar looks like when the Show hints for toolbar buttons, etc. and Show
keyboard shortcut in hints checkboxes are marked:

ESC key closes file views applies to all file view types, such as Text Compare, Table
Compare and Picture Compare.  It does not affect folder views.

Single vertical scrollbar can be marked to save horizontal space by hiding a redundant
vertical scrollbar.

Sticky splitter position can be marked to have the size of the panes in file views be user
defined instead of automatically determined.

Pick Compress to fit to compress the thumbnail to the available vertical space.  Pick Allow
scrolling to show a vertical scrollbar instead.

Log Panel

Operation summaries

Log a summary of each operation.

Operation details

Log details of each operation, including each file affected.

Warnings

Log warnings and errors.

FTP trace

Log messages to and from FTP site.

Debug messages

Log messages useful to Scooter Software's technical support staff.

Display up to defines how many messages the log can handle before it starts deleting the
oldest ones.

If a file is entered for Automatically save messages to file, it will be created when
necessary.
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Metrics

Max auto-saved sessions

Defines how many sessions can automatically be saved before the oldest one will be
automatically deleted.  Enter zero (0) to disable the auto-save sessions feature.

Max most recently used items

Defines how many items can automatically be remembered before the oldest one will be
automatically deleted.  For example, it affects how base folder dropdown lists.

Milliseconds before help hint appears

Defines how long to wait before showing a popup hint.

Milliseconds before help hint disappears

Defines how long a popup hint remains visible.

Milliseconds before incremental search resets

Defines how long to wait for the user to type in the next character for an incremental
search.

Name Filter Presets

Specify the preset name filter choices, available on the folder view's toolbar.  Use simple
wildcard definitions separated by semicolons for the mask.  Example:

*.htm;*.html;*.jpg

Scripts

Mark the Beep when finished checkbox for an audible cue that a script has finished.

Mark the Close when finished checkbox to exit the program when the script has finished.

Specify a Shared scripts folder to be the location for shared scripts.  If a script filename is
not found in the current folder, Beyond Compare will look for it there.

Shared Sessions File

If a Shared sessions file is specified, shared sessions will appear in your sessions tree.
You can use but not modify them.  Use Tools > Export Settings to create a shared
sessions file.

3.2 Session Settings

To edit session settings

1. Pick Session > Session Settings .
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2. Modify the desired settings on each tab.

3. The dropdown list at the bottom of the dialog controls the scope of your changes. 
Pick Use for this view only to affect the current session, or Update session defaults to
apply your changes to all new sessions of this type.

Additional choices are shown for child sessions, comparisons spawned from a folder
session.  Use for these files within parent session causes the current folder session to
remember these settings and use them whenever this particular pair of files is
compared.  Use for all files within parent session causes these settings to be used for
any new sessions of this type spawned from the current folder session.

4. Click OK.

Specific settings for session types

Folder Compare

Folder Merge 

Folder Sync

Text Compare

Text Merge 

Table Compare

Hex Compare

MP3 Compare

Picture Compare

Registry Compare 

Version Compare 

3.2.1 Folder Compare

Click the tab containing the settings you want to edit:

Specs

Comparison

Handling

Name Filters

Other Filters

Misc 
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3.2.1.1 Specs

Specify the base folders to be compared.

Mark Disable editing to protect content from being changed on disk.  New child sessions
will be affected as well.

The Description can include any text you want.

3.2.1.2 Comparison

These settings control what is considered a difference in a folder session.

Quick tests

These comparison tests can be performed simply by reading folders and are much quicker
than tests that require reading individual files.

Compare file size

Marks files as different if file sizes differ.

Compare timestamps

Compares files' date and time last modified.  Timestamps must differ by more seconds
than the second tolerance to be considered mismatches.

Ignore daylight saving difference ignores exact hour differences.  This is useful for
dealing with the way that different file systems handle Daylight Savings Time.

Ignore timezone differences ignores timestamp differences that are multiples of an
exact hour.

Compare filename case

Marks files as different if character capitalizations differ.

Compare file attributes 

Archive compares files' archive attribute.  Since merely copying a file can change its
archive attribute, you should normally disable this option.

System compares files' system attribute.

Hidden compares files' hidden attribute.

Read-only compares files' read-only attribute.

Align filenames with different extensions

Lines up files whose filenames are the same except for the extensions.

Align filenames with different Unicode normalization forms

Lines up files whose filenames are Unicode equivalent.
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Tests that require reading files

Compare contents

Enables size or content-related comparisons.

CRC comparison compares files using their CRC values.

Binary comparison compares files byte-by-byte.

Rules-based comparison compares files based on their file format associations.  Allows
you to ignore differences in line endings, whitespace, or source code comments.

Skip if quick tests indicate files are the same improves comparison speed by only
performing the slower, more thorough tests when timestamps are different.

Compare versions 

Compares version information, typically stored in application files (.exe, .dll, .ocx, etc).

Override quick test results

Marks files as matching if a content comparison determines they match even if there are
differences in timestamps or other quick tests.

3.2.1.3 Handling

Folder handling

Automatically scan subfolders in background causes folders to be read in the background
when a comparison is loaded.  This way, folders can be colored appropriately before you
open them.  Top-level orphan folders can usually be colored and filtered without scanning,
since they can only contain other orphans.  Automatically scan top-level orphan subfolders
causes these orphan folders to be scanned anyway, so that the folder's size is accurately
reported.

Expand subfolders when loading session opens all folders automatically when a comparison
is loaded.  Only expand subfolders with differences limits auto expansion to folders that are
found to have mismatches.

Archive handling (e.g. zip files)

As files always treats archive files like other files.  They will sort with files and not show a
folder icon.

As folders once opened sorts and compares archive files like other files, but with a zip
folder icon.  Once you open the zip folder, its comparison status changes to reflect its
contents, like other folders do.

As folders always treats archive files like regular folders.

File handling
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Touch local files when copying to an FTP site

Many FTP sites do not allow Beyond Compare to control file timestamps, so when a file is
copied to the FTP site, its date will not match the local copy.  This option changes the
local file timestamp to match the FTP copy.

Bypass disk cache during binary comparisons

Reads files directly from the media, avoiding the operating system's disk cache.  This
ensures an accurate comparison after copying to questionable media.

Follow symbolic links

Displays symbolic links and NTFS junction points as if they were their target.  This
includes whether they will be shown as files or folders, their size, their last modified time,
and their attributes.

Maintain DOS 8.3 aliases 

Tries to keep the same short (DOS 8.3) filenames when copying files.

Copy NTFS file permissions 

Copies security descriptors of files on NTFS file systems under Windows 2000 or newer. 
This feature does not preserve permissions of files edited from Text Compare sessions.

Copy creation dates 

Preserves original creation date of a local file when making a copy.

Automatic refresh

Set this option to periodically refresh the folder comparison.

3.2.1.4 Name Filters

You can include or exclude folders and files based on their names by using one or more file
masks.

To set a name filter

Add a file mask to the appropriate list.  Each file mask must be on its own line.

Include Files  Files to include in this session.

Exclude Files  Files to exclude from this session.

Include Folders  Folders to include in this session.

Exclude Folders  Folders to exclude from this session.

For examples, see File Masks.

To clear all name filters
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Click the Clear button to clear all the filter settings on this tab.

To make the current name filter a preset

Click the Add To Presets button, optionally enter a Name, optionally edit the Mask, and
click OK.

3.2.1.5 Other Filters

You can exclude files from a folder session based on criteria other than their names.  Click
the New button to add an Other Filter Item.

Note  Whenever a other filter items are defined, a comment bar appears near the

bottom of the folder view.  You can click the Other Filters  button on it to edit these
filters.

Note  If a file filter determines that a file on one side of the comparison should be
hidden but the corresponding file on the other side should be visible, both are made visible
and the one that should be hidden will be colored teal (blue-green).

The Exclude protected operating system files checkbox is marked by default.

3.2.1.6 Misc

To force a different alignment

By default, a folder session aligns files and subfolders by name, left and right.  Click the 
New button to add an Alignment Override.

Note  The easiest way to manually align two items in a folder session is to right-click
the first item, pick Align With, then click the second item.

To override file format associations

The Enabled file formats list lets you override which file formats will be used by this folder
session.  A file format is listed in bold if its enabled state in this session is different from
its global enabled state.  You can create a custom file format that is enabled for use in
this session but disabled in the global list.

3.2.2 Folder Merge

Click the tab containing the settings you want to edit:

Specs
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Comparison

Handling

Name Filters

Other Filters

Misc

3.2.2.1 Specs

Specify the base folders to be merged.

Merge to defines the destination folder of the merge results.

The Description can include any text you want.

3.2.2.2 Comparison

These settings control what is considered a difference in a folder session.

Quick tests

These comparison tests can be performed simply by reading folders and are much quicker
than tests that require reading individual files.

Compare file size

Marks files as different if file sizes differ.

Compare timestamps

Compares files' date and time last modified.  Timestamps must differ by more seconds
than the second tolerance to be considered mismatches.

Ignore daylight saving difference ignores exact hour differences.  This is useful for
dealing with the way that different file systems handle Daylight Savings Time.

Ignore timezone differences ignores timestamp differences that are multiples of an
exact hour.

Compare filename case

Marks files as different if character capitalizations differ.

Compare file attributes 

Archive compares files' archive attribute.  Since merely copying a file can change its
archive attribute, you should normally disable this option.

System compares files' system attribute.
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Hidden compares files' hidden attribute.

Read-only compares files' read-only attribute.

Tests that require reading files

Compare contents

Enables size or content-related comparisons.

CRC comparison compares files using their CRC values.

Binary comparison compares files byte-by-byte.

Rules-based comparison compares files based on their file format associations.  Allows
you to ignore differences in line endings, whitespace, or source code comments.

Skip if quick tests indicate files are the same improves comparison speed by only
performing the slower, more thorough tests when timestamps are different.

Compare versions 

Compares version information, typically stored in application files (.exe, .dll, .ocx, etc).

Override quick test results

Marks files as matching if a content comparison determines they match even if there are
differences in timestamps or other quick tests.

3.2.2.3 Handling

Folder handling

Automatically scan subfolders in background causes folders to be read in the background
when a comparison is loaded.  This way, folders can be colored appropriately before you
open them.  Top-level orphan folders can usually be colored and filtered without scanning,
since they can only contain other orphans.  Automatically scan top-level orphan subfolders
causes these orphan folders to be scanned anyway, so that the folder's size is accurately
reported.

Expand subfolders when loading session opens all folders automatically when a comparison
is loaded.  Only expand subfolders with differences limits auto expansion to folders that are
found to have mismatches.

Archive handling (e.g. zip files)

As files always treats archive files like other files.  They will sort with files and not show a
folder icon.

As folders once opened sorts and compares archive files like other files, but with a zip
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folder icon.  Once you open the zip folder, its comparison status changes to reflect its
contents, like other folders do.

As folders always treats archive files like regular folders.

File handling

Touch local files when copying to an FTP site

Many FTP sites do not allow Beyond Compare to control file timestamps, so when a file is
copied to the FTP site, its date will not match the local copy.  This option changes the
local file timestamp to match the FTP copy.

Bypass disk cache during binary comparisons

Reads files directly from the media, avoiding the operating system's disk cache.  This
ensures an accurate comparison after copying to questionable media.

Follow symbolic links

Displays symbolic links and NTFS junction points as if they were their target.  This
includes whether they will be shown as files or folders, their size, their last modified time,
and their attributes.

Maintain DOS 8.3 aliases 

Tries to keep the same short (DOS 8.3) filenames when copying files.

Copy NTFS file permissions 

Copies security descriptors of files on NTFS file systems under Windows 2000 or newer. 
This feature does not preserve permissions of files edited from Text Merge sessions.

Copy creation dates 

Preserves original creation date of a local file when making a copy.

Automatic refresh

Set this option to periodically refresh the folder comparison.

3.2.2.4 Name Filters

You can include or exclude folders and files based on their names by using one or more file
masks.

To set a name filter

Add a file mask to the appropriate list.  Each file mask must be on its own line.

Include Files  Files to include in this session.

Exclude Files  Files to exclude from this session.
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Include Folders  Folders to include in this session.

Exclude Folders  Folders to exclude from this session.

For examples, see File Masks.

To clear all name filters

Click the Clear button to clear all the filter settings on this tab.

To make the current name filter a preset

Click the Add To Presets button, optionally enter a Name, optionally edit the Mask, and
click OK.

3.2.2.5 Other Filters

You can exclude files from a folder session based on criteria other than their names.  Click
the New button to add an Other Filter Item.

Note  Whenever a other filter items are defined, a comment bar appears near the

bottom of the folder view.  You can click the Other Filters  button on it to edit these
filters.

Note  If a file filter determines that a file on one side of the comparison should be
hidden but the corresponding file on the other side should be visible, both are made visible
and the one that should be hidden will be colored teal (blue-green).

The Exclude protected operating system files checkbox is marked by default.

3.2.2.6 Misc

To override file format associations

The Enabled file formats list lets you override which file formats will be used by this folder
session.  A file format is listed in bold if its enabled state in this session is different from
its global enabled state.  You can create a custom file format that is enabled for use in
this session but disabled in the global list.

3.2.3 Folder Sync

Click the tab containing the settings you want to edit:

Specs
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Sync

Comparison

Handling

Name Filters

Other Filters

Misc 

3.2.3.1 Specs

Specify the base folders to be synced.

Mark Disable editing to protect content from being changed on disk.  New child sessions
will be affected as well.

The Description can include any text you want.

3.2.3.2 Sync

Operations

Presets

You can use one of the predefined sync methods described in the overview or create a
custom one.

3.2.3.3 Comparison

These settings control what is considered a difference in a folder session.

Quick tests

These comparison tests can be performed simply by reading folders and are much quicker
than tests that require reading individual files.

Compare file size

Marks files as different if file sizes differ.

Compare timestamps

Compares files' date and time last modified.  Timestamps must differ by more seconds
than the second tolerance to be considered mismatches.

Ignore daylight saving difference ignores exact hour differences.  This is useful for
dealing with the way that different file systems handle Daylight Savings Time.

Ignore timezone differences ignores timestamp differences that are multiples of an
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exact hour.

Compare filename case

Marks files as different if character capitalizations differ.

Compare file attributes 

Archive compares files' archive attribute.  Since merely copying a file can change its
archive attribute, you should normally disable this option.

System compares files' system attribute.

Hidden compares files' hidden attribute.

Read-only compares files' read-only attribute.

Align filenames with different extensions

Lines up files whose filenames are the same except for the extensions.

Align filenames with different Unicode normalization forms

Lines up files whose filenames are Unicode equivalent.

Tests that require reading files

Compare contents

Enables size or content-related comparisons.

CRC comparison compares files using their CRC values.

Binary comparison compares files byte-by-byte.

Rules-based comparison compares files based on their file format associations.  Allows
you to ignore differences in line endings, whitespace, or source code comments.

Skip if quick tests indicate files are the same improves comparison speed by only
performing the slower, more thorough tests when timestamps are different.

Compare versions 

Compares version information, typically stored in application files (.exe, .dll, .ocx, etc).

Override quick test results

Marks files as matching if a content comparison determines they match even if there are
differences in timestamps or other quick tests.

3.2.3.4 Handling

Folder handling

Sync empty folders will affect folders without content or whose entire contents have been
filtered out.
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Expand subfolders when loading session opens all folders automatically when a comparison
is loaded.

Sync within archives treats archive files like regular folders.

File handling

Delete to recycle bin if possible

Moves files and folders stored on a local drive to the recycle bin instead of permanently
deleting them.  This option is ignored for deletions from network drives, remote services
and within archive files.

Touch local files when copying to an FTP site

Many FTP sites do not allow Beyond Compare to control file timestamps, so when a file is
copied to the FTP site, its date will not match the local copy.  This option changes the
local file timestamp to match the FTP copy.

Bypass disk cache during binary comparisons

Reads files directly from the media, avoiding the operating system's disk cache.  This
ensures an accurate comparison after copying to questionable media.

Follow symbolic links

Displays symbolic links and NTFS junction points as if they were their target.  This
includes whether they will be shown as files or folders, their size, their last modified time,
and their attributes.

Maintain DOS 8.3 aliases 

Tries to keep the same short (DOS 8.3) filenames when copying files.

Copy NTFS file permissions 

Copies security descriptors of files on NTFS file systems under Windows 2000 or newer. 
This feature does not preserve permissions of files edited from Text Compare sessions.

Copy creation dates 

Preserves original creation date of a local file when making a copy.

Automatic refresh

Set this option to periodically refresh the folder comparison.

3.2.3.5 Name Filters

You can include or exclude folders and files based on their names by using one or more file
masks.

To set a name filter

Add a file mask to the appropriate list.  Each file mask must be on its own line.
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Include Files  Files to include in this session.

Exclude Files  Files to exclude from this session.

Include Folders  Folders to include in this session.

Exclude Folders  Folders to exclude from this session.

For examples, see File Masks.

To clear all name filters

Click the Clear button to clear all the filter settings on this tab.

To make the current name filter a preset

Click the Add To Presets button, optionally enter a Name, optionally edit the Mask, and
click OK.

3.2.3.6 Other Filters

You can exclude files from a folder session based on criteria other than their names.  Click
the New button to add an Other Filter Item.

Note  Whenever a other filter items are defined, a comment bar appears near the

bottom of the folder view.  You can click the Other Filters  button on it to edit these
filters.

Note  If a file filter determines that a file on one side of the comparison should be
hidden but the corresponding file on the other side should be visible, both are made visible
and the one that should be hidden will be colored teal (blue-green).

The Exclude protected operating system files checkbox is marked by default.

3.2.3.7 Misc

To force a different alignment

By default, a folder session aligns files and subfolders by name, left and right.  Click the 
New button to add an Alignment Override.

Note  The easiest way to manually align two items in a folder session is to right-click
the first item, pick Align With, then click the second item.

To override file format associations
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The Enabled file formats list lets you override which file formats will be used by this folder
session.  A file format is listed in bold if its enabled state in this session is different from
its global enabled state.  You can create a custom file format that is enabled for use in
this session but disabled in the global list.

3.2.4 Text Compare

Click the tab containing the settings you want to edit:

Specs

Format

Importance

Alignment

Replacements 

3.2.4.1 Specs

Specify the files to be compared.

Mark Disable editing to protect content from being changed on disk.

The Description can include any text you want.

3.2.4.2 Format

Specify the file format to be used when reading the left and/or right files.  The default
selection is Detected, which means the file format will be selected based on file masks.

Encoding overrides allow this session to override the character encoding to be used for
each file, normally controlled by the selected file format.  The default is None, which
means the file format's encoding choice will be used.

3.2.4.3 Importance

These settings control which differences you consider important in the current session. 
Important differences will be colored red in the comparison.  Unimportant differences will

be blue (or not highlighted at all if View > Ignore Unimportant Differences  is marked).

Unimportance

Text that matches items defined in this list are considered unimportant.

Grammar elements
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Mark the boxes in the list of items that are important to the comparison.

Leading whitespace controls whether whitespace at the start of the line is important.

Embedded whitespace controls whether whitespace in the middle of the line is important.

Trailing whitespace controls whether whitespace at the end of the line is important.

Everything else refers to non-whitespace text not already defined as a grammar element.

Mark the Character case checkbox if the "everything else" text is case-sensitive.  (The
case sensitivity of grammar elements is controlled by the file format's grammar.)

Click the Edit Grammar button to examine or change the grammar definitions in the
selected file format.

Miscellaneous

To consider an extra blank line (or an inserted line with only unimportant text) an
important difference, mark the Orphan lines are always important checkbox.

Beyond Compare normally ignores differences in line ending style, such as CR+LF in
Windows text files vs. LF only in Unix files.  To find differences in line endings on a line-
by-line basis, mark the Compare line endings (PC/Mac/Unix) checkbox.  (To examine the

line endings, mark View > Visible Whitespace .)

3.2.4.4 Alignment

The Alignment tab settings control the algorithm for aligning lines in the comparison.

Mark the Never align differences checkbox to show lines with important differences as
blocks of added and deleted text rather than changed text.

Pick Unaligned to compare files without aligning lines based on their content.

Pick Standard alignment to align the files by comparing successively smaller sections of
each file.  Parts of the alignment can be shown before the entire comparison is finished.

Pick Myers O(ND) aligment to align the files using a common LCS (Longest Common
Subsequence) algorithm.  This can give better matches in certain cases, such as large
inserts or when the files contain a lot of repeating text.  Since files are compared all at
once, larger file scans take much longer than the standard method, and the files are not
displayed until the comparison is complete.  It does not support similarity comparisons, so
mismatches will be grouped in blocks.

Pick Patience Diff alignment to align the files using Bram Cohen's algorithm.

The Skew tolerance specifies the maximum number of lines that the algorithm will check
when looking for a match to a particular line.  Increasing it can improve the alignment,
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especially if there are large gaps.  Of course, the comparison may also require more time.

Mark the Use closeness matching checkbox to attempt to align the remaining mismatched
lines based on their similarity.

Note  Regardless of these settings, the alignment algorithm will sometimes produce
undesirable results.  To manually align two lines, right-click one line and pick Align With
and then click the second line.

3.2.4.5 Replacements

Replacements identify repetitive changes that should be considered unimportant.  You can
specify the text to match on one side and the text that replaces it on the other side. 
Click the New button to add a Replacement Item.

3.2.5 Text Merge

Click the tab containing the settings you want to edit:

Specs

Format

Importance

Alignment

3.2.5.1 Specs

Specify the files to be merged.

Merge to defines the destination file of the merge results.

The Description can include any text you want.

3.2.5.2 Format

Specify the file format to be used when reading the input files.  The default selection is
Detected, which means the file format will be selected based on file masks.

Encoding overrides allow this session to override the character encoding to be used for
each file, normally controlled by the selected file format.  The default is None, which
means the file format's encoding choice will be used.
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3.2.5.3 Importance

These settings control which differences you consider important in the current session. 
Important differences will be colored red in the comparison.  Unimportant differences will

be blue (or not highlighted at all if View > Ignore Unimportant Differences  is marked).

Unimportance

Text that matches items defined in this list are considered unimportant.

Grammar elements

Mark the boxes in the list of items that are important to the comparison.

Leading whitespace controls whether whitespace at the start of the line is important.

Embedded whitespace controls whether whitespace in the middle of the line is important.

Trailing whitespace controls whether whitespace at the end of the line is important.

Everything else refers to non-whitespace text not already defined as a grammar element.

Mark the Character case checkbox if the "everything else" text is case-sensitive.  (The
case sensitivity of grammar elements is controlled by the file format's grammar.)

Click the Edit Grammar button to examine or change the grammar definitions in the
selected file format.

Miscellaneous

To consider an extra blank line (or an inserted line with only unimportant text) an
important difference, mark the Orphan lines are always important checkbox.

Beyond Compare normally ignores differences in line ending style, such as CR+LF in
Windows text files vs. LF only in Unix files.  To find differences in line endings on a line-
by-line basis, mark the Compare line endings (PC/Mac/Unix) checkbox.  (To examine the

line endings, mark View > Visible Whitespace .)

3.2.5.4 Alignment

The Alignment tab settings control the algorithm for aligning lines in the comparison.

Mark the Never align differences checkbox to show lines with important differences as
blocks of added and deleted text rather than changed text.
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Pick Unaligned to compare files without aligning lines based on their content.

Pick Standard alignment to align the files by comparing successively smaller sections of
each file.  Parts of the alignment can be shown before the entire comparison is finished.

Pick Myers O(ND) aligment to align the files using a common LCS (Longest Common
Subsequence) algorithm.  This can give better matches in certain cases, such as large
inserts or when the files contain a lot of repeating text.  Since files are compared all at
once, larger file scans take much longer than the standard method, and the files are not
displayed until the comparison is complete.  It does not support similarity comparisons, so
mismatches will be grouped in blocks.

Pick Patience Diff alignment to align the files using Bram Cohen's algorithm.

The Skew tolerance specifies the maximum number of lines that the algorithm will check
when looking for a match to a particular line.  Increasing it can improve the alignment,
especially if there are large gaps.  Of course, the comparison may also require more time.

Mark the Use closeness matching checkbox to attempt to align the remaining mismatched
lines based on their similarity.

Note  Regardless of these settings, the alignment algorithm will sometimes produce
undesirable results.  To manually align two lines, right-click one line and pick Align With
and then click the second line.

A merge conflict is

These settings define the scope of conflicts.  A conflict occurs when the same section of
text has changes on both left and right sides.

Pick Only different change lines to limit conflicts to where each line has changes on both
sides.  Pick Left change and right change separated by lines to specify the maximum
number of lines between changes that should be considered conflicts.  This way, left and
right changes that are close to each other can be flagged for review along with direct
conflicts.

3.2.6 Table Compare

Click the tab containing the settings you want to edit:

Specs

Format

Columns

3.2.6.1 Specs

Specify the files to be compared.
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Mark Disable editing to protect content from being changed on disk.

The Description can include any text you want.

3.2.6.2 Format

Specify the file format to be used when reading the left and/or right files.  The default
selection is Detected, which means the file format will be selected based on file masks.

Encoding overrides allow this session to override the character encoding to be used for
each file, normally controlled by the selected file format.  The default is None, which
means the file format's encoding choice will be used.

3.2.6.3 Columns

Each line in the display represents a comparison column, and shows:

Comparison  if key, column number, column name
Left file column number, sample data if available
Right file column number, sample data if available
Handling summary of column comparison

To control the alignment of rows

Define as many columns as keys as necessary to uniquely identify each row.  By default,
the first column is the only one defined as a key.  To define a column as a key, position
on the appropriate line, click the Edit button, mark the Key checkbox, and click OK.  If
multiple keys are defined, precedence follows the order in the comparison.  If no keys are
defined, the alignment will use all of the columns to uniquely identify each row.

By default, the files are sorted by their keys before the rows are aligned.  Mark the 
Unsorted alignment checkbox to force the alignment to preserve the order of rows as they
exist in the files.  Note that this may cause rows with the same key column data not to
be aligned.

To control the alignment of columns

By default, the comparison assumes the columns of the files are in the same order.  To
change the comparison order of a column in the left file, position on the appropriate line

under Left file, and click the Move Up  or Move Down  button as necessary.  If you
position under Comparison instead, those buttons will change the position of the
comparison column itself.  To prevent a column in the left file from being compared at all,
position on the appropriate line under Left file, and click the Remove button.  If you
position under Comparison instead, this button will prevent its file columns from being
compared and delete this comparison column definition.  To restore a removed column
from the left file, position under Left file, click the Insert button, mark items in the Insert
Columns dialog and click OK.  Click the Tidy button to remove any blank lines from the list.

To control the names of columns

By default, column names are automatically determined from the left or right file.  To give
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a column a specific name, position on the appropriate line, click the Edit button, change
the Name, and click OK.  To revert all columns to automatic naming, pick Reset Names
from the list's right-click menu.  If left file data is available, you can pick Fill Names Using
Left File from the list's right-click menu to force the names to be those found in the left
file.  Fill Names Using Comparison will force the names to be those that would be
automatically determined.

To control how column data is compared

Position on the appropriate line and click the Edit button to open the Column Handling
dialog.  To change the default Handling settings, click the Edit Default button.

3.2.7 Hex Compare

Click the tab containing the settings you want to edit:

Specs

Format

Comparison

3.2.7.1 Specs

Specify the files to be compared.

Mark Disable editing to protect content from being changed on disk.

The Description can include any text you want.

3.2.7.2 Format

Specify the file format to be used when reading the left and/or right files.  The default
selection is Detected, which means the file format will be selected based on file masks.

3.2.7.3 Comparison

These settings control how the files are compared.

Complete will align the bytes using a complex algorithm.  Fast will perform a simpler but
quicker alignment that is ideal for really large files.  None will just align the bytes one by
one.

Files up to this size are loaded without file locks allows smaller files to be edited in other
programs.

3.2.8 MP3 Compare

Click the tab containing the settings you want to edit:
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Specs

Importance

3.2.8.1 Specs

Specify the files to be compared.

The Description can include any text you want.

3.2.8.2 Importance

These settings control which differences you consider important.

3.2.9 Picture Compare

Click the tab containing the settings you want to edit:

Specs

Format

Replacements

3.2.9.1 Specs

Specify the files to be compared.

The Description can include any text you want.

3.2.9.2 Format

Specify the file format to be used when reading the left and/or right files.  The default
selection is Detected, which means the file format will be selected based on file masks.

3.2.9.3 Replacements

Replacements identify changes that should be considered unimportant.  You can specify
the color to match on one side and the color that replaces it on the other side.

3.2.10 Registry Compare

Click the tab containing the settings you want to edit:

Specs



Settings Reference 93

Copyright © 2014 Scooter Software, Inc.

3.2.10.1 Specs

Specify the files to be compared.

The Description can include any text you want.

3.2.11 Version Compare

Click the tab containing the settings you want to edit:

Specs

Importance

3.2.11.1 Specs

Specify the files to be compared.

The Description can include any text you want.

3.2.11.2 Importance

These settings control which differences you consider important.

3.3 File Formats

Pick Tools > File Formats  to see and manage the entire list of file formats.

The order of the list is important.  When Beyond Compare looks for a file format to use on
a file, it scans this list from top to bottom, stopping on the first enabled item whose mask
matches the filename.  To change the order of the list, highlight an item and click the 

Move Up  or Move Down  button.  To enable or disable an item, mark or unmark its
checkbox.

An item is colored red if any filename it could match is already matched by an item higher
in the list.  A disabled item is colored gray.  An item with an empty mask cannot match
any filename.  To use any of these file formats, you must manually pick them in file
sessions.

Note  A specific session can independently enable or disable file formats.  (See Folder
Compare Miscellaneous Settings.)  This way you can have a special file format that is
used only by one session.

3.3.1 Text Formats

Text formats are file formats used by the Text Compare and Text Merge session types.
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Click the tab containing the settings you want to edit:

General

Conversion

Grammar

Misc

3.3.1.1 General

The Mask is a set of file types to be associated with this file format.

The Description can include any text you want.  The built-in file format descriptions
include any limitations or requirements for using them.

3.3.1.2 Conversion

The Conversion tab defines how files should be loaded and saved.

Text Compare sessions can compare plain text files, such as programming source files,
directly.  To compare files with structured or proprietary formats, it may be necessary to
first extract the plain text content from the file.  For example, Microsoft Word documents
are binary files, but Beyond Compare can extract and compare their textual content. 
Beyond Compare can highlight differences in words and sentences but cannot identify
differences in formatting or embedded images.

Pick a Conversion method.  When using External program methods, you will need to
specify a conversion program with the appropriate path and command line switches in the 
Loading edit.  In order to support filenames with extended characters, make sure to pick
the appropriate filename encoding (Unicode or ANSI).  The following variables will be
replaced with the indicated information:

  %s source file

  %t target file

  %o original file

Conversion programs are only considered successful if they return a zero exit code and
generate a non-empty file.

If you have a conversion program you want to use before saving, you can unmark the 
Disable editing checkbox and in the Saving edit specify that conversion program's path
and command line switches.  The above variables apply.

The Encoding of most text files can be detected automatically, but you can specify a
specific code page to use.
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Mark the Ctrl+Z indicates end of file checkbox for if your file type uses the hex value 1A as
an EOF marker.

The characters per line limit setting will break long lines at the indicated length.  Those
artificial line breaks are removed when saving an edited file.

Trim trailing whitespace and Convert leading spaces to tabs are edits that can be
performed before saving files.

3.3.1.3 Grammar

The Grammar tab defines the syntax of a file.  Grammar elements such as comments and
keywords are defined here.  Each grammar element can be described by one or more
grammar items which appear in the list.  The order of the list is significant.  Items higher
on the list take precedence over lower items.  Click the New button to add a Grammar
Item.

Line weights are used to improve alignment in a comparison.  The alignment algorithm will
try to line up matching lines with higher line weights.

3.3.1.4 Misc

Insert spaces instead of tabs

When unmarked, pressing the Tab key inserts a tab character into the file.  When marked,
an appropriate number of spaces is inserted instead.

The Tab stop setting determines the interval between tab stops.  Pressing the Tab key
advances the cursor to the next tab stop.

Mark the Lines are independent checkbox when each line is an independent record and it
is not useful to manipulate consecutive difference lines as a Sec t ion.

Mark the Column-based data checkbox when the position of each character on a line is
important and lines should be compared column-by-column.

3.3.2 Table Format

Table formats are file formats used by the Table Compare session type.

Click the tab containing the settings you want to edit:

General

Conversion

Type

3.3.2.1 General

The Mask is a set of file types to be associated with this file format.
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The Description can include any text you want.  The built-in file format descriptions
include any limitations or requirements for using them.

3.3.2.2 Conversion

The Conversion tab defines how files should be loaded and saved.

Table Compare sessions can compare plain text files, such as comma separated value
files, directly.  To compare files with structured or proprietary formats, it may be
necessary to first extract the plain text content from the file.  For example, Microsoft
Excel spreadsheets are binary files, but Beyond Compare can extract and compare their
textual content.  Beyond Compare can highlight differences in words and sentences but
cannot identify differences in formatting or embedded images.

Pick a Conversion method.  When using External program methods, you will need to
specify a conversion program with the appropriate path and command line switches in the 
Loading edit.  In order to support filenames with extended characters, make sure to pick
the appropriate filename encoding (Unicode or ANSI).  The following variables will be
replaced with the indicated information:

  %s source file

  %t target file

  %o original file

Conversion programs are only considered successful if they return a zero exit code and
generate a non-empty file.

If you have a conversion program you want to use before saving, you can unmark the 
Disable editing checkbox and in the Saving edit specify that conversion program's path
and command line switches.  The above variables apply.

The Encoding of most text files can be detected automatically, but you can specify a
specific code page to use.

Mark the Ctrl+Z indicates end of file checkbox for if your file type uses the hex value 1A as
an EOF marker.

3.3.2.3 Type

The Type tab defines the syntax of the data file.

Delimited text files

Pick Delimited if the fields are separated by a delimiter character such as a tab or comma.

Mark the Detect checkbox to have the program automatically determine the delimiter.
Otherwise, pick the Delimiters that separate the fields and pick the Text qualifier that
optionally surrounds fields (necessary for data that contains the delimiter characters).
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Mark the Treat consecutive delimiters as one checkbox if a delimiter can consist of multiple
delimiter characters.  For example, if the data file contains columns separated by
whitespace, you should enable this option and pick Space as the delimiter character.

Unmark the Treat surrounding whitespace as part of delimiter checkbox if any whitespace
next to a delimiter should be considered part of the data field.

Fixed position text files

Pick Fixed for files where fields are defined by position on the line.

Enter the Column widths in a list separated by semicolons.

All types

Pick the First line contains option to control whether the first line in the file is treated as
cell data or as column names.  Normally, the Table Compare tries to detect this but you
can override it here.

3.3.3 Hex Format

Hex formats are file formats used by the Hex Compare session type.

Click the tab containing the settings you want to edit:

General

Conversion

3.3.3.1 General

The Mask is a set of file types to be associated with this file format.

The Description can include any text you want.  The built-in file format descriptions
include any limitations or requirements for using them.

3.3.3.2 Conversion

The Conversion tab defines how files should be loaded and saved.

Pick a Conversion method.  When using External program methods, you will need to
specify a conversion program with the appropriate path and command line switches in the 
Loading edit.  In order to support filenames with extended characters, make sure to pick
the appropriate filename encoding (Unicode or ANSI).  The following variables will be
replaced with the indicated information:

  %s source file

  %t target file
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  %o original file

Conversion programs are only considered successful if they return a zero exit code and
generate a non-empty file.

If you have a conversion program you want to use before saving, you can unmark the 
Disable editing checkbox and in the Saving edit specify that conversion program's path
and command line switches.  The above variables apply.

3.3.4 Picture Format

Picture formats are file formats used by the Picture Compare session type.

Click the tab containing the settings you want to edit:

General

Conversion

3.3.4.1 General

The Mask is a set of file types to be associated with this file format.

The Description can include any text you want.  The built-in file format descriptions
include any limitations or requirements for using them.

3.3.4.2 Conversion

The Conversion tab defines how files should be loaded.

Pick a Conversion method.  When using External program methods, you will need to
specify a conversion program with the appropriate path and command line switches in the 
Loading edit.  In order to support filenames with extended characters, make sure to pick
the appropriate filename encoding (Unicode or ANSI).  The following variables will be
replaced with the indicated information:

  %s source file

  %t target file

  %o original file

Conversion programs are only considered successful if they return a zero exit code and
generate a non-empty file.

3.3.5 External Format

To compare files using another application, define an external format.
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The Mask should be the set of file types it handles.

The Quick compare command line will be used whenever rules-based comparison results are
needed.  The return code should be 0 for a match and 1 for a mismatch.

The View command line will be used whenever a view is needed.

The Description can include any text you want.

3.4 Profiles

Pick Tools > Profiles to see and manage the entire list of profiles.

In addition to the named profiles, there is the <default> FTP profile whose settings can be
used by named FTP profiles.

3.4.1 FTP Profiles

Click the tab for the settings you wish to edit:

Global

Login

Server

Connection

Proxy

Listing

Transfer

3.4.1.1 Global

Anonymous logins

Email address

When connecting to anonymous FTP sites, it is customary to include your email address
as the password.  Specify the email address (real or fictitious) to use for anonymous
logins.

SSH public key authentication 

These settings are used to authenticate against an SSH server using a public/private key
pair.  Keys stored using OpenSSH's ssh-agent and PuTTY's pageant SSH agents will be
used automatically.

SSH private key file

Specify the path to the SSH private key.  OpenSSH, SSH.COM, PuTTY, and PGP key
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formats are supported.

Create Keys

Click to create a new SSH key pair.

SSL authentication 

These settings are used to authenticate against an SSL FTP server using an SSL client
certificate.

SSL client certificate

Specify the path to the SSL client certificate file.

Create Certificate

Click to create a new self-signed SSL client certificate.

ASCII types

To change which files get transferred as ASCII, add and remove extensions from this list.

Note  If you need help with the settings on this page, consult your system
administrator.

3.4.1.2 Login

Protocol

Specify FTP or one of the secure FTP options: SSL or SSH.

Port

Override if you don't want to use the standard value for the specified protocol.

Host, Username, Password

Specify login parameters for your account.

Save password

Mark to weakly encrypt your password and store it along with other FTP profile settings.

The Description can include any text you want.

Note  If you need help with the settings on this page, consult your system
administrator.

3.4.1.3 Server

Filenames are case sensitive

Mark to require filename character case to be the same in order to line up in the
comparison.

Encoding
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Specify the character encoding the server uses for directory listings and commands.

Time zone

Specify the time zone of the server.  Timestamps will be converted to local time
automatically.

Custom login commands

Specify any additional commands to send to the server upon connection.  Not supported
by SFTP (SSH) connections.

Note  If you need help with the settings on this page, consult your system
administrator.

3.4.1.4 Connection

These settings control how the connection is made to the remote server.

Simultaneous connections

Specify the maximum number of concurrent connections (from 1 to 10) that Beyond
Compare can create to this server.

Read timeout (seconds)

Specify the timeout for downloading files.  The operation will fail if no bytes are received
within this time.

Passive transfers (PASV)

Some firewall configurations require this setting, which modifies the methods used to
transfer data back and forth between your computer and the FTP server.  Not all FTP
servers support PASV mode.  If the connection hangs, try turning this on.

Limit ports used for active transfers (PORT)

Specify a range of ports that the FTP server will connect to when uploading/downloading
files using active transfers (The Passive transfers checkbox is unmarked).  Use this if you
need to configure your firewall to allow incoming connections.

Use HOST before login

Controls whether the HOST command should be sent before sending the username and
password to log in.  This is required to connect to some virtual FTP hosts.  Disable it if
the connection is being dropped before the username is sent.

Clear control channel (SSL only)

After sending encrypted login details, control channel communication is unencrypted.  Try
turning this on if the initial SSL connection succeeds but file transfers or directory listings
hang.

Clear data channel (SSL only)

Send file content and directory listings unencrypted.  This can provide a speedup when
transferring lots of files after sending encrypted login details.

Note  If you need help with the settings on this page, consult your system
administrator.
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3.4.1.5 Proxy

Use proxy

Mark if connections should use FTP Proxy protocol.  If you are not on a Local Area
Network (LAN) or Wide Area Network (WAN), leave this option unmarked.

Proxy type

Specify the type of firewall.

Host, Port, Username, Password

Specify login parameters for your firewall / proxy.

Note  If you need help with the settings on this page, consult your system
administrator.

3.4.1.6 Listings

Beyond Compare parses the plain text directory listings sent from the FTP server in order
to determine the remote folder structure.  Unfortunately, there is no one standard for
these listings.

These settings help Beyond Compare understand the conventions and capabilities of the
FTP server.

Link resolution

FTP sites can connect files together using symbolic "links" which point from one area of
the site to another.  These links do not specify whether they point to files or folders, so
the following methods of resolving are available:

Fast

Mark to treat any link which has an extension (e.g. '.txt') as a file and all others as
folders.  This requires no extra transfers.

Simple

Mark to attempt to change folders into every link as it encounters it.  If it succeeds the
link is considered a folder, otherwise it is considered a file.

LIST options

Use MLSD command

Mark to request high-resolution timestamps from the server.  If successful, the following
settings are ignored.  Soft links will be listed as plain files and folders, and listings won't
be recursive.

Show hidden [-a]

Mark to make the FTP server include files that it wouldn't normally include, such as Unix
filenames that begin with a period.

Force long format [-l]
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Mark to attempt to change the output of the FTP server list command.  Try this option if
Beyond Compare doesn't list any files when it loads.

Complete timestamps [-T]

Mark to expand the timestamps that the FTP server returns to include a full date and
time, including seconds.

Resolve links [-L]

Mark to make the FTP server list soft links as plain files and folders with the timestamp
and size of the link's target.

Recursive [-R]

Mark to make directory listings recursive, including contents of the subfolders in response
to a single FTP list command.  Recursive listings may be slower initially, but save time
overall if subfolders will need to be examined eventually.

Miscellaneous settings

Hide VMS versions

Mark to only include the most recent version of a file and align it with a local file. 
Otherwise, all versions of the file are included with their version numbers.

Fetch incomplete timestamps

Mark to try to fetch the file's last modified time in cases where the directory listing only
reports the date.  This will provide more accurate timestamp comparisons at the cost of
some performance.  Not supported on all FTP servers.

Note  If you need help with the settings on this page, consult your system
administrator.

3.4.1.7 Transfer

These settings control how files are transferred to and from the FTP server.

Transfer type

FTP sites can transfer data in two ways:  ASCII and Binary.  ASCII is used to transfer
text files which don't have any special characters.  The FTP server will automatically
make any adjustments to line endings needed in ASCII mode.  ASCII mode also handles
transfers from mainframes by converting from EBCDIC to ANSI and adding line terminators
to the end of records.  Binary is used to transfer all other files, including pictures, music,
Word documents, etc.  In Binary mode, no changes are made to the file during the
transfer.

Setting the transfer type to either ASCII or Binary will force all files to transfer that way.
If the transfer type is Auto, Beyond Compare will automatically switch back and forth
based on the file's extension.

Copy timestamps on upload

Mark to force the remote timestamp to match the source timestamp.  Only unmark if it
causes problems with the server.
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Copy Unix permissions on upload

Mark to force the remote Unix permissions to match the source Unix permissions.  Only
unmark if it causes problems with the server.

Compress transfers (MODE Z)

Mark to use compression to speed up transfers when supported by the server.  This may
actually slow down transfers on fast connections.

Limit download (Kbps), Limit upload (Kbps)

Specify how much bandwidth Beyond Compare can consume for each connection.

Force faster uploads to older OpenSSH servers

Mark to use larger transfer buffers and pipelining on OpenSSH servers prior to OpenSSH
3.9.  This can substantially increase transfer speed, but is not compatible with all servers,
and failures may not be obvious.  Use a binary content comparison to verify the first
transfers you do after enabling this.

Note  If you need help with the settings on this page, consult your system
administrator.

3.4.2 Amazon S3 Profiles

Access key ID, Secret access key

Specify parameters for your account.

The Description can include any text you want.

3.4.3 Dropbox Profiles

The Description can include any text you want.

3.4.4 Subversion Profiles

URL of repository, Revision

Specify parameters for your account.

The Description can include any text you want.

3.4.5 WebDAV Profiles

URL, Username, Password, Recursive listings

Specify parameters for your account.

The Description can include any text you want.

3.5 Source Control Integration
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You can associate folders with your SCC-compatible source control application so that
Beyond Compare can offer check out and check in services.

3.6 Where Settings are Stored

Beyond Compare stores your sessions, customized file formats and other preferences as .
xml files in its settings folder.  A quick way of finding this location is to pick Help >
Support and click the Explore settings folder link at the bottom of the dialog.

Standard installation

 In Windows, the settings folder is inside your Application Data folder.  The location
depends on your version of Windows.  For instance, under Windows Vista the settings
folder is:

C:\Users\<username>\AppData\Roaming\Scooter Software\Beyond Compare 4

Notice that this location differs for different users on the same computer.

 In Mac, the settings folder is:

~/Library/Application Support/Beyond Compare

If you want to install multiple major versions, you can rename this folder to:

~/Library/Application Support/Beyond Compare 4

 In Linux, the settings folder is:

~/$XDG_CONFIG_HOME/bcompare

If $XDG_CONFIG_HOME is not defined, the settings folder is:

~/.config/bcompare

If an older version of Beyond Compare has been installed, the settings folder is:

~/.beyondcompare

If you want to install multiple major versions, you can append the major version to the
settings folder name like this:

~/$XDG_CONFIG_HOME/bcompare4

Portable installation 

If you prefer a more portable installation with the program and settings all in one location,
you can copy your settings files to the same folder as the program.  Portable installs allow
you to share one set of settings for all users on a computer, or take your settings with
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you.  If you don't have existing settings files to copy, you can create an empty file
named BCState.xml in the folder.
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4
Commands Reference

This part of the documentation describes the commands available in menus and on the
toolbar for each view type.

Commands that are common to all views

Home Commands

Folder Compare Commands

Folder Merge Commands 

Folder Sync Commands

Text Compare Commands

Text Merge Commands 

Table Compare Commands

Hex Compare Commands

MP3 Compare Commands

Picture Compare Commands

Registry Compare Commands 

Version Compare Commands 

Text Edit Commands

Text Patch Commands

4.1 Common

The main menu changes depending on what kind of view is active.  However, the
commands listed below are common across different view types.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu
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New Session Opens a new view with an empty session of the
specified type.

New Tab Opens a new tab in the current window and displays
the Home view.

New Window Opens a new window and displays the Home view.

Open Session Opens a new view and displays the Home view.

Load Workspace Lists saved workspaces.  Picking one closes any open
views and restores the selected configuration.

Load Workspace  >
  Manage Workspaces

Lets you rename or delete saved workspaces.

Save Workspace As Saves the current configuration of windows and tabs as
a named workspace.

Close Tab Closes the current tab.

Exit Quits Beyond Compare, prompting to save any edits.  All
of the instance's windows will close.

The Tools menu

Options Opens the Options dialog to set program preferences.

File Formats Opens the File Formats dialog to manage file format
settings.

Profiles Opens the Profiles dialog to manage profile settings.

Source Control Integration Opens the Source Control Integration dialog.  Available
in Windows version only.

Export Settings Opens the Export Settings dialog to selectively save
settings and sessions to a file.

Import Settings Opens the Import Settings dialog to selectively load
settings and sessions from a file.

Restore Factory Defaults Opens the Restore Factory Defaults dialog to selectively
reset settings to defaults.

Save Snapshot Opens the Save Snapshot dialog to create a snapshot
of a folder structure.

Edit Text File Opens a new Text Edit view.



Commands Reference 109

Copyright © 2014 Scooter Software, Inc.

View Patch Opens a new Text Patch view.

The Help menu

Contents Displays help contents.

Context Sensitive Help Displays help contents page relevant to what you are
focused on.

Scooter Software on the Web Opens the Scooter Software website in your browser.

Check for Updates Checks to see if a newer version of Beyond Compare is
available.

Support Opens the Support dialog which lists instructions for
reporting problems.

Enter Key Opens the Register dialog to accept your license key.

About Beyond Compare Displays the About box with program version and license
information.

4.2 Home

Following is a description of the Home commands, in addition to the common commands.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The View menu

Show Session Management Shows or hides management panel.

Show Web Resources Shows or hides web panel.

4.3 Folder Compare

Following is a description of the Folder Compare commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu
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Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the Folder Compare Session Settings dialog.

Locked Locks or unlocks current session.

Clear Session Replaces the current view with an empty Folder
Compare.

Swap Sides Exchanges the left and right base folders.

Back Goes back to (earlier) compared base folders.

Forward Goes forward to (later) compared base folders.

Browse for Folder >
  Left Side / Right Side

Browses for an existing folder on the specified side.

Up One Level >
  Left Side / Right Side / Both
Sides

Changes either or both base folders to their parent
folders.

Folder Compare Report Produces a Folder Compare report.

Folder Compare Info Displays comparison statistics.

Sync Base Folders Opens a new Folder Sync session based on the current
base folders.

Compare Parent Folders Opens a new Folder Compare session based on the
parent folders of the current base folders.

The Actions menu

Open Folder / Close Folder Opens or closes the selected folder in the comparison.

Open Subfolders Opens the selected folders and all their subfolders.

Close Subfolders * Closes the selected folders and all their subfolders.

Set as Base Folder Sets the selected folder as the base folder on its side
of the comparison.

Set as Base on Other Side Sets the selected folder as the base folder on the other
side of the comparison.

Set as Base Folders Sets the two selected folders as the left and right base
folders in this comparison view.  (To open them in a
new view use Open in New View instead.)



Commands Reference 111

Copyright © 2014 Scooter Software, Inc.

Open Opens selected items in a new comparison view.  If the
items are files, the view type is determined by the file
format list.  If exactly two items are selected, they will
be compared to each other (whether or not they are
across from each other) in the new view.  If only one
item is selected it will be compared to the item across
from it, if it exists.

Open With Opens selected files in a new view using a specified
type of file session, or opens the selected items in an
external application, as defined in "Open With"
Applications.  Note that the Folder Compare view is not
automatically updated if the items are modified by the
external application.

Open With >
  Associated Application

Opens selected files with the associated application.

Open With >
  Text Edit

Opens selected files with the built-in text editor.

Open With >
  Text Patch

Opens selected files with the built-in patch view.

Quick Compare Displays the Quick Compare dialog for the selected files.
 If exactly two files are selected, they will be compared
to each other (whether or not they are across from
each other).  If only one file is selected, it will be
compared to the file across from it.

Compare To Allows you to select one item, and then click on a
second item to compare them in a new view.

Align Forces selected items to be side-by-side.  Items' parent
folders must be side-by-side.

Align With Allows you to select one item, and then click on a
second item to force them to be side-by-side.

Compare Contents Compares contents of the selected items using one of
three methods.

Copy to Other Side Dynamic command that copies selected files, folders to
the opposite side.  The caption and icon appear as 
Copy to Right, Copy to Left or Copy to Side depending on
which side(s) are selected.

Copy to Right / Copy to Left * Copies selected files, folders to the explicitly indicated
side.  Normally associated with Ctrl+R, Ctrl+L keyboard
shortcuts.

Copy to Side * Prompts which side to copy selected files, folders to.

Move to Other Side Dynamic command that moves selected files, folders to
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the opposite side.  The caption and icon appear as 
Move to Right, Move to Left or Move to Side depending
on which side(s) are selected.

Move to Right / Move to Left * Moves selected files, folders to the explicitly indicated
side.

Move to Side * Prompts which side to move selected files, folders to.

Exchange * Moves selected files, folders on both sides to the
opposite side.

Copy to Folder Copies selected files, folders to another folder.

Move to Folder Moves selected files, folders to another folder.

Delete Deletes selected files, folders.

Rename Renames selected files, folders.

Attributes Changes file attributes on selected files, folders.

Touch Changes timestamps on selected files, folders.

Exclude Excludes selected file, or type of file, from the current
session.

New Folder Creates a new folder.

Copy Filename Copies a list of the selected items' paths to the
clipboard.

Ignored Suppresses differences in selected items.

Refresh Selection Refreshes the selected items.

File Compare Report Produces a File Compare report for the selected files.

Synchronize >
  Update Right

Copies newer and orphan items from left to right.

Synchronize >
  Update Left

Copies newer and orphan items from right to left.

Synchronize >
  Update Both

Performs a bidirectional update by copying newer and
orphan items from left to right and from right to left.

Synchronize >
  Mirror to Right

Replaces all different items on right, deletes any right-
side orphans, and copies any left-side orphans to the
right.

Synchronize >
  Mirror to Left

Replaces all different items on left, deletes any left-side
orphans, and copies any right-side orphans to the left.
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Source Control Displays a submenu of source control actions (see
below).  Only appears if a source control provider has
been configured and all selected items are under source
control.

Explorer Displays the file manager's context menu for the
selected item(s).

Source Control Submenu 

Add to Source Control Adds the file to the project.

Remove from Source Control Removes the file from the project.

Get Latest Version Gets the latest version from the source control
repository.

Get * Gets a particular version from the source control
repository.

Check In Takes your changes and applies them to the project.

Check Out Checks the file out from the source control repository
and makes your local copy writable.

Undo Check Out Removes any changes you have made to the local copy
and sets it back to read-only.

Show Differences Tells the version control system to display the
comparison of the file with the one in version control. 
The version control system will only use Beyond
Compare if it is set up to do so.

Show History Shows the history of the file in the version control
system.

Show Properties Shows version control-specific properties.

Run Source Control Application Runs the source control application.

The Edit menu

Expand All Opens all folders in view.

Collapse All Closes all folders in view.

Select All Selects all visible items.
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Select All Files Selects all visible files.

Select Newer >
  Left Side / Right Side / Both
Sides

Selects all visible files that are newer on the specified
side.

Select Orphans >
  Left Side / Right Side / Both
Sides

Selects all visible orphan files on the specified side.

Invert Selection Selects all items not currently selected, and deselects
all items currently selected.

Refresh Refreshes open folders.

Full Refresh Refreshes entire comparison.

The Search menu

Next Difference Positions at next difference.

Previous Difference Positions at previous difference.

Find Filename Finds filename matching search string.

Find Next Filename Finds next filename matching search string.

Find Previous Filename Finds previous filename matching search string.

The View menu

Show All Uses no display filter on either side.

Show Differences Filters out matches, based on file status, from both
sides.

Show Same Filters out older, newer or different, and orphans from
both sides.

Show No Orphans Filters out orphans from both sides.

Show Differences but No
Orphans

Filters out matches and orphans from both sides.

Show Orphans Filters out matches, older, and newer or different from
both sides.

Show Left Newer Filters out matches, orphans, older on left (newer or
different on right) from both sides.
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Show Right Newer Filters out matches, orphans, newer or different on left
(older on right) from both sides.

Show Left Newer and Left
Orphans

Filters out matches and older on left (newer or different
on right) from both sides and orphans on the right side.

Show Right Newer and Right
Orphans

Filters out matches and newer or different on left (older
on right) from both sides and orphans from the left side.

Show Left Orphans Filters out matches, older, and newer or different from
both sides and orphans on the right side.

Show Right Orphans Filters out matches, older, and newer or different from
both sides and orphans on the left side.

Show None * Hides all files.  Useful in conjunction with Always Show

Folders  to copy folder structures.

Always Show Folders Shows all folders, except those excluded by file filters.

Compare Files and Folder
Structure

Shows folders containing files or folders that match the
current display filter.  Orphan folders will follow the
same filtering rules as orphan files.

Compare Files Only Shows only folders containing files to be shown.

Ignore Folder Structure Compares filenames regardless of which subfolder they
may be in.  (Also called F lat ten Folders.)

Ignore Unimportant Differences Treats unimportant differences as same.

Suppress Filters Temporarily suppresses file filters and display filters.

Columns Shows or hides view columns.

Legend Displays a window that lists what the different folder
colors mean.

Log Shows or hides the log panel.

Toolbar Shows or hides the toolbar.

* Hidden by default.

4.4 Folder Merge

Following is a description of the Folder Merge commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.
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Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu

Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the Folder Merge Session Settings dialog.

Locked Locks or unlocks current session.

Clear Session Replaces the current view with an empty Folder Merge.

Swap Sides Exchanges the left and right base folders.

Back Goes back to (earlier) compared base folders.

Forward Goes forward to (later) compared base folders.

Browse for Folder >
  Left Side / Center Side / Right
Side / Output Side

Browses for an existing folder on the specified side.

Up One Level >
  Left Side / Center Side / Right
Side / Output Side / All Sides

Changes specified base folders to their parent folders.

Compare to Output >
  Left Side / Center Side / Right
Side

Opens the base folder on the indicated side and the
output base folder in a new Folder Compare session.

Merge Parent Folders Opens a new Folder Merge session based on the parent
folders of the current base folders.

The Actions menu

Open Folder / Close Folder Opens or closes the selected folder in the comparison.

Open Subfolders Opens the selected folders and all their subfolders.

Close Subfolders * Closes the selected folders and all their subfolders.

Set as Base Folder Sets the selected folder as the base folder on its side
of the comparison.

Set as Base Folders Sets the two or three selected folders as the left and
right or left, right and center base folders in this
comparison view.  (To open them in a new view use 
Open in New View instead.)
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Open Opens selected items in a new comparison view.  If the
items are files, the view type is determined by the file
format list.  If exactly two items are selected, they will
be compared to each other (whether or not they are
across from each other) in the new view.  If only one
item is selected it will be compared to the item across
from it, if it exists.

Open With Opens selected files in a new view using a specified
type of file session, or opens the selected items in an
external application, as defined in "Open With"
Applications.  Note that the Folder Merge view is not
automatically updated if the items are modified by the
external application.

Open With >
  Associated Application

Opens selected files with the associated application.

Open With >
  Text Edit

Opens selected files with the built-in text editor.

Open With >
  Text Patch

Opens selected files with the built-in patch view.

Quick Compare Displays the Quick Compare dialog for the selected files.
 If exactly two files are selected, they will be compared
to each other (whether or not they are across from
each other).  If only one file is selected, it will be
compared to the file across from it.

Compare To Allows you to select one item, and then click on a
second item to compare them in a new view.

Compare Contents Compares contents of the selected items using one of
three methods.

Merge Performs automated merge of selected items.

Copy to Other Side Dynamic command that copies selected files, folders to
the opposite side.  The caption and icon appear as 
Copy to Right, Copy to Left or Copy to Side depending on
which side(s) are selected.

Copy to Right / Copy to Left * Copies selected files, folders to the explicitly indicated
side.  Normally associated with Ctrl+R, Ctrl+L keyboard
shortcuts.

Copy to Side * Prompts which side to copy selected files, folders to.

Copy to Output Copies selected files, folders to the output folder.

Delete Deletes selected files, folders.

Rename Renames selected files, folders.
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Attributes Changes file attributes on selected files, folders.

Touch Changes timestamps on selected files, folders.

Exclude Excludes selected file, or type of file, from the current
session.

New Folder Creates a new folder.

Copy Filename Copies a list of the selected items' paths to the
clipboard.

Ignored Suppresses differences in selected items.

Refresh Selection Refreshes the selected items.

Source Control Displays a submenu of source control actions (see
below).  Only appears if a source control provider has
been configured and all selected items are under source
control.

Explorer Displays the file manager's context menu for the
selected item(s).

Source Control Submenu 

Add to Source Control Adds the file to the project.

Remove from Source Control Removes the file from the project.

Get Latest Version Gets the latest version from the source control
repository.

Get * Gets a particular version from the source control
repository.

Check In Takes your changes and applies them to the project.

Check Out Checks the file out from the source control repository
and makes your local copy writable.

Undo Check Out Removes any changes you have made to the local copy
and sets it back to read-only.

Show Differences Tells the version control system to display the
comparison of the file with the one in version control. 
The version control system will only use Beyond
Compare if it is set up to do so.
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Show History Shows the history of the file in the version control
system.

Show Properties Shows version control-specific properties.

Run Source Control Application Runs the source control application.

The Edit menu

Expand All Opens all folders in view.

Collapse All Closes all folders in view.

Select All Selects all visible items.

Select All Files Selects all visible files.

Select Newer >
  Left Side / Right Side / Both
Sides

Selects all visible files that are newer on the specified
side.

Select Orphans >
  Left Side / Right Side / Both
Sides

Selects all visible orphan files on the specified side.

Invert Selection Selects all items not currently selected, and deselects
all items currently selected.

Refresh Refreshes open folders.

Full Refresh Refreshes entire comparison.

The Search menu

Next Difference Positions at next difference.

Previous Difference Positions at previous difference.

Find Filename Finds filename matching search string.

Find Next Filename Finds next filename matching search string.

Find Previous Filename Finds previous filename matching search string.

The View menu

Show All Uses no display filter on either side.
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Show Changes Shows left add, right add, left delete, right delete, left
change, right change and conflict items.

Show Conflicts Shows conflict items.

Show Left Changes Shows left add, left delete, and left change items.

Show Right Changes Shows right add, right delete, and right change items.

Show Mergeable Shows same change and difference change items.

Show Unchanged Shows unchanged items.

Show None * Hides all files.  Useful in conjunction with Always Show

Folders  to copy folder structures.

Always Show Folders Shows all folders, except those excluded by file filters.

Compare Files and Folder
Structure

Shows folders containing files or folders that match the
current display filter.  Orphan folders will follow the
same filtering rules as orphan files.

Compare Files Only Shows only folders containing files to be shown.

Ignore Folder Structure Compares filenames regardless of which subfolder they
may be in.  (Also called F lat ten Folders.)

Ignore Unimportant Differences Treats unimportant differences as same.

Suppress Filters Temporarily suppresses file filters and display filters.

Center Pane Shows or hides the center pane.

Columns Shows or hides view columns.

Legend Displays a window that lists what the different folder
colors mean.

Log Shows or hides the log panel.

Toolbar Shows or hides the toolbar.

* Hidden by default.

4.5 Folder Sync

Following is a description of the Folder Sync commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
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keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu

Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the Folder Sync Session Settings dialog.

Locked Locks or unlocks current session.

Clear Session Replaces the current view with an empty Folder Sync.

Swap Sides Exchanges the left and right base folders.

Folder Sync Info Displays sync statistics.

Run Sync Performs all sync actions.

Compare Base Folders Opens a new Folder Compare session based on the
current base folders.

Compare Parent Folders Opens a new Folder Compare session based on the
parent folders of the current base folders.

The Actions menu

Leave Alone Changes sync operation to leave alone.

Copy Right to Left Changes sync operation to copy right to left.

Copy Left to Right Changes sync operation to copy left to right.

Delete Left Changes sync operation to delete left.

Delete Right Changes sync operation to delete right.

Open Folder / Close Folder Opens or closes the selected folder in the comparison.

Open Subfolders Opens the selected folders and all their subfolders.

Close Subfolders * Closes the selected folders and all their subfolders.

Set as Base Folder Sets the selected folder as the base folder on its side
of the comparison.

Set as Base on Other Side Sets the selected folder as the base folder on the other
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side of the comparison.

Set as Base Folders Sets the two selected folders as the left and right base
folders in this comparison view.  (To open them in a
new view use Open in New View instead.)

Open Opens selected items in a new comparison view.  If the
items are files, the view type is determined by the file
format list.  If exactly two items are selected, they will
be compared to each other (whether or not they are
across from each other) in the new view.  If only one
item is selected it will be compared to the item across
from it, if it exists.

Open With Opens selected files in a new view using a specified
type of file session, or opens the selected items in an
external application, as defined in "Open With"
Applications.  Note that the Folder Sync view is not
automatically updated if the items are modified by the
external application.

Open With >
  Associated Application

Opens selected files with the associated application.

Open With >
  Text Edit

Opens selected files with the built-in text editor.

Open With >
  Text Patch

Opens selected files with the built-in patch view.

Exclude Excludes selected file, or type of file, from the current
session.

Copy Filename Copies a list of the selected items' paths to the
clipboard.

Refresh Selection Refreshes the selected items.

Explorer Displays the file manager's context menu for the
selected item(s).

The Edit menu

Expand All Opens all folders in view.

Collapse All Closes all folders in view.

Select All Selects all visible items.

Invert Selection Selects all items not currently selected, and deselects
all items currently selected.
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Refresh Refreshes open folders.

Full Refresh Refreshes entire comparison.

The Search menu

Next Conflict Positions at next conflict.

Previous Conflict Positions at previous conflict.

Find Filename Finds filename matching search string.

Find Next Filename Finds next filename matching search string.

Find Previous Filename Finds previous filename matching search string.

The View menu

Ignore Unimportant Differences Treats unimportant differences as same.

Suppress Filters Temporarily shows items that will not be affected by
the sync.

Columns Shows or hides view columns.

Legend Displays a window that lists what the different folder
colors mean.

Log Shows or hides the log panel.

Toolbar Shows or hides the toolbar.

4.6 Text Compare

Following is a description of the Text Compare commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu

Save Session Saves the current session.
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Save Session As Saves the current session under a new name.

Session Settings Opens the Text Compare Session Settings dialog.

Locked Locks or unlocks current session.

Clear Session Replaces the current view with an empty Text Compare.

Swap Sides Exchanges the left and right files.

Reload Files Reloads the displayed files, prompting to save first if
necessary.

Recompare Files Recompares the displayed files, preserving edits, but
not undoability.

Text Compare Report Produces the Text Compare report.

Text Compare Info Displays comparison statistics.

Compare Files Using Opens the displayed files in a new session using a
different class of file view.

Merge Files Opens a new Text Merge session based on the currently
loaded files.

Compare Parent Folders Opens a new Folder Compare session based on the
parent folders of the currently loaded files.

The File menu

Open File Opens an existing file into the picked pane.

Open File on File System * Opens an existing local file into the picked pane.

Open File Using Profile * Opens an existing file into the picked pane using a
profile.

Open Clipboard Loads the Clipboard contents into the picked pane.

Open With Opens the picked pane's file in one of the external Open
With applications.

Open With >
  Associated Application

Opens the picked pane's file with its associated
application.

Open With >
  Text Edit

Opens the picked pane's file with the built-in text
editor.
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Open With >
  Text Patch

Opens the picked pane's file with the built-in patch
view.

Save File Saves the modified file from the picked pane.

Save File As Saves the file from the picked pane with a new name.

Save File on File System As * Saves the file from the picked pane with a new name on
the file system.

Save File Using Profile As * Saves the file from the picked pane with a new name
using a profile.

Explorer Displays the file manager's context menu for the file in
the picked pane.

Check In Appears if a source control provider has been
configured and the file is under source control.

Check Out 

Undo Check Out 

The Edit menu

Undo Undoes previous action.

Redo Redoes previously undone action.

Align With Allows you to select one or more lines, and then click
on a line on the other side to force them to be side-by-
side.

Isolate Realigns comparison so that selected lines are by
themselves.

Replacement Adds item to the replacement list based on the current
difference.

Copy to Right / Copy to Left * Copies selected lines or current section to indicated
side.

Copy to Other Side Copies selected lines or current section to opposite
side.  The caption and icon appear as Copy to Right or
Copy to Left depending on the current side.

Copy Line to Right / Copy Line
to Left *

Copies current line to indicated side.

Copy Line to Other Side Copies current line to other side.  The caption and icon
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appear as Copy Line to Right or Copy Line to Left
depending on the current side.

Increase Indent Increases indentation of selected lines.

Decrease Indent Decreases indentation of selected lines.

Cut / Copy / Paste / Delete Standard editing commands.

Delete Line * Deletes the current line.

Delete to Start of Line * Deletes text from the current position to the beginning
of the line.

Delete to End of Line * Deletes text from the current position to the end of the
line.

Delete Word * Deletes the word at the current position.

Delete to Start of Word * Deletes from the current position to the beginning of
the word.

Delete to End of Word * Deletes from the current position to the end of the
word.

Insert Line Before * Inserts a new blank line before the current line.

Insert Line After * Inserts a new blank line after the current line.

Select All Selects all visible lines in the current pane.

Select Section Selects all lines in the current section.

Compare Selection to Clipboard Compares the selected text with the contents of the
clipboard in a new view.

Convert File  >
  Trim Trailing Whitespace

Strips off spaces and tab characters at end of lines.

Convert File  >
  Leading Spaces to Tabs

Replaces spaces at the beginning of lines with the
appropriate number of tab characters (based on current
tab stop setting).

Convert File  >
  Tabs To Spaces

Replaces all tab characters with the appropriate number
of space characters (based on current tab stop
setting).

Convert File  >
  Line Endings

Changes the line ending style on all lines.

Full Edit Toggles between full character mode editing (marked)
and Beyond Compare 2-like line mode (unmarked) in the
main file panes.
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The Search menu

Next Difference Positions at next difference text.

Previous Difference Positions at previous difference text.

Next Difference Section Positions at next difference section.

Previous Difference Section Positions at previous difference section.

Next Difference Files Opens the parent folder session's next pair of files with
differences.  (Child sessions only.)

Previous Difference Files Opens the parent folder session's previous pair of files
with differences.  (Child sessions only.)

Copy File to Right and Open Next
Difference

Copies the entire left-side file to the right and opens
the folder session's next different files.  (Child sessions
only.)

Copy File to Left and Open Next
Difference

Copies the entire right-side file to the left and opens
the folder session's next different files.  (Child sessions
only.)

Next Replacement Positions at next replacement text.

Previous Replacement Positions at previous replacement text.

Next Edit Positions at the next edited line beyond the cursor.

Previous Edit Positions at previous edited line before the cursor.

Find Searches for matching text.

Replace Replaces matching text.

Find Next Finds next occurrence of search string.

Find Previous Finds previous occurrence of search string.

Go To Positions at specified line and column.

Toggle Bookmark Places a numbered marker on the current line of the
comparison, numbered from 0 to 9.

Go To Bookmark Repositions at the specified bookmark.

Clear Bookmarks Removes all bookmarks from the comparison.
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The View menu

Show All Shows all lines, with or without differences.

Show Differences Shows only lines with differences.

Show Same Shows only lines without differences.

Show None * Hides all lines.

Show Context Shows lines surrounding differences.  The number of
context lines can be set in Text View Options.

Ignore Unimportant Differences Treats unimportant differences as same.

Ignored Suppresses differences in selected lines or current
section.

Visible Whitespace Shows or hides visible spaces, tabs.

Line Numbers Shows or hides line numbers.

Syntax Highlighting Shows or hides syntax highlighting.

Display Font * Selects the font to use in editor panes.

Side-by-side Layout Arranges editor panes left and right of each other.

Over-under Layout Arranges editor panes above and below each other.

Webpages Shows or hides web browser panels that display the
current files as webpages.

Thumbnail Shows or hides the thumbnail summary of changes at
left of view.

Text Details Shows or hides the text details panel at bottom of
view.

Hex Details Shows or hides the hexadecimal details panel at bottom
of view.

Alignment Details Shows or hides the alignment details panel at bottom of
view.

Ruler Shows or hides the line details ruler.

File Info Shows or hides file information panels at the top of
editor panes.
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Toolbar Shows or hides the toolbar.

* Hidden by default.

4.7 Text Merge

Following is a description of the Text Merge commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu

Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the Text Merge Session Settings dialog.

Locked Locks or unlocks current session.

Clear Session Replaces the current view with an empty Text Merge.

Swap Sides Exchanges the left and right files.

Reload Files Reloads the displayed files, prompting to save first if
necessary.

Recompare Files Recompares the displayed files, preserving edits, but
not undoability.

Text Merge Info Displays merge statistics.

Compare to Output >
  Left Side / Center Side / Right
Side

Opens the file on the indicated side and the output file
in a new Text Compare session.

Merge Parent Folders Opens a new Folder Merge session based on the parent
folders of the currently loaded files.

The File menu

Open File Opens an existing file into the picked pane.
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Open File on File System * Opens an existing local file into the picked pane.

Open File Using Profile * Opens an existing file into the picked pane using a
profile.

Open Clipboard Loads the Clipboard contents into the picked pane.

Open With Opens the picked pane's file in one of the external Open
With applications.

Open With >
  Associated Application

Opens the picked pane's file with its associated
application.

Open With >
  Text Edit

Opens the picked pane's file with the built-in text
editor.

Open With >
  Text Patch

Opens the picked pane's file with the built-in patch
view.

Save File Saves the modified file from the picked pane.

Save File As Saves the file from the picked pane with a new name.

Save File on File System As * Saves the file from the picked pane with a new name on
the file system.

Save File Using Profile As * Saves the file from the picked pane with a new name
using a profile.

Explorer Displays the file manager's context menu for the file in
the picked pane.

The Edit menu

Undo Undoes previous action.

Redo Redoes previously undone action.

Align With Allows you to select one line, and then click on a
second line to force them to be side-by-side.

Isolate Realigns comparison so that selected lines are by
themselves.

Conflict Clears or sets conflict for selected lines or current
section.

Take Left / Take Center / Take
Right

Takes selected lines or current section from indicated
side.
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Take Left Then Right / Take
Right Then Left

Takes selected lines or current section from left and
right in the indicated order.

Take Left Line / Take Center
Line / Take Right Line

Takes current line from indicated side.

Increase Indent Increases indentation of selected lines.

Decrease Indent Decreases indentation of selected lines.

Cut / Copy / Paste / Delete Standard editing commands.

Delete Line * Deletes the current line.

Delete to Start of Line * Deletes text from the current position to the beginning
of the line.

Delete to End of Line * Deletes text from the current position to the end of the
line.

Delete Word * Deletes the word at the current position.

Delete to Start of Word * Deletes from the current position to the beginning of
the word.

Delete to End of Word * Deletes from the current position to the end of the
word.

Insert Line Before * Inserts a new blank line before the current line.

Insert Line After * Inserts a new blank line after the current line.

Select All Selects all visible lines in the current pane.

Select Section Selects all lines in the current section.

Compare Selection to Clipboard Compares the selected text with the contents of the
clipboard in a new view.

Full Edit Toggles between full character mode editing (marked)
and Beyond Compare 2-like line mode (unmarked) in the
main file panes.

The Search menu

Clear Conflict Section, Next Clears conflict for current section and positions at next
conflict section.

Next Conflict Section Positions at next conflict section.
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Previous Conflict Section Positions at previous conflict section.

Next Difference Positions at next difference text.

Previous Difference Positions at previous difference text.

Next Difference Section Positions at next difference section.

Previous Difference Section Positions at previous difference section.

Next Difference Files Opens the parent folder session's next pair of files with
differences.  (Child sessions only.)

Previous Difference Files Opens the parent folder session's previous pair of files
with differences.  (Child sessions only.)

Take Left File and Open Next
Difference

Takes the entire left-side file and opens the folder
session's next different files.  (Child sessions only.)

Take Right File and Open Next
Difference

Takes the entire right-side file and opens the folder
session's next different files.  (Child sessions only.)

Next Left Taken / Next Right
Taken

Positions at next range of lines where indicated side
was taken.

Previous Left Taken / Previous
Right Taken

Positions at previous range of lines where indicated side
was taken.

Next Edit Positions at the next edited line beyond the cursor.

Previous Edit Positions at previous edited line before the cursor.

Find Searches for matching text.

Replace Replaces matching text.

Find Next Finds next occurrence of search string.

Find Previous Finds previous occurrence of search string.

Go To Positions at specified line and column.

Toggle Bookmark Places a numbered marker on the current line of the
comparison, numbered from 0 to 9.

Go To Bookmark Repositions at the specified bookmark.

Clear Bookmarks Removes all bookmarks from the comparison.

The View menu
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Show All Shows unchanged, same change, left change, right
change, different change and conflict lines.

Show Changes Shows same change, left change, right change,
different change and conflict lines.

Show Conflicts Shows conflict lines.

Show Left Changes Shows same change, left change, different change and
conflict lines.

Show Right Changes Shows same change, right change, different change
and conflict lines.

Show Mergeable Shows same change, left change, right change, and
different change lines.

Show Unchanged Shows unchanged lines.

Show None * Shows no lines.

Show Context Shows lines surrounding differences.  The number of
context lines can be set in Text View Options.

Ignore Unimportant Differences Treats unimportant differences as same.

Ignore Same Changes Treats same changes as same.

Favor Left Changes Suppresses highlighting of left-only changes in output.

Favor Right Changes Suppresses highlighting of right-only changes in output.

Ignored Ignores (or unignores) differences in selected lines or
current section.

Visible Whitespace Shows or hides visible spaces, tabs.

Line Numbers Shows or hides line numbers.

Syntax Highlighting Shows or hides syntax highlighting.

Display Font * Selects the font to use in editor panes.

Side-by-side Layout Arranges editor panes left and right of each other.

Over-under Layout Arranges editor panes above and below each other.

Detached Output Pane Shows output pane in separate window.

Webpages Shows or hides web browser panels that display the
current files as webpages.
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Thumbnail Shows or hides the thumbnail summary of changes at
left of view.

Center Pane Shows or hides center pane.

Text Details Shows or hides the text details panel at bottom of
view.

Hex Details Shows or hides the hexadecimal details panel at bottom
of view.

Ruler Shows or hides the line details ruler.

File Info Shows or hides file information panels at the top of
editor panes.

Toolbar Shows or hides the toolbar.

* Hidden by default.

4.8 Table Compare

Following is a description of the Table Compare commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu

Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the Table Compare Session Settings dialog.

Locked Locks or unlocks current session.

Clear Session Replaces the current view with an empty Table
Compare.

Swap Sides Exchanges the left and right files.

Reload Files Reloads the displayed files, prompting to save first if
necessary.

Recompare Files Recompares the displayed files, preserving edits, but
not undoability.
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Table Compare Report Produces the Table Compare report.

Table Compare Info Displays comparison statistics.

Compare Files Using Opens the displayed files in a new session using a
different class of file view.

Compare Parent Folders Opens a new Folder Compare session based on the
parent folders of the currently loaded files.

The File menu

Open File Opens an existing file into the picked pane.

Open File on File System * Opens an existing local file into the picked pane.

Open File Using Profile * Opens an existing file into the picked pane using a
profile.

Open Clipboard Loads the Clipboard contents into the picked pane.

Open With Opens the picked pane's file in one of the external Open
With applications.

Open With >
  Associated Application

Opens the picked pane's file with its associated
application.

Open With >
  Text Edit

Opens the picked pane's file with the built-in text
editor.

Save File Saves the modified file from the picked pane.

Save File As Saves the file from the picked pane with a new name.

Save File on File System As * Saves the file from the picked pane with a new name on
the file system.

Save File Using Profile As * Saves the file from the picked pane with a new name
using a profile.

Explorer Displays the file manager's context menu for the file in
the picked pane.

The Edit menu

Undo Undoes previous action.
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Redo Redoes previously undone action.

Copy to Right / Copy to Left * Copies selected rows to indicated side.

Copy to Other Side Copies selected rows to opposite side.  The caption and
icon appear as Copy to Right or Copy to Left depending
on the current side.

Cut / Copy / Paste / Delete Standard editing commands.

Insert Inserts new row.

Edit Toggles edit mode on current cell.

Select All Selects all visible rows in the current pane.

The Search menu

Next Difference Row Positions at next difference row.

Previous Difference Row Positions at previous difference row.

Next Difference Files Opens the parent folder session's next pair of files with
differences.  (Child sessions only.)

Previous Difference Files Opens the parent folder session's previous pair of files
with differences.  (Child sessions only.)

Copy File to Right and Open Next
Difference

Copies the entire left-side file to the right and opens
the folder session's next different files.  (Child sessions
only.)

Copy File to Left and Open Next
Difference

Copies the entire right-side file to the left and opens
the folder session's next different files.  (Child sessions
only.)

Next Edit Positions at the next edited row beyond the cursor.

Previous Edit Positions at previous edited row before the cursor.

Find Searches for matching text.

Find Next Finds next occurrence of search string.

Find Previous Finds previous occurrence of search string.

Go To Positions at specified row and column.
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The View menu

Show All Shows all rows, with or without differences.

Show Differences Shows only rows with differences.

Show Same Shows only rows without differences.

Show None * Hides all rows.

Ignore Unimportant Differences Treats unimportant differences as same.

Resize Columns to Fit Makes columns wide enough for data to be fully visible.

Columns Shows or hides columns.

Visible Whitespace Shows or hides visible spaces, tabs.

Row Numbers Shows or hides row numbers.

Display Font * Selects the font to use to display file data.

Side-by-side Layout Arranges panes left and right of each other.

Over-under Layout Arranges panes above and below each other.

Thumbnail Shows or hides the thumbnail summary of changes at
left of view.

Text Details Shows or hides the text details panel at bottom of
view.

File Info Shows or hides file information panels at the top of
panes.

Toolbar Shows or hides the toolbar.

* Hidden by default.

4.9 Hex Compare

Following is a description of the Hex Compare commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu
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Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the Hex Compare Session Settings dialog.

Locked Locks or unlocks current session.

Clear Session Replaces the current view with an empty Hex Compare.

Swap Sides Exchanges the left and right files.

Reload Files Reloads the displayed files, prompting to save first if
necessary.

Recompare Files Recompares the displayed files, preserving edits, but
not undoability.

Hex Compare Report Produces the Hex Compare report.

Hex Compare Info Displays comparison statistics.

Compare Files Using Opens the displayed files in a new session using a
different class of file view.

Compare Parent Folders Opens a new Folder Compare session based on the
parent folders of the currently loaded files.

The File menu

Open File Opens an existing file into the picked pane.

Open File on File System * Opens an existing local file into the picked pane.

Open File Using Profile * Opens an existing file into the picked pane using a
profile.

Open Clipboard Loads the Clipboard contents into the picked pane.

Open With Opens the picked pane's file in one of the external Open
With applications.

Open With >
  Associated Application

Opens the picked pane's file with its associated
application.

Open With >
  Text Edit

Opens the picked pane's file with the built-in text
editor.

Save File Saves the modified file from the picked pane.
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Save File As Saves the file from the picked pane with a new name.

Save File on File System As * Saves the file from the picked pane with a new name on
the file system.

Save File Using Profile As * Saves the file from the picked pane with a new name
using a profile.

Explorer Displays the file manager's context menu for the file in
the picked pane.

The Edit menu

Undo Undoes previous action.

Redo Redoes previously undone action.

Copy to Right / Copy to Left * Copies selected bytes to indicated side.

Copy to Other Side Copies selected bytes to opposite side.  The caption
and icon appear as Copy to Right or Copy to Left
depending on the current side.

Cut / Copy / Paste / Delete Standard editing commands.

Select All Selects all visible bytes in the current pane.

The Search menu

Next Difference Bytes Positions at next difference bytes.

Previous Difference Bytes Positions at previous difference bytes.

Next Difference Files Opens the parent folder session's next pair of files with
differences.  (Child sessions only.)

Previous Difference Files Opens the parent folder session's previous pair of files
with differences.  (Child sessions only.)

Copy File to Right and Open Next
Difference

Copies the entire left-side file to the right and opens
the folder session's next different files.  (Child sessions
only.)

Copy File to Left and Open Next
Difference

Copies the entire right-side file to the left and opens
the folder session's next different files.  (Child sessions
only.)
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Find Searches for matching text.

Replace Replaces matching text.

Find Next Finds next occurrence of search string.

Find Previous Finds previous occurrence of search string.

Go To Positions at specified byte.

The View menu

Show All Shows all bytes, with or without differences.

Show Differences Shows only bytes with differences.

Show Same Shows only bytes without differences.

Current Byte Address Shows current byte address.

Little Endian Values Lists values treating the first byte as the least
significant one.

Big Endian Values Lists values treating the first byte as the most
significant one.

Byte Addresses Shows or hides byte addresses.

Display Font * Selects the font to use to display file data.

Layout Configures layout options.

Side-by-side Layout Arranges panes left and right of each other.

Over-under Layout Arranges panes above and below each other.

Thumbnail Shows or hides the thumbnail summary of changes at
left of view.

File Info Shows or hides file information panels at the top of
panes.

Toolbar Shows or hides the toolbar.

* Hidden by default.
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4.10 MP3 Compare

Following is a description of the MP3 Compare commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu

Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the MP3 Compare Session Settings dialog.

Locked Locks or unlocks current session.

Clear Session Replaces the current view with an empty MP3 Compare.

Swap Sides Exchanges the left and right files.

Reload Files Reloads the displayed files.

Recompare Files Recompares the displayed files without reloading.

MP3 Compare Report Produces the MP3 Compare report.

MP3 Compare Info Displays comparison statistics.

Play Both Plays both audio tracks.

Compare Files Using Opens the displayed files in a new session using a
different class of file view.

Compare Parent Folders Opens a new Folder Compare session based on the
parent folders of the currently loaded files.

The File menu

Open File Opens an existing file into the picked pane.

Open File on File System * Opens an existing local file into the picked pane.

Open File Using Profile * Opens an existing file into the picked pane using a
profile.



Beyond Compare142

Copyright © 2014 Scooter Software, Inc.

Play Plays audio track.

Open With Opens the picked pane's file in one of the external Open
With applications.

Open With >
  Associated Application

Opens the picked pane's file with its associated
application.

Explorer Displays the file manager's context menu for the file in
the picked pane.

The Edit menu

Copy Copies selection to the Clipboard.

Select All Selects all visible items in the current pane.

The Search menu

Next Difference Item Positions at next difference item.

Previous Difference Item Positions at previous difference item.

Next Difference Files Opens the parent folder session's next pair of files with
differences.  (Child sessions only.)

Previous Difference Files Opens the parent folder session's previous pair of files
with differences.  (Child sessions only.)

Copy File to Right and Open Next
Difference

Copies the entire left-side file to the right and opens
the folder session's next different files.  (Child sessions
only.)

Copy File to Left and Open Next
Difference

Copies the entire right-side file to the left and opens
the folder session's next different files.  (Child sessions
only.)

Find Searches for matching text.

Find Next Finds next occurrence of search string.

Find Previous Finds previous occurrence of search string.

The View menu
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Show All Shows all items, with or without differences.

Show Differences Shows only items with differences.

Show Same Shows only items without differences.

Show None * Hides all items.

Ignore Unimportant Differences Treats unimportant differences as same.

Item Is Important Marks selected item as important or unimportant.

Visible Whitespace Shows or hides visible spaces, tabs.

Display Font * Selects the font to use to display file data.

Side-by-side Layout Arranges panes left and right of each other.

Over-under Layout Arranges panes above and below each other.

Text Details Shows or hides the text details panel at bottom of
view.

File Info Shows or hides file information panels at the top of
panes.

Toolbar Shows or hides the toolbar.

* Hidden by default.

4.11 Picture Compare

Following is a description of the Picture Compare commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu

Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the Picture Compare Session Settings dialog.

Locked Locks or unlocks current session.
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Clear Session Replaces the current view with an empty Picture
Compare.

Swap Sides Exchanges the left and right files.

Reload Files Reloads the displayed files.

Recompare Files Recompares the displayed files without reloading.

Picture Compare Report Produces the Picture Compare report.

Picture Compare Info Displays comparison statistics.

Compare Files Using Opens the displayed files in a new session using a
different class of file view.

Compare Parent Folders Opens a new Folder Compare session based on the
parent folders of the currently loaded files.

The File menu

Open File Opens an existing file into the picked pane.

Open File on File System * Opens an existing local file into the picked pane.

Open File Using Profile * Opens an existing file into the picked pane using a
profile.

Open Clipboard Loads the Clipboard contents into the picked pane.

Open With Opens the picked pane's file in one of the external Open
With applications.

Open With >
  Associated Application

Opens the picked pane's file with its associated
application.

Explorer Displays the file manager's context menu for the file in
the picked pane.

The Edit menu

Copy Copies selection to the Clipboard.

The Search menu

Next Difference Files Opens the parent folder session's next pair of files with
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differences.  (Child sessions only.)

Previous Difference Files Opens the parent folder session's previous pair of files
with differences.  (Child sessions only.)

Copy File to Right and Open Next
Difference

Copies the entire left-side file to the right and opens
the folder session's next different files.  (Child sessions
only.)

Copy File to Left and Open Next
Difference

Copies the entire right-side file to the left and opens
the folder session's next different files.  (Child sessions
only.)

The View menu

Tolerance Mode Detects pixel differences greater than configurable
tolerance.

Mismatch Range Mode Measures degree of pixel difference.

Blend Mode Blends pictures based on configurable percentage.

Ignore Unimportant Differences Treats unimportant differences as same.

Auto Scale Forces pictures to have same height or width.

Rotate Clockwise Spins current picture to right by 90 degrees.

Rotate Counterclockwise Spins current picture to left by 90 degrees.

Flip Horizontally Swaps pixels of current picture relative to its horizontal
center.

Flip Vertically Swaps pixels of current picture relative to its vertical
center.

Reset Difference Offset Realigns top left corner of both pictures.

Blend Toggle Switches between left and right pictures.

File Info Shows or hides file information panels at the top of
panes.

Full Screen Displays the picked pane full screen.  Press ESC to exit
full screen mode.

Zoom  >
  Zoom In

Makes pictures appear to be larger.

Zoom  >
  Zoom Out

Makes pictures appear to be smaller.
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Zoom  >
  Actual Size

Makes pictures appear at actual size.

Zoom  >
  Fit to Window

Makes pictures appear to fill panes.

Toolbar Shows or hides the toolbar.

* Hidden by default.

4.12 Registry Compare

Following is a description of the Registry Compare commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu

Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the Registry Compare Session Settings dialog.

Locked Locks or unlocks current session.

Clear Session Replaces the current view with an empty Registry
Compare.

Swap Sides Exchanges the left and right registries.

Up One Level >
  Left Side / Right Side / Both
Sides

Changes either or both base keys to their parent keys.

Reload Reloads the displayed registries.

Recompare Recompares the displayed registries without reloading.

Registry Compare Report Produces the Registry Compare report.

Registry Compare Info Displays comparison statistics.

Compare Files Using Opens the displayed files in a new session using a
different class of file view.

Compare Parent Folders Opens a new Folder Compare session based on the



Commands Reference 147

Copyright © 2014 Scooter Software, Inc.

parent folders of the currently loaded files.

The File menu

Open Opens a registry into the picked pane.

Open Registry * Opens a live registry into the picked pane.

Open Registry File on File
System *

Opens an existing local registry file into the picked
pane.

Open Registry File Using Profile 
*

Opens an existing registry file into the picked pane
using a profile.

Open With Opens the picked pane's file in one of the external Open
With applications.

Open With >
  Associated Application

Opens the picked pane's file with its associated
application.

Open With >
  Text Edit

Opens the picked pane's file with the built-in text
editor.

Explorer Displays the file manager's context menu for the file in
the picked pane.

The Edit menu

Set as Base Keys Sets selected keys as base keys.

Set Both as Base Keys Sets selected key and key on other side as base keys.

Set as Base Key on Other Side Sets selected key as base key on other side.

Undo Undoes previous action.

Redo Redoes previously undone action.

Copy to Right / Copy to Left * Copies selected items to indicated side.

Copy to Other Side Copies selected items to opposite side.  The caption
and icon appear as Copy to Right or Copy to Left
depending on the current side.

Copy Copies selection to the Clipboard.

Delete Deletes selected items.
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Rename Renames current item.

New Key Adds a new key.

New Value Adds a new value.

Modify Modifies current value.

Copy Key Name Copies current key's name to Clipboard.

Export Saves current key as registry file.

Export All Saves all keys as registry file.

Select All Selects all visible items in the current pane.

The Search menu

Next Difference Item Positions at next difference item.

Previous Difference Item Positions at previous difference item.

Next Difference Files Opens the parent folder session's next pair of files with
differences.  (Child sessions only.)

Previous Difference Files Opens the parent folder session's previous pair of files
with differences.  (Child sessions only.)

Copy File to Right and Open Next
Difference

Copies the entire left-side file to the right and opens
the folder session's next different files.  (Child sessions
only.)

Copy File to Left and Open Next
Difference

Copies the entire right-side file to the left and opens
the folder session's next different files.  (Child sessions
only.)

Find Searches for matching text.

Find Next Finds next occurrence of search string.

Find Previous Finds previous occurrence of search string.

The View menu

Show All Shows all items, with or without differences.

Show Differences Shows only items with differences.
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Show Same Shows only items without differences.

Show None * Hides all items.

Expand All Opens all items.

Collapse All Closes all items.

Visible Whitespace Shows or hides visible spaces, tabs.

Display Font * Selects the font to use to display file data.

Side-by-side Layout Arranges panes left and right of each other.

Over-under Layout Arranges panes above and below each other.

Text Details Shows or hides the text details panel at bottom of
view.

Hex Details Shows or hides the hexadecimal details panel at bottom
of view.

File Info Shows or hides file information panels at the top of
panes.

Toolbar Shows or hides the toolbar.

* Hidden by default.

4.13 Version Compare

Following is a description of the Version Compare commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The Session menu

Save Session Saves the current session.

Save Session As Saves the current session under a new name.

Session Settings Opens the Version Compare Session Settings dialog.

Locked Locks or unlocks current session.
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Clear Session Replaces the current view with an empty Version
Compare.

Swap Sides Exchanges the left and right files.

Reload Files Reloads the displayed files.

Recompare Files Recompares the displayed files without reloading.

Version Compare Report Produces the Version Compare report.

Version Compare Info Displays comparison statistics.

Compare Files Using Opens the displayed files in a new session using a
different class of file view.

Compare Parent Folders Opens a new Folder Compare session based on the
parent folders of the currently loaded files.

The File menu

Open File Opens an existing file into the picked pane.

Open File on File System * Opens an existing local file into the picked pane.

Open File Using Profile * Opens an existing file into the picked pane using a
profile.

Open With Opens the picked pane's file in one of the external Open
With applications.

Open With >
  Associated Application

Opens the picked pane's file with its associated
application.

Explorer Displays the file manager's context menu for the file in
the picked pane.

The Edit menu

Copy Copies selection to the Clipboard.

Select All Selects all visible items in the current pane.

The Search menu

Next Difference Item Positions at next difference item.
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Previous Difference Item Positions at previous difference item.

Next Difference Files Opens the parent folder session's next pair of files with
differences.  (Child sessions only.)

Previous Difference Files Opens the parent folder session's previous pair of files
with differences.  (Child sessions only.)

Copy File to Right and Open Next
Difference

Copies the entire left-side file to the right and opens
the folder session's next different files.  (Child sessions
only.)

Copy File to Left and Open Next
Difference

Copies the entire right-side file to the left and opens
the folder session's next different files.  (Child sessions
only.)

Find Searches for matching text.

Find Next Finds next occurrence of search string.

Find Previous Finds previous occurrence of search string.

The View menu

Show All Shows all items, with or without differences.

Show Differences Shows only items with differences.

Show Same Shows only items without differences.

Show None * Hides all items.

Ignore Unimportant Differences Treats unimportant differences as same.

Item Is Important Marks selected item as important or unimportant.

Visible Whitespace Shows or hides visible spaces, tabs.

Display Font * Selects the font to use to display file data.

Side-by-side Layout Arranges panes left and right of each other.

Over-under Layout Arranges panes above and below each other.

Text Details Shows or hides the text details panel at bottom of
view.

File Info Shows or hides file information panels at the top of
panes.
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Toolbar Shows or hides the toolbar.

* Hidden by default.

4.14 Text Edit

Following is a description of the Text Edit commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.

The File menu

Open File Opens an existing file.

Open File on File System * Opens an existing local file.

Open File Using Profile * Opens an existing file using a profile.

Open With Opens the file in one of the external Open With
applications.

Open With >
  Associated Application

Opens the file with its associated application.

Open With >
  Text Patch

Opens the file with the built-in patch view.

Save File Saves the modified file.

Save File As Saves the file with a new name.

Save File on File System As * Saves the file with a new name on the file system.

Save File Using Profile As * Saves the file with a new name using a profile.

Explorer Displays the file manager's context menu for the file.

Check In Appears if a source control provider has been
configured and the file is under source control.

Check Out 

Undo Check Out 

The Edit menu
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Undo Undoes previous action.

Redo Redoes previously undone action.

Increase Indent Increases indentation of selected lines.

Decrease Indent Decreases indentation of selected lines.

Cut / Copy / Paste / Delete Standard editing commands.

Delete Line * Deletes the current line.

Delete to Start of Line * Deletes text from the current position to the beginning
of the line.

Delete to End of Line * Deletes text from the current position to the end of the
line.

Delete Word * Deletes the word at the current position.

Delete to Start of Word * Deletes from the current position to the beginning of
the word.

Delete to End of Word * Deletes from the current position to the end of the
word.

Insert Line Before * Inserts a new blank line before the current line.

Insert Line After * Inserts a new blank line after the current line.

Select All Selects all visible lines.

Convert File  >
  Trim Trailing Whitespace

Strips off spaces and tab characters at end of lines.

Convert File  >
  Leading Spaces to Tabs

Replaces spaces at the beginning of lines with the
appropriate number of tab characters (based on current
tab stop setting).

Convert File  >
  Tabs To Spaces

Replaces all tab characters with the appropriate number
of space characters (based on current tab stop
setting).

Convert File  >
  Line Endings

Changes the line ending style on all lines.

The Search menu

Next Edit Positions at the next edited line beyond the cursor.

Previous Edit Positions at previous edited line before the cursor.
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Find Searches for matching text.

Replace Replaces matching text.

Find Next Finds next occurrence of search string.

Find Previous Finds previous occurrence of search string.

Find in Files Finds search string in multiple files.

Go To Positions at specified line and column.

Toggle Bookmark Places a numbered marker on the current line of the
comparison, numbered from 0 to 9.

Go To Bookmark Repositions at the specified bookmark.

Clear Bookmarks Removes all bookmarks from the comparison.

The View menu

Visible Whitespace Shows or hides visible spaces, tabs.

Line Numbers Shows or hides line numbers.

Syntax Highlighting Shows or hides syntax highlighting.

Display Font * Selects the font to use in editor pane.

Webpages Shows or hides web browser panel that displays the
current file as a webpage.

File Info Shows or hides file information panels at the top of
editor panes.

Toolbar Shows or hides the toolbar.

* Hidden by default.

4.15 Text Patch

Following is a description of the Text Patch commands, in addition to the common
commands.  Most of these commands are available as toolbar buttons.

Pick Tools > Options  and switch to the Toolbars, etc. page to define your own
keyboard shortcuts, and hide or expose commands on the menus and toolbars.
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The Edit menu

Copy Copies selection to the Clipboard.

Select All Selects all visible lines in the current pane.

Select Section Selects all lines in the current section.

The Search menu

Next Difference Positions at next difference text.

Previous Difference Positions at previous difference text.

Next Difference Section Positions at next difference section.

Previous Difference Section Positions at previous difference section.

Find Searches for matching text.

Find Next Finds next occurrence of search string.

Find Previous Finds previous occurrence of search string.

Go To Positions at specified line and column.

Toggle Bookmark Places a numbered marker on the current line of the
comparison, numbered from 0 to 9.

Go To Bookmark Repositions at the specified bookmark.

Clear Bookmarks Removes all bookmarks from the comparison.

The View menu

Visible Whitespace Shows or hides visible spaces, tabs.

Line Numbers Shows or hides line numbers.

Syntax Highlighting Shows or hides syntax highlighting.

Display Font * Selects the font to use in editor panes.

Side-by-side Layout Arranges editor panes left and right of each other.

Over-under Layout Arranges editor panes above and below each other.
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Thumbnail Shows or hides the thumbnail summary of changes at
left of view.

Text Details Shows or hides the text details panel at bottom of
view.

Hex Details Shows or hides the hexadecimal details panel at bottom
of view.

Alignment Details Shows or hides the alignment details panel at bottom of
view.

Ruler Shows or hides the line details ruler.

Toolbar Shows or hides the toolbar.

* Hidden by default.
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5
Command Line Reference

Command line executable files

Executable Meaning

BCompare.exe 

bcompare  

This is the main application.  Only one copy
will run at a time, regardless of how many
windows you have open.  If you launch a
second copy it will tell the existing copy to
start a comparison and exit immediately.

BComp.exe This is a Win32 GUI program.  If launched
from a version control system, it should
work just fine.  If launched from a console
window, the console (or batch file) will not
wait for it.

BComp.com This is a Win32 console program.  It has to
have a console.  If you launch it from one
(or a batch file) that console will wait for
the comparison to complete before
returning.  If you launch it from a version
control system interactively, it will show a
console window while it's waiting.

bcomp  Launch this program from a version control
system because it will wait for the
comparison to complete before returning.

Command line parameters

Notice that each parameter should be enclosed in quotation marks if it might contain a
space.

  Note  Mac and Linux users should use "bcompare" instead of "BCompare.exe".

Parameter Meaning

Named Session Opens the specified session in the
appropriate view.  For example:
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  BCompare.exe "My Session"

Named Workspace Opens the specified saved workspace. 
(see also Managing Workspaces)  For
example:
  BCompare.exe "My Special Workspace
"

Pair of folders Opens a new Folder Compare view with the
specified base folders.  For example:
  BCompare.exe "C:\Left Folder" "C:\
Right Folder"

Pair of files Opens the specified files in the associated
file view.  For example:
  BCompare.exe "C:\Left File.ext"
"C:\Right File.ext"

3 files Opens a Text Merge view with the
specified files in the left, right, and center
panes.  For example:
  BCompare.exe C:\Left.ext C:\Right.
ext C:\Center.ext

4 files Opens a Text Merge view with the
specified files in the left, right, center, and
output panes.  For example:
  BCompare.exe C:\Left.ext C:\Right.
ext C:\Center.ext C:\Output.ext

Script file Automatically executes a list of commands
without using a view.  For example:
  BCompare.exe "@C:\My Script.txt"

- Opens stdin in the appropriate view.  For
example:
  dir | BCompare.exe -

Command line switches

  Note  Mac and Linux users should prefix the switches with "-" instead of "/".

Switch Meaning

/?, /h, /help  Opens the help file to the "Command
Line Reference" page.

  Writes usage information to the
console.

/automerge Automatically merges files without user
interaction unless conflicts are found.

/bds <filename> Prompts to compare against previous
revisions available in the CodeGear RAD
Studio/Borland Developer Studio "__history"
folders.  Add to the IDE Tools menu with "/
BDS $SAVE $EDNAME" as the parameters,
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or use the Beyond Compare IDE Expert from
JED Software, available at www.jed-
software.com.

/closescript Closes the script window on completion. 
Overrides the Close when finished setting
in Tools > Options > Tweaks > Scripts.

/edit Opens a Text Edit view.

/expandall Expands all subfolders during the initial
folder comparison.

/favorleft
/favorright 

Draws non-conflicting changes in the
output from the "favored" side without
coloring or section lines.  For ignored
unimportant conflicts, changes are
automatically taken from the "favored" side
instead of the center.

/filters=<file masks> Uses the specified name filter for the initial
folder comparison.  Separate multiple file
masks with semi-colons.  Surround the
name filter with quotes if it contains
spaces.

/force Writes conflicts to the output with CVS-
style markers if /automerge is present.

/fv=<type>, /fileviewer=<type> Opens a new view of the specified type
which can be any of:
    "Text Compare"
    "Text Merge"
    "Table Compare"
    "Hex Compare"
    "MP3 Compare"
    "Picture Compare"
    "Registry Compare"
    "Version Compare"

/iu, /ignoreunimportant Turns on Ignore Unimportant Differences if
/automerge is present.

/mergeoutput=<filename> Explicitly specifies the merge output file.

/nobackups Prevents the creation of backup files.

/qc=<type>, /quickcompare=<type> Performs a quick comparison of two files
and sets the DOS error level on exit.  The
specified type can be size, crc, or binary

.  If a type is not specified, a rules-based
comparison will be performed.  Error levels
are documented below.

/reviewconflicts Opens a Text Merge view if /automerge is

present and conflicts are found.

/ro, /readonly Disables editing on all sides.

/ro1, /lro, /leftreadonly
/ro2, /rro, /rightreadonly

Disables editing on the respective side.

http://www.jed-software.com/
http://www.jed-software.com/
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/savetarget=<filename> Overwrites the specified file instead of
original file when the file view's Save
command is used.

/silent Causes a script to be processed invisibly,
bypassing the Task Bar entry and Scripting
Status window.  All interaction will be
suppressed, so any unresolved issue that
would normally show a dialog will log an
error instead.

/solo Forces a new instance of the program.

/sync Opens a Folder Sync view.

/title1=<title>, /lefttitle=<title>
/title2=<title>, /righttitle=<title>
/title3=<title>, /centertitle=<title>
/title4=<title>, /outputtitle=<title>

Shows the specified description in the
respective path edit.

/vcs1=<path>, /vcsleft=<path>
/vcs2=<path>, /vcsright=<path>
/vcs3=<path>, /vcscenter=<path>
/vcs4=<path>, /vcsoutput=<path>

Shows the specified version control system
path in the respective path edit unless a
title has been provided.  For a file view,
the specified path is also used to pick the
appropriate file format.

Return codes

Code Meaning

0 Success

1 Binary same

2 Rules-based same

11 Binary differences

12 Similar

13 Rules-based differences

14 Conflicts detected

100 Unknown error

101 Conflicts detected, merge output not
written

102 BComp.exe unable to wait until BCompare.
exe finishes

103 BComp.exe cannot find BCompare.exe

104 Trial period expired

105 Error loading script file

106 Script syntax error

107 Script failed to load folders or files
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6
Scripting Reference

A script is a simple text file containing a list of commands which can control the program
and automatically perform file operations or produce reports.  See also Scripts and Sample
Scripts.

Notation Meaning

| delimits the possible choices

() surrounds a required expression

[] surrounds an optional expression

<> surrounds the description of required user
text

[...] follows an expression that can be repeated

You can use lt in place of left or rt in place of right in any of the commands.

These are the script commands (in alphabetical order):

ATTRIB BEEP COLLAPSE COMPARE COPY COPYTO CRITERIA DATA-REPORT DELETE EXPAND
 FILE-REPORT FILTER FOLDER-REPORT HEX-REPORT LOAD LOG MOVE MOVETO MP3-
REPORT OPTION PICTURE-REPORT REGISTRY-REPORT RENAME SELECT SNAPSHOT SYNC
TEXT-REPORT TOUCH VERSION-REPORT

ATTRIB 

Usage:

attrib (+|-)<attribute set 1> [(+|-)<attribute set 2> [...]]

Where <attribute set> is:

[a][s][h][r]

  The Mac and Linux versions do not support attrib.
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Sets (+) or clears (-) the DOS file attributes in the current selection.  Use a for archive, s
for system, h for hidden and r for read-only.

Examples:

attrib +h
attrib +sh -a

BEEP

Usage:

beep

Beeps the PC speaker.  The beep occurs regardless of the /silent command line switch.

COLLAPSE

Usage:

collapse all
collapse <path 1> [<path 2> [...]]

Collapses all folders or folders with specified paths.  Paths are relative to the base folder
and can not have wildcards.

Example:

collapse "My Folder 1" "My Folder 2"

COMPARE

Usage:

compare [CRC|binary|rules-based]

Compares the contents of the current selection using the compare type.  By default, the
most recent compare type is used.

This command only compares files once.  To change how files are compared after
modification, use CRITERIA.

COPY
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Usage:

copy (left->right|right->left)

Copies the selected files/folders in the direction indicated.

COPYTO

Usage:

copyto [left|right|all] [path:(relative|base|none)] <path>

Copies the selected files/folders on the specified side to the specified path using the path
option.

base keeps the entire folder structure relative to the base folders of all selected items.
relative keeps the minimum relative folder structure of all selected items.
The defaults are all and path:none.

CRITERIA

Usage:

criteria [attrib:<attribute set>] [version] [timestamp[:[<number of
seconds>sec][;IgnoreDST]]] [size|CRC|binary|rules-based] [timezone:
(ignore|(left|right)(+|-)<0..12>)] [follow-symlinks] [ignore-
unimportant]

Where <attribute set> is:

[a][s][h][r]

  The Mac and Linux versions do not support attrib.

Sets all comparison criteria settings.

attrib enables comparisons of the specified DOS file attributes.  Use a for archive, s for
system, h for hidden and r for read-only.
version enables comparisons of version information common in exes and dlls.
timestamp enables timestamp comparisons.
o <number of seconds>sec considers differences within a tolerance of seconds as

matches.
o IgnoreDST considers differences of exactly 1 hour as matches.

size, CRC, binary and rules-based are the possible ways to compare contents.
timezone ignores timezone differences or applies timezone offset to the specified side.
follow-symlinks treats symbolic links and NTFS junctions as the target file or folder,
rather than the link itself.
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ignore-unimportant treats unimportant differences as matches.

Example:

criteria attrib:sh timestamp:2sec;IgnoreDST rules-based timezone:left+6

DATA-REPORT

Usage:

data-report layout:<layout> [options:<options>] [title:<report title>]
output-to:(printer|clipboard|<filename>) [output-options:<options>] [<
comparison>]

Generates a Table Compare report of the currently selected files.

layout controls the report's appearance and can be side-by-side, summary or
interleaved.
options is optional and is used differently for each layout.
o ignore-unimportant treats differences in unimportant text as matches and is available

in all layouts.
o display-all, display-mismatches or display-matches can be used to control which lines

of the comparison are included in all layouts except summary.  By default, display-all
is used.

o line-numbers includes row numbers in the side-by-side layout.

title, output-to, output-options and <comparison> arguments are documented under
Common Report Arguments.

DELETE

Usage:

delete [recyclebin=(yes|no)] (left|right|all)

Deletes the currently selected files/folders on the specified side(s).  The recyclebin
argument only has effect where supported by the operating system.  Network drives,
remote services and archive files do not support it.

EXPAND

Usage:

expand all
expand <path 1> [<path 2> [...]]
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Expands specified subfolders or all subfolders.  Paths are relative to the base folder and
can not have wildcards.  Subfolders must be expanded in order for their contents to be
used by other commands, like SELECT.  expand all will not expand subfolders that have
been excluded from the comparison by File Filter settings.

FILE-REPORT

Usage:

file-report layout:<layout> [options:<options>] [title:<report title>]
output-to:(printer|clipboard|<filename>) [output-options:<options>] [<
comparison>]

Generates a report of the currently selected files based on the type of files processed. 
For example, it will produce a DATA-REPORT for file types associated with a Table
Compare file format.

layout controls the report's appearance and can be side-by-side or summary.
options is optional and is used differently for each layout.
o ignore-unimportant treats differences in unimportant text as matches and is available

in all layouts.
o display-all, display-mismatches or display-matches can be used to control which lines

of the comparison are included in all layouts except summary.  By default, display-all
is used.

o line-numbers includes line numbers in the side-by-side layout.

title, output-to, output-options and <comparison> arguments are documented under
Common Report Arguments.

Example:

file-report layout:side-by-side options:display-mismatches &
    output-to:printer output-options:print-color,wrap-word

FILTER

Usage:

filter <file masks>
filter cutoff:([<|>](<timestamp>|<number of days>[days])|none)
filter attrib:((+|-)<attribute set>|none)
filter size:([<|>]<number>[KB|MB|GB|TB]|none)
filter exclude-protected
filter include-protected

Where <attribute set> is:

[a][s][h][r]
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  The Mac and Linux versions do not support attrib, exclude-protected or include-
protected.

Controls which folders and types of files are compared by using name filtering (file masks),
date filtering (cutoff) or other filtering (attrib, size, exclude-protected or include-
protected).

Name filters include and exclude files and folders based on their names and paths. 
Multiple masks can be separated by semicolons.  To indicate that a mask is an exclude
mask use a leading minus (-).  To indicate that a mask affects folders use a trailing
backslash (\).
cutoff excludes all files older (<) or newer (>) than a timestamp or a number of days
from the current system date (<number of days>days).  By default, cutoff:< is used. 
none can be used to remove date filtering.  The date parsing is fairly lenient but if you
want to be sure it parses correctly, use the format specified by the operating system's
regional settings.  (See Control Panel > Regional and Language Settings.)  The time is
optional and should follow the date (cutoff:"12/31/2012 12:00pm").  Remember to use
quotation marks (" ") whenever a term contains a space.
attrib limits the comparison to files which have an included DOS file attribute (+) and
don't have an excluded attribute (-).  Use a for archive, s for system, h for hidden and r
for read-only.  none can be used to remove attribute filtering.
size excludes all files smaller (<) or larger (>) than the given size.  By default the size is
given in bytes but you can add KB, MB, GB or TB to the end to indicate that the value is
in kilobytes, megabytes, gigabytes or terabytes, respectively.  none can be used to
remove size filtering.
exclude-protected excludes files and folders that have both system and hidden
attributes set.

include-protected includes files and folders that have both system and hidden attributes
set.

Examples:

filter "*.pas;*.dpr;*.dfm"
filter cutoff:<7days
filter cutoff:>"Dec 31, 2012"
filter cutoff:"12/31/2012 12:00pm"
filter attrib:-sh
filter "*.txt;-My Folder\" attrib:+r

FOLDER-REPORT

Usage:

folder-report layout:<layout> [options:<options>] [title:<report title>]
output-to:(printer|clipboard|<filename>) [output-options:<options>]

Generates a folder comparison report of the currently loaded base folders.  Folders are
shown in their current state.  To include subfolders add an expand all command before
this.
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layout controls the report's appearance and can be side-by-side, summary or xml.
options is optional.
o Display filter flags control which files are included in the report.  The possible values

are display-all, display-mismatches, display-no-orphans, display-mismatches-no-
orphans, display-orphans, display-left-newer, display-right-newer, display-left-newer-
orphans, display-right-newer-orphans and display-matches.  By default, display-all is
used.

o Optional columns can be included, separated by commas, in the report by using the

flags column-version, column-size, column-crc, column-timestamp, column-attributes,
column-group, column-owner and column-vcs.  By default, column-size and column-
timestamp are included.  column-none can be used by itself to clear the default
columns.

o Use the flag include-file-links to generate file reports and include links to them in the

folder report.  Only a folder report that is both side-by-side and HTML can use this
flag.

title, output-to and output-options arguments are documented under Common Report
Arguments.

Examples:

folder-report layout:side-by-side &
    options:column-size,column-version,column-timestamp &
    output-to:clipboard output-options:html-color
folder-report layout:xml output-to:"C:\My Report.xml"

HEX-REPORT

Usage:

hex-report layout:<layout> [options:<options>] [title:<report title>]
output-to:(printer|clipboard|<filename>) [output-options:<options>] [<
comparison>]

Generates a Hex Compare report of the currently selected files.

layout controls the report's appearance and can be side-by-side, summary or
interleaved.
options is optional and is used differently for each layout.
o display-all, display-mismatches or display-matches can be used to control which lines

of the comparison are included in all layouts except summary.  By default, display-all
is used.

o line-numbers includes byte addresses in the side-by-side layout.

title, output-to, output-options and <comparison> arguments are documented under
Common Report Arguments.

LOAD
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Usage:

load <session>
load [create:(all|left|right)] <left path> [<right path>]
load <default>

Loads the specified Folder Compare session, the specified base folders or a new Folder
Compare session with default settings (load <default>).  Failure to load a base folder will
cause the script to terminate.

Loading a session causes all that session's settings, except the display filter (show all,
only mismatches, only matches, etc.), to be used.
Loading base folders uses the currently active settings.  By default, the program
default s are used.

The optional create parameter creates a base folder if it doesn't already exist.

Examples:

load "My Session"
load "C:\My Folder" "X:\Your Folder"
load <default>

LOG

Usage:

log [none|normal|verbose] [[append:]<filename>]

Controls how detailed the log is and where the log is stored.

none, normal and verbose determine the amount of detail used in the log.  Logging is
initially disabled and begins when the mode is changed from none.

append: causes logging to add to the file instead of replace it.  By default, the log is
output as Log.txt in the current folder (eg, the Windows "Start In" folder in shortcut
properties).

MOVE

Usage:

move (left->right|right->left)

Moves the selected files/folders in the direction specified.

MOVETO
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Usage:

moveto [left|right|all] [path:(relative|base|none)] <path>

Moves the selected files/folders on the specified side to the specified path using the path
option.

base keeps the entire folder structure relative to the base folders of all selected items.
relative keeps the minimum relative folder structure of all selected items.
The defaults are all and path:none.

MP3-REPORT

Usage:

mp3-report layout:<layout> [options:<options>] [title:<report title>]
output-to:(printer|clipboard|<filename>) [output-options:<options>] [<
comparison>]

Generates a MP3 Compare report of the currently selected files.

layout controls the report's appearance and can be side-by-side or summary.
options is optional and is used differently for each layout.
o ignore-unimportant treats differences in unimportant text as matches and is available

in all layouts.
o display-all, display-mismatches or display-matches can be used to control which lines

of the comparison are included in all layouts except summary.  By default, display-all
is used.

title, output-to, output-options and <comparison> arguments are documented under
Common Report Arguments.

OPTION

Usage:

option stop-on-error
option confirm:(prompt|yes-to-all|no-to-all)

Adjusts script processing options.

stop-on-error makes the script watch for various error conditions, including file
operation errors, and, when one occurs, prompts the user before continuing.

confirm can use prompt, yes-to-all or no-to-all to handle confirmation dialogs that occur
due to file operations.  By default, prompt is used.
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PICTURE-REPORT

Usage:

picture-report layout:<layout> [options:<options>] [title:<report title
>] output-to:(printer|clipboard|<filename>) [output-options:<options>]
[<comparison>]

Generates a Picture Compare report of the currently selected files.

layout controls the report's appearance and can be side-by-side or summary.
options is optional and is used differently for each layout.
o ignore-unimportant treats differences in unimportant text as matches in the summary

layout.

title, output-to, output-options and <comparison> arguments are documented under
Common Report Arguments.

REGISTRY-REPORT 

Usage:

registry-report layout:<layout> [options:<options>] [title:<report title
>] output-to:(printer|clipboard|<filename>) [output-options:<options>]
[<comparison>]

Generates a Registry Compare report of the currently selected files.

layout controls the report's appearance and can be side-by-side or summary.
options is optional and is used differently for each layout.
o ignore-unimportant treats differences in unimportant text as matches and is available

in all layouts.
o display-all, display-mismatches or display-matches can be used to control which lines

of the comparison are included in all layouts except summary.  By default, display-all
is used.

title, output-to, output-options and <comparison> arguments are documented under
Common Report Arguments.

RENAME

Usage:

rename [regexpr <old mask>] <new mask>

Performs a multi-file rename on the current selection using the specified new mask. 
regexpr uses an old mask to perform a regular expression rename.  By default, a DOS-
style rename is performed.
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Examples:

rename *.bak
rename regexpr (...)(...)\.txt $2$1.txt

SELECT

Usage:

select <selection mask 1> [<selection mask 2> [...]]

Where <selection mask> is one of the following:

all
[(left|right|all).][(exact|diff|newer|older|orphan|all).][(files|
folders|all)]
empty.folders

Select controls which files and folders can be operated on.  Only files and folders that
match at least one of the selection masks are part of the selection.

left, right or all limits the selection to the specified side.  By default, all is used.
exact, diff, newer, older, orphan or all limits the selection based on results of
comparison.  diff refers to differences in criteria other than timestamps.  To compare
timestamps use newer or older instead.  Folders must contain only the specified result
type to be affected.  By default, all is used.
files, folders or all limits the selection to files, folders or both.  By default, all is used.

empty.folders is a special selection mask that will select empty folders.

Examples:

select all
select left
select exact
select files
select right.diff
select left.folders
select newer.files right.older.files

SNAPSHOT

Usage:

snapshot [save-crc] [save-version] [expand-archives] [follow-symlinks]
[no-filters] left|right|path:<path> [output:<target>]

Saves a read-only snapshot of the specified folder.
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save-crc calculates CRC's for all files and stores them as part of the snapshot.
save-version stores version information for executable files.
expand-archives stores the contents of archive files in an expanded format.
follow-symlinks stores files and folders pointed to by symbolic links.
no-filters stores all files regardless of the active filename filters.
left, right and path indicate which folder is stored.  left or right will save a snapshot of
one of the loaded base folders and path will save a snapshot of a specified path.
output is optional and determines where the snapshot will be saved.  By default, it will
be saved in the current folder.
o If target is a fully qualified filename, that will be the name of the snapshot.  If target

doesn't have an extension, .bcss will be used.

o If the target isn't included or refers to a folder a filename will be generated based on

the source folder's name and the current system date, eg folder_2012-12-31.bcss.

If necessary an additional number will be added to the generated name to keep it from
overwriting existing snapshots.

Examples:

snapshot save-crc save-version no-filters path:C:\ output:D:\
snapshot left output:"My Snapshot.bcss"

SYNC

Usage:

sync [visible] [create-empty] (update|mirror):(left->right|right->left|
all)

Synchronizes folders by copying and deleting files.  This command does not use the
current selection.

visible enables "Only affect visible files" behavior.  Only files in expanded folders will be
affected.
create-empty enables the "Create empty folders" behavior.
update copies newer and orphan files in the indicated direction, leaving orphans and
newer files on the opposite side unchanged.  Using all as the direction indicates a
bidirectional sync and copies newer and orphan files in both directions.

mirror makes the target folder identical to the source one.  Newer, older, different and
orphaned files are all copied to the destination.  Orphans in the destination are deleted.
The all direction doesn't apply in this context and is not valid.

Example:

sync create-empty mirror:left->right

TEXT-REPORT
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Usage:

text-report layout:<layout> [options:<options>] [title:<report title>]
output-to:(printer|clipboard|<filename>) [output-options:<options>] [<
comparison>]

Generates a Text Compare report of the currently selected files.

layout controls the report's appearance and can be side-by-side, summary, interleaved,
patch, statistics or xml.  Deprecated layouts over-under and composite have been
replaced by interleaved.
options is optional and is used differently for each layout.
o ignore-unimportant treats differences in unimportant text as matches and is available

in all layouts.
o display-all, display-mismatches, display-context or display-matches can be used to

control which lines of the comparison are included in all layouts except summary,
patch and statistics.  By default, display-all is used.

o line-numbers includes line numbers in the side-by-side layout.

o strikeout-left-diffs crosses out left difference lines in the interleaved layout.

o strikeout-right-diffs crosses out right difference lines in the interleaved layout.

o patch-normal, patch-context or patch-unified formats are available in the patch

layout.  By default, patch-normal is used.

title, output-to, output-options and <comparison> arguments are documented under
Common Report Arguments.

The deprecated stats-descriptive option will generate a summary report instead and post
a warning to the log.  The deprecated stats-tabular option is ignored in the statistics
layout: the statistics layout is always tabular (CSV) now.

Examples:

text-report layout:interleaved options:display-context &
    output-to:printer output-options:print-color,wrap-word
text-report layout:patch options:patch-unified &
    output-to:"My Report.txt"

TOUCH

Usage:

touch (left->right|right->left)
touch (left|right|all):(now|<timestamp>)

Copies the timestamps from files on one side to the other or sets the timestamps of all
files on a specified side to the current system time (now) or a specified timestamp.  You
must select files before you can touch them.
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VERSION-REPORT 

Usage:

version-report layout:<layout> [options:<options>] [title:<report title
>] output-to:(printer|clipboard|<filename>) [output-options:<options>]
[<comparison>]

Generates a Version Compare report of the currently selected files.

layout controls the report's appearance and can be side-by-side or summary.
options is optional and is used differently for each layout.
o ignore-unimportant treats differences in unimportant text as matches and is available

in all layouts.
o display-all, display-mismatches or display-matches can be used to control which lines

of the comparison are included in all layouts except summary.  By default, display-all
is used.

title, output-to, output-options and <comparison> arguments are documented under
Common Report Arguments.

Common report arguments

The report commands (data-report, file-report, folder-report, hex-report, mp3-report,
pix-report, registry-report, text-report and version-report) must include information on
where the report should be sent and may include additional information on the output
format.

title controls the title that appears at the top of the report.
output-to controls the output target.  It can be printer, clipboard or a filename.
output-options is optional and is used differently for each output target.
o print-color or print-mono color schemes are available for printer output.  By default,

print-mono is used.
o print-portrait or print-landscape orientations are available for printer output.  By

default, print-portrait is used.
o wrap-none, wrap-character or wrap-word control whether long lines are wrapped. 

printer output can use all three options.  HTML output can use wrap-none and wrap-
word.  By default, wrap-none is used.

o html-color, html-mono or html-custom are required to output as HTML instead of plain

text.  These options are available for clipboard and file outputs.  html-custom requires
the filename or URL of an external style sheet.

<comparison> can either be a session name or a pair of filenames.  The file report will
use the specified comparison instead of the files that have been selected within the
script.  When using a saved session, the comparison type must match the report type
(e.g., a Table Compare session must use data-report or file-report).

Examples:

data-report layout:interleaved output-to:printer &
    output-options:print-color,print-landscape
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file-report layout:summary output-to:clipboard &
    output-options:wrap-word,html-color
text-report layout:patch options:patch-unified &
    output-to:"My Report.txt"
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7
Regular Expression Reference

Regular Expressions are a powerful way to define patterns for searching and matching. 
Beyond Compare allows you to use regular expressions when searching through text, and
when specifying rules for classifying text.  The regular expression support in Beyond
Compare is a subset of the Perl Compatible Regular Expression (PCRE) syntax.

While Regular Expressions can be a complex topic, there are several excellent resources
about them.  One such resource is a book called Master ing Regular Expressions.  Another
excellent resource is Steve Mansour's A T ao of Regular Expressions, a copy of which can
be found at:

      www.scootersoftware.com/RegEx.html

A regular expression is composed of two types of characters:  normal characters and
metacharacters.  When performing a match, metacharacters take on special meanings,
controlling how the match is made and serving as wildcards.  Normal characters always
match against only themselves.  To match against a metacharacter, esc ape it, by
prefixing it with a backslash "\".  There are multiple types of metacharacters, each
detailed below.

Metacharacters - Escape sequences

Escape sequence Meaning

\xnn character with the hex code nn

\x{nnnn} character with the hex code nnnn

\x{F000} character with a null value

\t tab (0x09)

\f form feed (0x0C)

\a bell (0x07)

\e escape (0x1B)

Metacharacters - Predefined classes

Predefined character classes match any of a certain subset of characters.  The following
classes are already defined for you.

http://www.scootersoftware.com/RegEx.html
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Class Meaning

. match any character

\w any alphanumeric character or _

\W any non-alphanumeric character

\d any numeric character (0-9)

\D any non-numeric character

\s any whitespace (space, tab)

You can also construct your own character classes by surrounding a group of characters
in brackets "[]".  The predefined classes (except ".") can be used in the brackets, and if a
dash "-" appears between two characters, it represents a range.  Thus [a-z] would
represent all lowercase letters, and [a-zA-Z] would represent both lower and uppercase
letters.  To include a "-" as part of the class, place it at the beginning or end of the
string.

If the first character within the brackets is a caret "̂ ", then the class represents
everything except the specified characters.  [^a-z] matches on any character that isn't
a lower-case alphabetic character.

Metacharacters - Alternatives

By placing an "|" between two groups of items, alternative matches can be represented. 
a|b will match either a or b.  ab|cd will match "ab" or "cd", but not "ac".  "|" groups
characters from pattern delimiter ("(", "[", or the start of the pattern) to itself and then
again to the end of the pattern.  Alternatives can be placed within parenthesis "()" to
make it obvious what is being matched against, as in a(bc|de)f.  Alternatives are matched
left to right.  bey|beyond will match on bey, even if the string is "beyond".

Metacharacters - Position

The following metacharacters control where the match can occur on a line.  Note: \A
and \Z match the start and end of text respectively, but since Beyond Compare performs
the search on a line by line basis, these have the same effect as ^ and $.

Metacharacter Meaning

^ match only at start of line

$ match only at end of line

Metacharacters - Iterators

Anything in a regular expression can be followed by an iterator metacharacter, which
refers to the item before it.  There are two kinds of iterators - greedy and non-greedy. 
Greedy iterators match as many as they can, non-greedy match as few as they can.

Greedy:
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Metacharacter Meaning

* match zero or more of the preceding
character (equivalent to {0,})

+ match one or more of the preceding
character (equivalent to {1,})

? matches zero or one times (equivalent to
{0,1})

{n} matches exactly n times (equivalent to {n,
n})

{n,} matches n or more times

{n,m} matches at least n but no more than m
times

Non-greedy:

Metacharacter Meaning

*? matches zero or more times

+? matches one or more times

?? matches zero or one time

{n}? matches exactly n times

{n,}? matches at least n times

{n,m}? matches at least n but no more than m
times

Metacharacters - Subexpressions

Parenthesis "()" can also be used to group characters for use with iterators and
backreferences (discussed below).  (bey){4,5} will match between 4 and 5 instances of
"bey".  (abc|[0-9])* will match any combination of "abc" and the digits 0 to 9 (e.g.
"abc5", "679abc" and "abc77abc").

Metacharacters - Back references

Each sequence of characters which is matched within a "()" will be saved as a
subexpression, which you can refer to later with \1 to \9, which refer to the
subexpressions from left to right.  b(.)\1n will match "been" and "boon", but not "bean",
"ben" or "beeen".

Modifiers

Modifiers allow changes to the matching behavior from that point on.  If the modifier is
contained within a subexpression, it affects only that subexpression.  Use (?i) and (?-i) to
control the case sensitivity of matching.

Examples:
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  (?i)Beyond Compare matches both "Beyond Compare" and
"beyond compare"

  (?i)Beyond (?-i)Compare matches "Beyond Compare" and "bEyOnD
Compare", but not "beyond compare"
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8
Glossary

Base folder

The top-most folder on either side of a folder view.  Base folder names appear in the
toolbar path edits above each pane of the comparison.

Child Session

A file session launched from a folder session.

Conflict

In a 3-way merge, a conflict occurs when the same section of text has changes on
both left and right sides.

CRC

CRC (Cyclic Redundancy Check) is a numeric representation of the contents of a file. 
If the CRCs of two files are different, then the contents of those files must be
different.  If the CRCs match, then it is quite likely that the contents match.

CSV

CSV (Comma Separated Values) is a common file layout for representing row and
column data.

File Format

Our term for the collection of settings that characterize a type of file.  For example,
the Java Source file format describes the Java grammar for syntax highlighting and
rules-based comparisons, and stores your tab stop preference for Java source.  File
formats can also specify conversion routines to be run before and after comparisons.

Filter

A setting that limits what is displayed or processed, "filtering out" unneeded content.

Important text
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Text that is important to the comparison.

Line ending style

The pattern of control characters that define the end of each line in a text file. 
Typically, it is CR+LF in Windows/DOS, LF only in Unix, and CR only in Macintosh.

Orphan

Our term for an item that is on one side and not the other in a comparison.

Plug-in

Software accessory that can be 'plugged into' the program for more features.

Profile

A named collection of settings and credentials for remote services such as FTP,
WebDAV, Dropbox and subversion.

Regular Expressions

Formulas for matching strings that follow a pattern.

Rules

Our term for the session settings that control how a comparison is performed.

Section

A contiguous range of lines with differences.

Session

Our term for a comparison task, such as comparing folders or files.  Each session view
is in its own top-level window, or tab on a window.

Skew tolerance

The number of lines Beyond Compare will search forward and backward for a matching
section.

Snapshot

A custom Beyond Compare file that contains folder tree information.  Like a camera
capturing reality at a moment in time, a snapshot file captures the state of a folder so
that the user can compare it to the live folder at some later time, and find what has
changed.

Thumbnail
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In file comparison windows, the (optional) panel on the left with the color-coded
summary of differences.

Timestamp

A timestamp is a file or folder's last modified time.

Tolerance

In Table Compare and Picture Compare, the amount that two cells (or pixels) can
differ before being considered an important difference.  Differences less than or equal
to the tolerance are unimportant differences.

Touch/Touching

The action of setting the timestamp of a file to a specific value.

Unimportant differences

Differences in text that are defined to be unimportant to the comparison.  They may
include whitespace or character case differences, comments or line numbers.

View

An open session (or the Home view) as it appears as a window or on a tab.

Whitespace

The blank space at the beginning and end of lines and between words.  Whitespace is
generally made up of any combination of the 'space' and 'tab' characters.

Workspace

The collection of all open sessions, including the size and position of windows and
tabs.
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9
Support, Ordering and License

For the latest version of Beyond Compare and for other news about the program, visit our
web site at:  www.scootersoftware.com

Technical Support

Please send any comments, suggestions or bug reports to:  support@scootersoftware.
com

Visit our support forums to share problems and ideas:  www.scootersoftware.com/forum

Access our online FAQ and Knowledge Base articles at:  www.scootersoftware.com/kb

Customer Support

The single user license fee for Beyond Compare is $30 (US dollars) for the Standard
edition and $50 for the Pro edition.  The Windows, Mac and Linux versions are licensed
separately, unless you purchase a multi-platform license.  For current information on
multi-user discounts and upgrade policy, please visit our on-line shop at:  www.
scootersoftware.com/shop

If you need help ordering Beyond Compare, contact us at:  sales@scootersoftware.com

For our mailing address and other contact information, visit:  www.scootersoftware.com/
contact

License Agreement

Our License Agreement allows each licensed user to install and use Beyond Compare on
any number of computers.  Read the agreement to understand your rights and obligations
concerning the use of the software.

Third-Party Software

Beyond Compare has been created with the help of a number of open source libraries. 
Source code is available on their respective websites, and any customizations by Scooter
Software can be requested by emailing us at:  support@scootersoftware.com

http://www.scootersoftware.com/
mailto:support@scootersoftware.com
mailto:support@scootersoftware.com
http://www.scootersoftware.com/forum
http://www.scootersoftware.com/kb
http://www.scootersoftware.com/shop
http://www.scootersoftware.com/shop
mailto:sales@scootersoftware.com
http://www.scootersoftware.com/contact
http://www.scootersoftware.com/contact
mailto:support@scootersoftware.com
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License Agreement Website

7-zip www.7-zip.org

Abbrevia tpabbrevia.sourceforge.net

ChsDet chsdet.sourceforge.net

dspack code.google.com/p/dspack

FastcodePatch fastcode.sourceforge.net

FastMM4 www.sourceforge.net/projects/fastmm

Free Pascal www.freepascal.org

GnuWin32 (patch.exe) gnuwin32.sourceforge.net

GraphicEx www.delphi-gems.com/index.php/libs/
graphicex-library

HtmlViewer code.google.com/p/thtmlviewer

HTTPGet www.utilmind.com

Indy indyproject.org/index.en.aspx

Inno Setup jrsoftware.org/isinfo.php

IntLck64 cc.embarcadero.com/Item/22917

Jedi Code Library jcl.sourceforge.net

Lazarus lazarus.freepascal.org

LetsMove github.com/potionfactory/LetsMove

PCRE www.pcre.org

PerlRegEx www.regular-expressions.info/delphi.html

RegExpr regexpstudio.com

TextDiff www.angusj.com/delphi/textdiff.html

WavPack wavpack.com

WiX wixtoolset.org

Xpdf (PdfToText.exe) www.foolabs.com/xpdf/home.html

ZLib www.zlib.org
www.base2ti.com

Beyond Compare was also created with these commercial libraries and applications:

Software Website

cMicroThreads www.eternallines.com/microthreads/index.
html

Delphi www.embarcadero.com

FinalBuilder www.finalbuilder.com

madExcept www.madshi.net

Plasmatech Shell Control Pack www.plasmatech.com

SecureBlackBox www.eldos.com

SMWord www.scalabium.com

http://www.7-zip.org
http://tpabbrevia.sourceforge.net
http://chsdet.sourceforge.net
http://code.google.com/p/dspack
http://fastcode.sourceforge.net
http://www.sourceforge.net/projects/fastmm
http://www.freepascal.org
http://gnuwin32.sourceforge.net
http://www.delphi-gems.com/index.php/libs/graphicex-library
http://www.delphi-gems.com/index.php/libs/graphicex-library
http://code.google.com/p/thtmlviewer
http://www.utilmind.com
http://indyproject.org/index.en.aspx
http://jrsoftware.org/isinfo.php
http://cc.embarcadero.com/Item/22917
http://jcl.sourceforge.net
http://lazarus.freepascal.org
https://github.com/potionfactory/LetsMove
http://www.pcre.org
http://www.regular-expressions.info/delphi.html
http://regexpstudio.com
http://www.angusj.com/delphi/textdiff.html
http://wavpack.com
http://wixtoolset.org
http://www.foolabs.com/xpdf/home.html
http://www.zlib.org
http://www.base2ti.com
http://www.eternallines.com/microthreads/index.html
http://www.eternallines.com/microthreads/index.html
http://www.embarcadero.com
http://www.finalbuilder.com
http://www.madshi.net
http://www.plasmatech.com
http://www.eldos.com
http://www.scalabium.com
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Toolbar 2000 jrsoftware.org/tb2k.php

ZipForge www.componentace.com

http://jrsoftware.org/tb2k.php
http://www.componentace.com
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content comparison     21

copy    

files, folders     22, 23, 32
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cutoff date     76, 80, 84
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load     107

save     107

display filters     18

Dropbox    
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editions (Standard vs Pro)     10

editor     48

editor options     66

error level     157

exchange    

files, folders     22

exclude     28

files by attribute     76, 80, 84

files by date modified     76, 80, 84

files by file size     76, 80, 84

files by name     75, 79, 83

folders by name     75, 79, 83

Explorer context menu     63

external applications     68

- F -

factory defaults     63

file filters     18

File Formats     52

managing     93

file masks     75, 79, 83

filename conversion     103

filter    

by attribute     76, 80, 84

by date modified     76, 80, 84

by file size     76, 80, 84

by name     75, 79, 83

filter presets     67

filters     18

firewall settings     101

Folder Compare    

about     16

commands     109

rules     73

session settings     72

Folder Merge    

about     30

commands     115

rules     77

session settings     76

Folder Sync    

about     33

commands     120

presets     81

rules     81

session settings     80

FTP    

authentication     99

connection settings     101

listing format     102

login     100

profile     99

transfer settings     103

- G -

grammar    

using     52

- H -

Hex Compare    

about     43

commands     137

session settings     91

hints, configuring     68

Home    

commands     109

Home view     13

Home view options     68

HTML output     52

http compare     36

- I -

ignore    

folder structure     18
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files by name     75, 79, 83

folders by name     75, 79, 83
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keyboard shortcuts     68
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limit download/upload speed     103

location of program settings     105

lock session     13
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- M -

menu    

Folder Compare commands     109

Folder Merge commands     115

Folder Sync commands     120

global commands     107

Hex Compare commands     137

Home commands     109

MP3 Compare commands     141

Picture Compare commands     143

Registry Compare commands     146

Table Compare commands     134

Text Compare commands     123

Text Edit commands     152

Text Merge commands     129

Text Patch commands     154

Version Compare commands     149

menu configuration     68

merge    

files, folders     32

session     40

move    

files, folders     22, 24

MP3 Compare    

about     50

commands     141

session settings     91

- N -

new features     9

next difference     38

next difference options     66

- O -

Open With    

configuration     68

options     62, 63

ordering Beyond Compare     183

override    

file formats     74, 78, 82

filename alignment     76, 80, 84

folder alignment     76, 80, 84

- P -

PASV     101

Picture Compare    

about     44

commands     143

options     66

session settings     92

plug-ins     50

portable install     105

previous difference     38

printouts     52

Pro Edition     10

Profiles    

Amazon S3     104

Dropbox     104

FTP     99

managing     99

Subversion     104

WebDAV     104

proxy settings     102

- R -

reconcile differences     20

refresh    

automatic     74, 78, 82

Registry Compare    

about     47

commands     146

session settings     92

regular expressions     176

rename    

files, folders     26

replacements     87

reports     52

- S -

scheduled task     60

scripts    

overview     56

reference     161

samples     58

scheduling     60

selecting folders, files     20
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sessions    

deleting     13

Folder Compare     16

Folder Merge     30

Folder Sync     33

locking     13

managing     13

Picture Compare     44

renaming     13

sharing     68

Table Compare     42

Text Compare     36

Text Merge     40

settings    

how to find     62

location of     105

move to new computer     56

tweaks     62

SFTP    

authentication     99

login     100

shared sessions     68

sharing Beyond Compare on a network     105

sharing sessions     14

shell extension     63

simultaneous connections     101

snapshot    

creating, using     55
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SSL    

certificate     99

clear control channel     101

clear data channel     101

startup options     63

stored settings     105

Subversion    

profile     104

switches, command line     157

synchronize folders     33

syntax highlighting     52
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tab stops     95

tabbed windows    

options     64
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about     42

commands     134

rules     90

session settings     89

tear off tab     12
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Text Compare    

about     36

commands     123

options     66

rules     85

session settings     85

Text Edit    

about     48

commands     152

Text Merge    

about     40

commands     129

rules     88

session settings     87

Text Patch    

about     49

commands     154
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timeout     101

timestamp    

filter by     76, 80, 84

modify     28

timestamps    

compare     73, 77, 81

preserve on upload     103

toolbar configuration     68

touch     28

tweaks     62

- V -

version    

compare version info     73, 77, 81

Version Compare    

about     50

commands     149

session settings     93

- W -

WebDAV     104
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workspace    

auto-load, auto-save     63

- Z -

zip files    

associations     67

comparing     16

handling     74, 78, 82
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