Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2012

    Default Override Text format default for bulk comparison of .TXT files


    I have ~1,000 files to compare (e.g. 2,000 files total), all of which are in identically named pairs and are in .TXT format. However they contain tabulated data and I need to compare using Data Compare so I can assign Key columns to correctly align the data, and apply tolerance to numerical amounts.
    Using Data compare works fine for individual files, and I have saved the data session settings keys etc (with option 'Use for all files within parent session' selected). I also saved the parent File Comparison session afterwards.

    However when I select a large number of reports to compare and select File Compare Report from right click menu, it always defaults to Text Compare. I have gone to to the Folder session settings and set it to Rules Based comparison, but still cannot force the Data Compare for groups.

    I noticed that if I take a couple of file pairs and open in Excel and re-save as .XLS, the File Compare report options seems to switch to Data Compare, so it looks like there is some kind of embedded default somewhere based on the file extensions. However I cannot re-save all 2k files this way.

    The question is, how do I override this default and force BC to use Data Compare in all cases?


    PS - I read a post that stated that the last edited session defaults in the 'Edit Sessions' home window will be used in future comparisons. Does this get overridden by file extension defaults or are these defaults being ignored? There are some weird settings in my corporate file system so its possible the last edited defaults are being lost somehow (e.g. BC tries to save them to a read only location)

  2. #2
    Join Date
    Oct 2007
    Madison, WI



    The session type is determined by the detect File Format. In the Tools menu -> File Formats dialog, you can create a new format (a Data Format) and associate the file mask with *.txt. The topmost file format in the list is the one used first/automatically. So if the *.txt Data Format is higher, .txt files will open with the Data Compare by default. If the *.txt Text format (or default) is first, they will open in the Text Compare Session.

    If you force a file to open in a different session, it will use the topmost format for that session type.

    Does this help make the current behavior make sense. Once the file is open and the format is used, the session settings are applied based on which session was opened.
    Aaron P Scooter Software

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts